Author Topic: RAM usage problem after upgra NEW Avast Version 20.7.2425  (Read 23058 times)

0 Members and 1 Guest are viewing this topic.

Offline Spec8472

  • Avast team
  • Sr. Member
  • *
  • Posts: 261
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #90 on: November 18, 2020, 10:30:14 AM »
Hi Dale5351,
the pool allocation tags from your screen (FMfn, MmSt, NtfF) is normal file-system cache. You can validate this by using some tool to allocate huge amount of memory (like sysinternals testlimit64.exe -v) for example. For 8GB RAM computer, allocate 7GB RAM for example (testlimit64.exe -v 7000). Then you'll see huge decrease of allocations of these tags.

Offline dale5351

  • Jr. Member
  • **
  • Posts: 35
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #91 on: November 18, 2020, 03:47:27 PM »
Thanks for that info.  My win10 computer seems stable, and I will be keeping Avast now.  None of the other top 10 virus programs I tested worked as well for me.

Offline darkwaechter

  • Newbie
  • *
  • Posts: 15
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #92 on: November 19, 2020, 11:19:13 AM »
Is the Problem fixed ?

We ar running Cloudacre with AV
20.8.2615

An the issue still exists.

Still not solved with 20.9.2437.
Maybe in the next release  ::)

Offline cry4dawn

  • Jr. Member
  • **
  • Posts: 48
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #93 on: December 09, 2020, 09:54:22 PM »
Has this issue been fixed completely yet?

Offline darkwaechter

  • Newbie
  • *
  • Posts: 15
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #94 on: December 10, 2020, 12:17:05 PM »
No, still not solved in 20.10.2442 ...  :-[

Offline ncos

  • Newbie
  • *
  • Posts: 3
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #95 on: January 26, 2021, 03:23:27 PM »
Hi,

We are also having a problem similar to this - have logged a ticket with support (we are a business cloudcare customer). The issue we are having is quite frequently throughout the day 'System' will randomly run using between 10% - 30% CPU and the machine will become pretty much unusable (very laggy). It only affects machines that are plugged into the LAN - luckily the majority of staff are working from home at the moment!

When I run Windows Performance Recorder and Analyzer we get aswNetHub.sys!<PDF not found> using a lot of resource - a quick google tells me aswNetHub.sys is Avast Network Security Driver. The majority of our devices are running build 20.8.5684.613

As soon as I uninstall Avast on a machine the problem stops, if I just connect to the wifi the problem stops - are there any fixes for this issue yet?

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 72884
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #96 on: January 26, 2021, 03:28:46 PM »
Hi,

We are also having a problem similar to this - have logged a ticket with support (we are a business cloudcare customer). The issue we are having is quite frequently throughout the day 'System' will randomly run using between 10% - 30% CPU and the machine will become pretty much unusable (very laggy). It only affects machines that are plugged into the LAN - luckily the majority of staff are working from home at the moment!

When I run Windows Performance Recorder and Analyzer we get aswNetHub.sys!<PDF not found> using a lot of resource - a quick google tells me aswNetHub.sys is Avast Network Security Driver. The majority of our devices are running build 20.8.5684.613

As soon as I uninstall Avast on a machine the problem stops, if I just connect to the wifi the problem stops - are there any fixes for this issue yet?
-> https://forum.avast.com/index.php?board=77.0
Win 8.1 [x64] - Avast PremSec 21.11.6787.IBC [UI.679] - EEK - Firefox ESR 91.3 [NS/uBO/PB] - TB 91.3.2
Avast-Tools: Secure Browser 96.0 - Cleanup 21.3 - SecureLine 5.14 - Driver Updater 21.4 - CCleaner 5.87
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline darkwaechter

  • Newbie
  • *
  • Posts: 15
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #97 on: April 09, 2021, 10:41:09 AM »
More than 6 months later, following problem is still not solved  :-\


Hi,
I found the the source of the problem, is the wpad.dat file used to auto define the proxy (or no proxy).

Sorry for delay.
Version 20.8.5684.602  not solved my situation.  Same behavior, soon I connect network cable Avsta start eating all memory.
It happens on some networks, not on others.  Or start after some time.
My network are the culprit? Why special have on these networks?

My test procedure is this:
Disable swap/paging on window, avoid system to use paging, a avast just eat all ram and killed by the kernel (I think). 
Start computer with network cable disconnected (no wifi).
Open taskmanager, and Avast GUI.
Connect network cable and watch rise of memory usage by Avast.

If have some thing on my network causing the Avast memory issue, what can be?
My firewall is a linux machine, very simple, just for NAT, no complex packet filtering, multi internet access and Squid proxy (all most disabled).
I drop all forwarding from offending host. No change.
Dropped all input to firewall. NOW, avast no eating memory.
I opened port 80, and Avast start eating memory again.  What Avast accessing? Check the webserver log.
Avast getting the wpad file for proxy definition on this network. Renamed wpad.dat file, and try again.
Whitout wpad, no problem, avast try to get file, get a 404 and nothing happens.

Code: [Select]
The log on webserver (lighttpd 1.4.19):
10.0.103.91 wpad - [09/Oct/2020:09:36:43 -0300] "GET /wpad.dat HTTP/1.1" 200 94 "-" "Mozilla/5.0 AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.3.3626.1895 Safari/537.36 Avastium (20.8.2432)"

wpad.dat content:

function FindProxyForURL(url, host)
         return "DIRECT";
}

I hope this information helps to solve the problem.

Tanks, Paulino.

I confirm, it comes from the proxy !

Disabling the option "Automatically detect settings" of proxy under Windows, will no more cause the memory leak.
Activating it again, and Avast eats again all memory ...



Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 72884
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #98 on: April 10, 2021, 09:21:37 AM »
More than 6 months later, following problem is still not solved  :-\
1. Enable debug logging (Menu > Settings > General > Troubleshooting > Enable debug logging) and reproduce the issue.
2. Follow instructions: https://support.avast.com/article/33/ and post the File-ID or name of the Support-File here afterwards.
Win 8.1 [x64] - Avast PremSec 21.11.6787.IBC [UI.679] - EEK - Firefox ESR 91.3 [NS/uBO/PB] - TB 91.3.2
Avast-Tools: Secure Browser 96.0 - Cleanup 21.3 - SecureLine 5.14 - Driver Updater 21.4 - CCleaner 5.87
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline darkwaechter

  • Newbie
  • *
  • Posts: 15
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #99 on: April 12, 2021, 10:41:21 AM »
More than 6 months later, following problem is still not solved  :-\
1. Enable debug logging (Menu > Settings > General > Troubleshooting > Enable debug logging) and reproduce the issue.
2. Follow instructions: https://support.avast.com/article/33/ and post the File-ID or name of the Support-File here afterwards.

ID : 02PFY

Steps to trigger the problem in all cases :
- Disable the "Automatically detect settings" of Proxy under Windows (otherwise I cannot update Avast 20.7 to a newer version).
- Update Avast to the latest version or to any version newer than 20.7.
- Enable again the "Automatically detect settings" of Proxy.
- Open Avast GUI -> RAM usage increases quickly to 100%, pagefile will then saturated the disk and computer finally crashes.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 72884
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #100 on: April 12, 2021, 10:56:35 AM »
More than 6 months later, following problem is still not solved  :-\
1. Enable debug logging (Menu > Settings > General > Troubleshooting > Enable debug logging) and reproduce the issue.
2. Follow instructions: https://support.avast.com/article/33/ and post the File-ID or name of the Support-File here afterwards.
ID : 02PFY

Steps to trigger the problem in all cases :
- Disable the "Automatically detect settings" of Proxy under Windows (otherwise I cannot update Avast 20.7 to a newer version).
- Update Avast to the latest version or to any version newer than 20.7.
- Enable again the "Automatically detect settings" of Proxy.
- Open Avast GUI -> RAM usage increases quickly to 100%, pagefile will then saturated the disk and computer finally crashes.
Hi, I forwarded it, let's see...
Win 8.1 [x64] - Avast PremSec 21.11.6787.IBC [UI.679] - EEK - Firefox ESR 91.3 [NS/uBO/PB] - TB 91.3.2
Avast-Tools: Secure Browser 96.0 - Cleanup 21.3 - SecureLine 5.14 - Driver Updater 21.4 - CCleaner 5.87
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline petr blatny

  • Avast team
  • Jr. Member
  • *
  • Posts: 77
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #101 on: April 12, 2021, 12:06:43 PM »
Hello, I'm really sorry the delay. Issue is not directly in our code (3td party lib). We are testing the new build right now. If everything goes well it should be ready for beta 21.5. I know it is still pretty far. But we need to test it properly (few weeks in internal builds).

Petr

Offline darkwaechter

  • Newbie
  • *
  • Posts: 15
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #102 on: April 13, 2021, 10:51:26 AM »
Hello, I'm really sorry the delay. Issue is not directly in our code (3td party lib). We are testing the new build right now. If everything goes well it should be ready for beta 21.5. I know it is still pretty far. But we need to test it properly (few weeks in internal builds).

Petr

Thank you for the information !

I made some more tests, and I can confirm that Adobe Creative Cloud Desktop has exactly the same issue (also since some months).
Maybe they use the same third party library ::)

Will now wait your beta.

Offline darkwaechter

  • Newbie
  • *
  • Posts: 15
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #103 on: May 20, 2021, 05:12:53 PM »
Hello,

On one of concerned computer, Avast has accidentally upgraded to the latest release 21.4 and I noticed that the memory problem seems to no more occur.

Can you confirm that it is solved in this version ?

Offline darkwaechter

  • Newbie
  • *
  • Posts: 15
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #104 on: October 28, 2021, 05:14:36 PM »
For information, the problem did not occur since the 21.4 version ;)

Unfortunately, other software are now more and more concerned with the same issue.
Adobe Creative Cloud Desktop was the first were we identified it, and it is still not fixed !
Then it was Avast, which is now solved.

Meantime, Adobe InDesign is also concerned and not fixed.
And the latest version of Adobe Reader (october 2021) is now also concerned !
Edit : for Adobe Reader, it seams that the problem concerns the 64 bits version.

On the other hand, Google Driver Desktop has a very similar problem.

As you fixed or bypassed the problem, do you know where it comes from ?
From Avast itself ? Or from a third party library / framework ?

Better, could you directly inform Adobe, Microsoft or Google to help them for solving ?
« Last Edit: November 25, 2021, 09:03:19 AM by darkwaechter »