Author Topic: BETA version 14.6 with support for BigSur  (Read 1211 times)

0 Members and 1 Guest are viewing this topic.

Offline lukas.hasik

  • Avast team
  • Advanced Poster
  • *
  • Posts: 895
  • Product manager of Mac AV and Cleanup
BETA version 14.6 with support for BigSur
« on: September 29, 2020, 11:31:04 AM »
There is new version 14.6 of Avast Security for Mac available for Beta users. You can install it from links bellow.
 
What's new?
  • Added support for BigSur, macosx 11 - real time protection kernel extensions rewritten to system extension
  • New setup wizard - to help users to setup their macosx to get the most protection working. Necessary because the system UX flows sucks. I cannot belive that flows like "Allow kernel/system extensions" or "Full System Access" were designed by Apple...
  • Uninstallation survey - let us know why you are uninstalling
  • Smart Scan extended with performance functionality

While the list may seems short we really had to rewrite the whole approach to real time protection aka shields. If you face any issues with browsing internet, playing videos or anytime when you have a feeling that something is wrong please let us know.

Download it from direct link - http://mac-av.u.avcdn.net/mac-av/10_10/beta/AAFM/avast_security_online.dmg
Technical change log - http://mac-av.u.avcdn.net/mac-av/10_10/beta/AAFM/changelog.html
« Last Edit: September 29, 2020, 09:23:14 PM by MartinZ »
Quality is also a feature.

Offline DarylW

  • Newbie
  • *
  • Posts: 2
Re: BETA version 14.6 with support for BigSur
« Reply #1 on: September 30, 2020, 11:09:51 PM »
Cannot login to my account or activate with this version, otherwise seems to have shields up.

Offline DarylW

  • Newbie
  • *
  • Posts: 2
Re: BETA version 14.6 with support for BigSur
« Reply #2 on: September 30, 2020, 11:12:26 PM »
Also, running Smart Scan causes app to crash.

Offline lukas.hasik

  • Avast team
  • Advanced Poster
  • *
  • Posts: 895
  • Product manager of Mac AV and Cleanup
Re: BETA version 14.6 with support for BigSur
« Reply #3 on: October 01, 2020, 10:58:42 AM »
Cannot login to my account or activate with this version, otherwise seems to have shields up.
Any error message? Afair, there were no changes in this area of functionality...
Quality is also a feature.

Offline tomerV

  • Newbie
  • *
  • Posts: 2
Re: BETA version 14.6 with support for BigSur
« Reply #4 on: October 16, 2020, 02:11:20 PM »
Hi, When I had avast after I updated to bigsur, it didn't work, so I deleted it.
But now when I try to install avast, it says that I already have Avast Installed (But I don').
I'll add screenshots...

Thanks in advance, Tomer.

Offline lukas.hasik

  • Avast team
  • Advanced Poster
  • *
  • Posts: 895
  • Product manager of Mac AV and Cleanup
Re: BETA version 14.6 with support for BigSur
« Reply #5 on: October 16, 2020, 02:46:17 PM »
Hi, When I had avast after I updated to bigsur, it didn't work, so I deleted it.
But now when I try to install avast, it says that I already have Avast Installed (But I don').
I'll add screenshots...

Thanks in advance, Tomer.
there must be some remnants of Avast. Please follow Jakub's recommendations at https://forum.avast.com/index.php?topic=221972.msg1480656#msg1480656
Let us know if it helps.
Quality is also a feature.

Offline lukas.hasik

  • Avast team
  • Advanced Poster
  • *
  • Posts: 895
  • Product manager of Mac AV and Cleanup
Re: BETA version 14.6 with support for BigSur
« Reply #6 on: October 16, 2020, 03:04:29 PM »
FYI - 14.6 is available as regular version now https://forum.avast.com/index.php?topic=210570.0
Please note that it's not available at Avast's website yet (next week).
Quality is also a feature.

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 67393
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: BETA version 14.6 with support for BigSur
« Reply #7 on: October 16, 2020, 03:12:56 PM »
Nice, thanks Lukas. :)
Win 8.1 [x64] - Avast PremSec 20.9.2434.Beta#2 [UI.573] - CC 5.72 - EEK - FF ESR 78.4 [NS/AOS/uBO/PB] - TB 78.4 - SB/CP/SL/DU.B
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline tomerV

  • Newbie
  • *
  • Posts: 2
Re: BETA version 14.6 with support for BigSur
« Reply #8 on: October 16, 2020, 03:17:48 PM »
Hi, When I had avast after I updated to bigsur, it didn't work, so I deleted it.
But now when I try to install avast, it says that I already have Avast Installed (But I don').
I'll add screenshots...

Thanks in advance, Tomer.
there must be some remnants of Avast. Please follow Jakub's recommendations at https://forum.avast.com/index.php?topic=221972.msg1480656#msg1480656
Let us know if it helps.

Hi, Thanks! It worked!

Offline happygerbster

  • Newbie
  • *
  • Posts: 1
Re: BETA version 14.6 with support for BigSur
« Reply #9 on: October 16, 2020, 05:45:04 PM »
So I just installed this today and it crashes my macbook completely:
- everything becomes unresponsive
- the macbook turns itself off instantly
- after boot i first get a message that the computer shut itself down because of an error (apple logo) before it proceeds to boot
- after boot the same as above repeats
- removing avast fixed the issue, i suspect its the kext files

Good to know, i also have a couple of other kexts installed; one is from Tripmode, and another one is from VirtualBox

Offline lukas.hasik

  • Avast team
  • Advanced Poster
  • *
  • Posts: 895
  • Product manager of Mac AV and Cleanup
Re: BETA version 14.6 with support for BigSur
« Reply #10 on: October 20, 2020, 01:47:46 PM »
Hi happygerbster,
my bet is that there is some incompatibility between Tripmode and our web shield. I doubt that there is any issue with VirtualBox as we are using it as well ;)
Would you mind to help to prove it? However it would require you to install Avast again after you uninstall Tripmode. If everything works fine than there is probably some hiccup between these two products :(
One more question - did the issue appeared on BigSur or older macosx?

Thank you for sharing your experience with us!
Lukas


So I just installed this today and it crashes my macbook completely:
- everything becomes unresponsive
- the macbook turns itself off instantly
- after boot i first get a message that the computer shut itself down because of an error (apple logo) before it proceeds to boot
- after boot the same as above repeats
- removing avast fixed the issue, i suspect its the kext files

Good to know, i also have a couple of other kexts installed; one is from Tripmode, and another one is from VirtualBox
Quality is also a feature.