Author Topic: Forum software needs update  (Read 14038 times)

0 Members and 1 Guest are viewing this topic.

dk70

  • Guest
Re: Forum software needs update
« Reply #30 on: October 02, 2006, 04:29:01 AM »
May be he has taken a calculated risk and is ready with 1.1 RC3 (considered very stable) and backup of old data? Just more convinient to save power for 1.1 update.