Author Topic: New beta version 20.10.2442  (Read 4110 times)

0 Members and 1 Guest are viewing this topic.

Offline jan.svoboda

  • Avast team
  • Full Member
  • *
  • Posts: 101
New beta version 20.10.2442
« on: December 07, 2020, 05:58:23 PM »
Hi everyone,

I'm glad to announce that new beta version is ready - 20.10.2442 (build 20.10.5824).

What's new
Final tuning before release

Download links
Avast free https://bits.avcdn.net/productfamily_ANTIVIRUS/insttype_FREE/platform_WIN/installertype_ONLINE/build_BETA
Avast premium https://bits.avcdn.net/productfamily_ANTIVIRUS/insttype_APR/platform_WIN/installertype_ONLINE/build_BETA

Enjoy this beta!
We are looking forward to your feedback.

AVAST Team

Offline strakl

  • Sr. Member
  • ****
  • Posts: 226
Re: New beta version 20.10.2442
« Reply #1 on: December 07, 2020, 06:02:32 PM »
Thanks for the new beta, testing asap.

Offline strakl

  • Sr. Member
  • ****
  • Posts: 226
Re: New beta version 20.10.2442
« Reply #2 on: December 07, 2020, 06:31:19 PM »
No issues so far.

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6908
  • When you think you know, Think Again
Re: New beta version 20.10.2442
« Reply #3 on: December 07, 2020, 11:46:16 PM »
In program update on 2 OS's
Running smoothly, no noticed issues
Thanks
***HP ENVY 15K LT W10 Pro 21H1 64Bit/750GB HD/16GB Ram/Avast Premium 21.5.2470b/Secureline VPN v.5.12.5576b/ADU v.21.1b/ASB v.91.0b/ACP 21.1b/SANDBOXIE-plus/MailWasherPRO
**HP Compaq 8510p LT W10 Pro 20H2 64Bit/1TB HD/8GB Ram/Avast Premium 21.5.2470b/ADU v.21.1b/ACP 21.1b/SANDBOXIE/MailWasherPRO/HotSpot Shield
     
RIP*Dell Inspiron XPsp4 PRO 32Bit/Avast(since 2002)18.8.2356/WP/Comodo FW 3.14/Secureline/Comodo IceDragon v.40
LAYERED SECURITY SOFTWARE

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 70641
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: New beta version 20.10.2442
« Reply #4 on: December 08, 2020, 07:50:40 AM »
Thanks Jan, testing it asap...

• Had to reboot twice for the splash screen to show up and still no details
• Else, no noticeable issues, the new beta is running smooth here (so far)
• Side note, some additional data has been sent via AvBugReport
« Last Edit: December 08, 2020, 09:35:45 AM by Asyn »
Win 8.1 [x64] - Avast PremSec 21.5.6354.BCi [UI.646] - EEK - Firefox ESR 78.11 [NS/uBO/PB] - TB 78.11
Avast-Tools: Secure Browser 91.0 - Cleanup 21.1 - SecureLine 5.12 - Driver Updater 21.1 - CCleaner 5.82
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Online NON

  • Japanese User
  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 4796
  • Whatever will be, will be.
Re: New beta version 20.10.2442
« Reply #5 on: December 08, 2020, 02:02:04 PM »
Thanks for the new beta :)
Main: Win10 Pro 20H2 64bit / Core i5-7400 3.0GHz / 16GB RAM / Avast 21 Premier Beta / (looking for firewall...)
Mobile: Win10 Pro 20H2 64bit / Core i5-3340M 2.7GHz / 8GB RAM / Avast 21 Free / Windows Firewall Control

Avast の設定について解説しています。よろしければご覧ください。

Offline darkwaechter

  • Newbie
  • *
  • Posts: 14
Re: New beta version 20.10.2442
« Reply #6 on: December 08, 2020, 06:03:57 PM »
Still have following memory leak since 20.7 ...

Hi,
I found the the source of the problem, is the wpad.dat file used to auto define the proxy (or no proxy).

Sorry for delay.
Version 20.8.5684.602  not solved my situation.  Same behavior, soon I connect network cable Avsta start eating all memory.
It happens on some networks, not on others.  Or start after some time.
My network are the culprit? Why special have on these networks?

My test procedure is this:
Disable swap/paging on window, avoid system to use paging, a avast just eat all ram and killed by the kernel (I think). 
Start computer with network cable disconnected (no wifi).
Open taskmanager, and Avast GUI.
Connect network cable and watch rise of memory usage by Avast.

If have some thing on my network causing the Avast memory issue, what can be?
My firewall is a linux machine, very simple, just for NAT, no complex packet filtering, multi internet access and Squid proxy (all most disabled).
I drop all forwarding from offending host. No change.
Dropped all input to firewall. NOW, avast no eating memory.
I opened port 80, and Avast start eating memory again.  What Avast accessing? Check the webserver log.
Avast getting the wpad file for proxy definition on this network. Renamed wpad.dat file, and try again.
Whitout wpad, no problem, avast try to get file, get a 404 and nothing happens.

Code: [Select]
The log on webserver (lighttpd 1.4.19):
10.0.103.91 wpad - [09/Oct/2020:09:36:43 -0300] "GET /wpad.dat HTTP/1.1" 200 94 "-" "Mozilla/5.0 AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.3.3626.1895 Safari/537.36 Avastium (20.8.2432)"

wpad.dat content:

function FindProxyForURL(url, host)
         return "DIRECT";
}

I hope this information helps to solve the problem.

Tanks, Paulino.

I confirm, it comes from the proxy !

Disabling the option "Automatically detect settings" of proxy under Windows, will no more cause the memory leak.
Activating it again, and Avast eats again all memory ...


« Last Edit: January 19, 2021, 05:46:21 PM by darkwaechter »