Author Topic: Avast/Exchange/SMTP Issue  (Read 31161 times)

0 Members and 1 Guest are viewing this topic.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast/Exchange/SMTP Issue
« Reply #15 on: November 15, 2006, 07:47:16 PM »
Sounds like related to this: http://support.microsoft.com/default.aspx?scid=kb;en-us;299046

Try putting the Exchange M: drive (it's M: on your server, too, right?) to the list of Standard Shield's scan exceptions.

I.e. add something like

M:\*

(double-click avast tray icon, select "Details >>", double-click Standard Shield, go to the "Advanced" page and add it to the list).


Cheers
Vlk
If at first you don't succeed, then skydiving's not for you.

scrimpyd

  • Guest
Re: Avast/Exchange/SMTP Issue
« Reply #16 on: November 15, 2006, 08:09:49 PM »
 ;D
Thanks.

I added that to the list. I will let you know what happens.


dan

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast/Exchange/SMTP Issue
« Reply #17 on: November 15, 2006, 08:22:48 PM »
OK, thanks.

BTW you (scrimpyd) and twilson are both with the same "company"? That is, you're both refering to the same servers? :)

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

scrimpyd

  • Guest
Re: Avast/Exchange/SMTP Issue
« Reply #18 on: November 15, 2006, 09:04:11 PM »
Yes we are in the same company- The College of Southern Idaho.
We are even in the same office. :)

So far we don't see any errors in our event log on the server running Avast. We will keep an eye on it. The DCOM error I posted we only saw on boot up. When I get a chance I will reboot that server to see if that DCOM error goes away.

dan
« Last Edit: November 15, 2006, 09:05:56 PM by scrimpyd »

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast/Exchange/SMTP Issue
« Reply #19 on: November 15, 2006, 09:55:00 PM »
OK, let's see how it evolves. The change that was made to the modified DLL is quite subtle but may actually be the culprit (let's hope so).

BTW how many messages has the service scanned so far?
If at first you don't succeed, then skydiving's not for you.

scrimpyd

  • Guest
Re: Avast/Exchange/SMTP Issue
« Reply #20 on: November 15, 2006, 10:52:53 PM »
So far its doing good.
In the last 3.5 hours the 'MS SMTP 200/2003 Provider' has processed 6231 emails.
The 'Exchange 2000/2003 Provider' has precessed 1021821 while it has been scanning the Exchange mail store.
No errors in the event log. We will let it run until something happens.

Everyone here is curious about what the change in the file is.

Thanks
dan
« Last Edit: November 15, 2006, 11:18:40 PM by scrimpyd »

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast/Exchange/SMTP Issue
« Reply #21 on: November 15, 2006, 11:36:46 PM »
Glad to hear that... Fingers xed.  :)

As about the change, actually, the modification consisted only in exactly 6 characters in the source code ;D But the strange thing is, a lot of MSDN samples actually use this code (the original version), so if this proves to be the culprit I guess MS will have to update quite a few of its pages...


Cheers
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast/Exchange/SMTP Issue
« Reply #22 on: November 16, 2006, 06:33:25 PM »

Any news on the current status? ;)
If at first you don't succeed, then skydiving's not for you.

scrimpyd

  • Guest
Re: Avast/Exchange/SMTP Issue
« Reply #23 on: November 16, 2006, 06:43:15 PM »
Here are some new stats from our server:

In the last 23 hours the 'MS SMTP 200/2003 Provider' has processed 28500 emails.
The 'Exchange 2000/2003 Provider' has precessed 2872451 emails.

Through the night the server ran with out any problems. There are no errors in the event viewer.  So far it seems to be working. - Knock on wood!   ;D

We will wait until Monday before we put Avast back on our Front-end OWA Server and the other cluster node.  We don't want any issues over the weekend.

dan

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast/Exchange/SMTP Issue
« Reply #24 on: November 16, 2006, 06:56:38 PM »
Great, thanks for that.
Let's wait till Monday. :)
If at first you don't succeed, then skydiving's not for you.

gadeem0517

  • Guest
Re: Avast/Exchange/SMTP Issue
« Reply #25 on: November 16, 2006, 10:47:04 PM »
Good news.  Thanks Scrimpyd for testing

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast/Exchange/SMTP Issue
« Reply #26 on: November 18, 2006, 10:01:27 AM »
Just got back home from Redmond.

Any news on this issue (from Idaho)?


Thanks :)
Vlk
If at first you don't succeed, then skydiving's not for you.

scrimpyd

  • Guest
Re: Avast/Exchange/SMTP Issue
« Reply #27 on: November 19, 2006, 06:23:33 AM »
Vlk, hope you had a good trip.

Well so far the stats are:
In the last 3 days 11 hours the 'MS SMTP 200/2003 Provider' has processed 101419 emails.
The 'Exchange 2000/2003 Provider' has precessed 3009627 emails.

No errors in the event logs from exchange or the cluster services.

dan

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast/Exchange/SMTP Issue
« Reply #28 on: November 19, 2006, 02:34:10 PM »
Very good, thanks for keeping us updated.

Hopefully, it will work flawlessly on the cluster as well...

You said that before applying the patch, it usually crashed after a couple of hours, right?


Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast/Exchange/SMTP Issue
« Reply #29 on: November 20, 2006, 09:12:08 PM »
Still everything OK? knock, knock...

:)
If at first you don't succeed, then skydiving's not for you.