Author Topic: Configuration with Spam Off  (Read 6356 times)

0 Members and 1 Guest are viewing this topic.

Offline EVdB

  • Jr. Member
  • **
  • Posts: 49
  • Brabantse Leeuw
Configuration with Spam Off
« on: January 28, 2004, 10:54:45 PM »
Hi,

:) Recently I trashed NIS2004 for Avast Professional 4.1.335 and I like it. (Configuration: XP Pro - Sygate Pro).  :-[ Still have to clean the remains of the so called uninstall function of Norton.

I do however have some questions concerning the setup of a spamfilter.

Spam Off by Astonsoft
Pop3 must be set: 127.0.0.1 (same as Avast)
Username: name/Pop3 server

 ??? However for Avast I have to use the # sign.
How can I let them work together because it's giving me a headache from trying.

But it's also using port 110 and port 25! In Spam Off you can however change the Pop3 port settings.
I know that I've have to change the Avast-ini settings, but I don't see how to do this and what commands I should use. Also what should be put in the e-mail client. The help-file included in Avast doesn't give me a clue about what I should do. I'm not that technical.

I've read a lot on this forum, but nothing which brings me closer to a solution.

Can someone help me with this?

Oh yes, almost forgot: I'm using Pocomail & The Bat. I would like to configure them both. Once I know how to do this, I won't forget.

Thanks in advance!

 ;) Eric

Offline Culpeper

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1187
Re:Configuration with Spam Off
« Reply #1 on: January 29, 2004, 02:55:38 AM »
In your email client you can try changing your User ID to yourname#pop.yourisp.com@127.0.0.1

Also, you may need to change the port numbers for your email client and your spam program.  I use SpamPal but the configuration should be similar.  My email client incoming port is set for 1110 and my spam program incoming port is set for 111.  Avast uses 110 by default.  

However, Avast, my email client, and spam program are set for port 25 for outgoing.
« Last Edit: January 29, 2004, 02:56:28 AM by Culpeper »
The wind in the wires made a tattletale sound
And a wave broke over the railing
And every man knew, as the Captain did, too,
T'was the witch of November come stealing.

Offline EVdB

  • Jr. Member
  • **
  • Posts: 49
  • Brabantse Leeuw
Re:Configuration with Spam Off
« Reply #2 on: January 29, 2004, 03:18:52 AM »
Hi Culpeper,

:) Thanks for replying so quickly.
Quote
In your email client you can try changing your User ID to yourname#pop.yourisp.com@127.0.0.1
Tried your suggestion, but no way to make it work.

Quote
Also, you may need to change the port numbers for your email client and your spam program.  I use SpamPal but the configuration should be similar.  My email client incoming port is set for 1110 and my spam program incoming port is set for 111.  Avast uses 110 by default.
Do I have to change anything in the ini-file?
My settings are:
DefaultPopServer=POP3
DefaultSmtpServer=SMTP
SmtpListen=127.0.0.1:26
PopListen=127.0.0.1:111

Which POP3 portnumber do I have to set for Spam Off and which one for my email client.

It's not the same as SpamPal, because I already saw this on the forum. It's the dash that must be included as mentionned above or maybe I'm doing something wrong here.

Sorry for troubling you with this puzzle  ???

Any further suggestions are always welcome!

 ;) Thank you in advance.

Eric

Offline Culpeper

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1187
Re:Configuration with Spam Off
« Reply #3 on: January 29, 2004, 03:37:56 AM »
Leave the Avast4.ini alone.  Let it use 110 and 25 by default.  I guess you already tried changing the "@" with "/" in your email client user id?
The wind in the wires made a tattletale sound
And a wave broke over the railing
And every man knew, as the Captain did, too,
T'was the witch of November come stealing.

Offline Culpeper

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1187
Re:Configuration with Spam Off
« Reply #4 on: January 29, 2004, 03:58:14 AM »
After browsing through Spam Off help files http://www.spamoff.com/help/  it may help to change the Avast server settings to localhost (127.0.0.1)

Here is a thread with some examples of the Avast4.ini settings to give you an idea.

Also, have you posted on the Spam Off forums about this.

http://www.astonsoft.com/spamoff_forum/

The wind in the wires made a tattletale sound
And a wave broke over the railing
And every man knew, as the Captain did, too,
T'was the witch of November come stealing.

Offline EVdB

  • Jr. Member
  • **
  • Posts: 49
  • Brabantse Leeuw
Re:Configuration with Spam Off
« Reply #5 on: January 29, 2004, 04:01:52 AM »
Hi Culpeper,
Quote
I guess you already tried changing the "@" with "/" in your email client user id?
I've tried everything, but your idea about yourname#pop.yourisp.com@127.0.0.1 and I tried several combinations on your suggestion.

 ;D By accident I stumbled on the solution:

In case others are interested, I'll post it here:

I've set Spam off on POP3=111
and the following settings for my e-mail client:
Server = 127.0.0.1:111
Username = User/POP3#127.0.0.1

Quote
Leave the Avast4.ini alone.  Let it use 110 and 25 by default.
Doesn't that interfere with Avast? It isn't clearly indicated in the help file? Better would be some real examples (= FAQ's). Sure there's enough material to use from this forum.

 ;D I'm glad I finally struggled through with your much appreciated help.

 ;) Thanks again for everything.

Eric

Offline Culpeper

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1187
Re:Configuration with Spam Off
« Reply #6 on: January 29, 2004, 04:16:20 AM »
Cool! :D
The wind in the wires made a tattletale sound
And a wave broke over the railing
And every man knew, as the Captain did, too,
T'was the witch of November come stealing.

Offline EVdB

  • Jr. Member
  • **
  • Posts: 49
  • Brabantse Leeuw
Re:Configuration with Spam Off
« Reply #7 on: January 29, 2004, 04:18:10 AM »
Hi Culpeper,

You replied during my above post, so I didn't know.
Quote
Also, have you posted on the Spam Off forums about this.
http://www.astonsoft.com/spamoff_forum/
I've looked at this forum, but frankly there isn't much respons. It's like there's nobody home  :(

:) Not like here where there's always been a lot of activity.

Anyhow it's solved and working and scanning. I'm a happy man and grateful to you because you gave me some ideas to try out.

 ;D You're very helpfull in these matters and that's what counts for us beginners. We'll learn in time with ups and downs.

 ;) Till later. I'll keep monitoring this forum in case I can learn something new.

 :D Eric

Offline Culpeper

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1187
Re:Configuration with Spam Off
« Reply #8 on: January 29, 2004, 04:24:17 AM »
Thanks for posting the solution so others can use it.  Welcome to Avast forums.
« Last Edit: January 29, 2004, 04:24:32 AM by Culpeper »
The wind in the wires made a tattletale sound
And a wave broke over the railing
And every man knew, as the Captain did, too,
T'was the witch of November come stealing.

Offline Datagg

  • Sr. Member
  • ****
  • Posts: 219
  • Perceive things that you cant see
    • Girlfriends Lingerie
Re:Configuration with Spam Off
« Reply #9 on: January 29, 2004, 01:18:43 PM »
Yah cul rules..helped me out alot also...This is a good place, and im happy to help all when i can..

Thanks..
X64
GA-K8N-SLI
AMD 64 3500+
Nvidia Nforce4
e-Geforce 6800GT - PCI-E 256M
Gig of PC3200 DDR2

Offline EVdB

  • Jr. Member
  • **
  • Posts: 49
  • Brabantse Leeuw
Re:Configuration with Spam Off
« Reply #10 on: January 29, 2004, 07:05:45 PM »
Hi Culpeper,

??? After I started my computer this evening Spam Off gave me an error message, so all mentionned above is incorrect.
Quote
After browsing through Spam Off help files http://www.spamoff.com/help/  it may help to change the Avast server settings to localhost (127.0.0.1)
I look into it and changed everything, so now after rebooting everything is fine again. No error messages whatsoever.

Here are the correct settings:

Avast ini-file:
DefaultSmtpServer=127.0.0.1
DefaultPopServer=127.0.0.1
PopListen=127.0.0.1:111
SmtpListen=127.0.0.1:26

Spam Off incoming port settings: 110

Email client: Pocomail settings
Server POP3: 127.0.0.1:111
Username: Name/POP3#127.0.0.1
Server SMTP: 127.0.0.1:26

For other email clients where you can change the ports, here the settings for ex. The Bat
Server POP3: 127.0.0.1   Port: 111
Username: Name/POP3#127.0.0.1
Server SMTP: 127.0.0.1   Port: 26

::) I'm sorry if someone tried the earlier settings and didn't succeed.

 :) Finally it's set to go.

If someone using Spam Off with Avast could post and confirm here, that these are the correct settings. I'm almost 100% sure they are, but any confirmation is welcome.  ;D

:) Thanks again, Culpeper, for all your suggestions which lead to the final solution.

;) Eric  

Offline EVdB

  • Jr. Member
  • **
  • Posts: 49
  • Brabantse Leeuw
Re:Configuration with Spam Off
« Reply #11 on: January 29, 2004, 10:43:47 PM »
Hi Culpeper,

 :o I'm really ennoyed to report you that one more change needs to be done to get it working to send mail.

Change the following to the previous post:
Avast ini-file:
DefaultPopServer=POP3:110
DefaultSmtpServer=SMTP:25

 ::) Boy, is this a puzzle who's giving me an headache!

But like I said before "almost 100% certain"  ;D

 :P :P :P :P :P :P :P I'm beat  ;D ;D ;D ;D ;D

Offline Culpeper

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1187
Re:Configuration with Spam Off
« Reply #12 on: January 30, 2004, 01:19:09 AM »
I went through the same headaches setting up SpamPal with Avast.
The wind in the wires made a tattletale sound
And a wave broke over the railing
And every man knew, as the Captain did, too,
T'was the witch of November come stealing.

Offline EVdB

  • Jr. Member
  • **
  • Posts: 49
  • Brabantse Leeuw
Re:Configuration with Spam Off
« Reply #13 on: January 30, 2004, 01:28:41 AM »
Hi Culpeper,
Quote
I went through the same headaches setting up SpamPal with Avast.
 :P Well it's all working now, so maybe the settings are right this time. I'm getting more prudent this time in my statements.

 :o Don't want to go through this ordeal anymore!

:P Going to sleep now, so have a nice day tomorrow & a great weekend.

 ;) Bye for now & thanks again for all your help!