Author Topic: FIX Sound broken/no audio output device after using Avast Driver Updater  (Read 4988 times)

0 Members and 1 Guest are viewing this topic.

Offline Luong2

  • Newbie
  • *
  • Posts: 1
Hi everyone. After a day trying to fix the problem, I finally bring back my audio. What I did is restore all the driver that has the "Audio", and "Sound" in its name. In my case, these drivers are:

- Intel Display Audio
- Intel Smart Sound Technology Audio Controller
- Intel Smart Sound Technology OED
- Realtek Audio Universal Service
- Realtek Audio Effects Component

After I restored these drivers, I restarted my laptop and the audio came back.
« Last Edit: February 02, 2021, 05:44:44 AM by Luong2 »

Offline Stellarman

  • Moderator
  • Advanced Poster
  • *
  • Posts: 817
  • Product Manager
Hi everyone. After a day trying to fix the problem, I finally bring back my audio. What I did is restore all the driver that has the "Audio", and "Sound" in its name. In my case, these drivers are:

- Intel Display Audio
- Intel Smart Sound Technology Audio Controller
- Intel Smart Sound Technology OED
- Realtek Audio Universal Service
- Realtek Audio Effects Component

After I restored these drivers, I restarted my laptop and the audio came back.

Hello,

first of all let me sincerely apologize for all troubles associated with usage of our product.
We really try to make the product better but there are still cases when a wrong driver is installed and then it causes such issues.
We also work on a feature which should help users to easily revert all drivers connected to a particular device (e.g. in your case it would be sound) so in future there will be no need to find them one by one in Windows but you should be able to revert them from one place directly inside our product.
What is probably more important though is that we are also trying to improve the detection and installation process to eliminate such issues at the first place and there will be a better detection in one of the future updates.

I know that all of this does not "erase" what already happened to you. I just want to tell you that we are constantly doing our best to improve our product to make sure that such situations either won't happen at all or at least there will be a bare minimum of them.

Thank you for your feedback and have a nice day!

Offline Helena61

  • Newbie
  • *
  • Posts: 5
Hi. The same is happening to me and I don't know how to fix it.
Avast Driver Updater installed a new version of the Realtek Audio in my computer 2 weeks ago and since that day the audio doesn't work.
But I don't know how to restore the old version or fix this issue, because when I click "Driver versions" it only shows this current version, installed now.
How can I fix it then?
thank you
Helena

Offline _Uli_

  • Avast team
  • Newbie
  • *
  • Posts: 14
Hi Helena, I already answered in "your" thread. Best regards, Uli

Offline nicole.nicholas

  • Newbie
  • *
  • Posts: 1
I'm having the same problem. I updated my drivers and now my sound doesn't work. I used your support chat and that was a joke... They spent 1.5 hrs and barely did anything at all. Most of the chat was me sitting there wondering where they went, because they weren't doing anything and weren't letting me know what was going on.

They tried one thing to solve the problem in 1.5 hrs (uninstalled the driver and restarted) which I'd already done and it didn't work. They sent my issue to their team who takes care of these things but I haven't heard back and I need this fixed asap, as I work in the audio industry, so this is a big deal not to have working.

After the chat, I went into the Avast Driver Installer app and clicked on "Sound" and reverted all of them, then restarted but that still didn't work. This makes no sense. I've reverted all drivers that have anything to do with sound but my sound still isn't working...

A quick Google search shows that this is a common issue, so I'm not sure why it's such a headache to get this resolved.

Offline Stellarman

  • Moderator
  • Advanced Poster
  • *
  • Posts: 817
  • Product Manager
I'm having the same problem. I updated my drivers and now my sound doesn't work. I used your support chat and that was a joke... They spent 1.5 hrs and barely did anything at all. Most of the chat was me sitting there wondering where they went, because they weren't doing anything and weren't letting me know what was going on.

They tried one thing to solve the problem in 1.5 hrs (uninstalled the driver and restarted) which I'd already done and it didn't work. They sent my issue to their team who takes care of these things but I haven't heard back and I need this fixed asap, as I work in the audio industry, so this is a big deal not to have working.

After the chat, I went into the Avast Driver Installer app and clicked on "Sound" and reverted all of them, then restarted but that still didn't work. This makes no sense. I've reverted all drivers that have anything to do with sound but my sound still isn't working...

A quick Google search shows that this is a common issue, so I'm not sure why it's such a headache to get this resolved.

Hello,

first of all let me sincerely apologize for all troubles associated with usage of our product.
We really try to make the product better but there are still cases when a wrong driver is installed and then it causes such issues.

In order to be able to help you I would like to ask you to send the log files so we can investigate where the problem is.
We replaced our previous log collector tool with the official Avast Support Tool which is more or less the same however just to make sure here is the process:
  • Open Driver Updater - Menu - Settings - Troubleshooting
  • Click "Open Support Tool" button at the top
  • Confirm the Windows User Access Control dialog to start the tool
  • After the initial check click "Next"
  • Fill in your email address so we can contact you afterwards if necessary
  • Click "Generate" button to start the process
  • When everything is finished, send me the code displayed in the final screen (see the attached picture) so we can find the right package associated with it

Thank you for your cooperation. We will try to investigate this issue as soon as possible and get back to you.