Author Topic: new to avast- where did all my icons go?  (Read 10178 times)

0 Members and 1 Guest are viewing this topic.

Lessa

  • Guest
new to avast- where did all my icons go?
« on: December 21, 2006, 02:52:02 PM »
hi - i just installed avast this morning - after rebooting all my icons are gone - from the IE ball in my taskbar to all file icons in program files - how do i get my icons back?

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: new to avast- where did all my icons go?
« Reply #1 on: December 21, 2006, 03:17:08 PM »
Icons?
avast shouldn't mess anything related to icons...  ::)
Do you have any other antivirus installed in this computer? Did you have in the past?

Can you post a screenshot of your 'missing' icons desktop?
The best things in life are free.

Lessa

  • Guest
Re: new to avast- where did all my icons go?
« Reply #2 on: December 21, 2006, 03:23:58 PM »
all icons gone - everything everywhere is all in this type of text where before there was an icon for every filetype

Lessa

  • Guest
Re: new to avast- where did all my icons go?
« Reply #3 on: December 21, 2006, 04:36:54 PM »
just for anyones info i am running windows me on this comp ( i will be going to an new xp comp next week and wanted to test on this comp first) and just got all my icons back- was going to unistall avast and do a system restore til i remembered ie has a repair and figured let me try that before doing a restore -
go to control panel - add/remove - look for mircrosoft ie tools - click repair- reboot and all is well ( at least for me)
so thanks ;)

Lessa

  • Guest
Re: new to avast- where did all my icons go?
« Reply #4 on: December 21, 2006, 04:41:04 PM »
this is much better now  ;)

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89244
  • No support PMs thanks
Re: new to avast- where did all my icons go?
« Reply #5 on: December 21, 2006, 04:50:35 PM »
Glad you have found a resolution (excuse the pun) to your problem.

Welcome to the forums

For the future when you post images, please crop the image to show only the relevant part, 2000.1500 pixels is too big (especially for those with low resolution monitors). Not to mention all there is is a white background that could be cropped that would also reduce the file size from 150KB plus to around 35KB or less.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.4.6112 (build 24.4.9067.762) UI 1.0.803/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline sergofun

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1607
  • Hello, world>_
Re: new to avast- where did all my icons go?
« Reply #6 on: December 21, 2006, 09:06:46 PM »
Hi, Lessa. ;D
Just for some information. Disappearing icons of the desktop is a normal when you use avast! on Win95,98,Me. It isn't a problem on WinXP.
Take a look:
strange behaviour (icons are gone!)
why does windows98 dissappear?
Windows98 se Icons dissapear
and some others.
After rebooting icons appear again. Don't worry, install WinXP as soon as possible (just for your safety - NT based systems much more better). ;)

sebon

  • Guest
Re: new to avast- where did all my icons go?
« Reply #7 on: January 16, 2007, 03:59:42 PM »
Hi, Lessa. ;D
Just for some information. Disappearing icons of the desktop is a normal when you use avast! on Win95,98,Me. It isn't a problem on WinXP.
Take a look:
strange behaviour (icons are gone!)
why does windows98 dissappear?
Windows98 se Icons dissapear
and some others.
After rebooting icons appear again. Don't worry, install WinXP as soon as possible (just for your safety - NT based systems much more better). ;)


People with Win9X want a solution tothus Avastr Bug they don't want to preach or exhorted to get another operatiing system.
If you don't know the answer to the provlem then please don't make unproductive comments like that .It is very annoying
I have winME, and the same thing happened when I unchecked
[] use skins for simple interface, I had also set scan to thorough and to scan archives which you cant access when inm skin mode.

It is Avast that is causing the problem.

If you disagree then explain why  it is not avast ie Facts not supposition nor opinion,
 

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: new to avast- where did all my icons go?
« Reply #8 on: January 16, 2007, 05:21:15 PM »
It is Avast that is causing the problem.
Look Sebon, it's well-known that Windows 9x and Me are terrible on memory management. So, Microsoft has improved a lot its operational system.
It's natural that an application that has a lot of impact in the system, like an antivirus, could use resources that are now well-managed...
Troubles could happen (although I've used avast in Windows 98 for two years without having the icons disappearing).

Lessa said that the problem was gone  ???
The best things in life are free.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11862
    • AVAST Software
Re: new to avast- where did all my icons go?
« Reply #9 on: January 16, 2007, 05:25:05 PM »
I had also set scan to thorough and to scan archives which you cant access when inm skin mode.

You can change the sensitivity and archive scanning in any mode.

sebon

  • Guest
Re: new to avast- where did all my icons go?
« Reply #10 on: January 17, 2007, 05:36:34 PM »
I had also set scan to thorough and to scan archives which you cant access when inm skin mode.

You can change the sensitivity and archive scanning in any mode.



Thanks I realised that aferwards but forgot to edit it

sebon

  • Guest
Re: new to avast- where did all my icons go?
« Reply #11 on: January 17, 2007, 07:07:02 PM »
It is Avast that is causing the problem.
Look Sebon, it's well-known that Windows 9x and Me are terrible on memory management. So, Microsoft has improved a lot its operational system.
It's natural that an application that has a lot of impact in the system, like an antivirus, could use resources that are now well-managed...
Troubles could happen (although I've used avast in Windows 98 for two years without having the icons disappearing).

Lessa said that the problem was gone  ???




It is Avast that is causing the problem.
Look Sebon, it's well-known that Windows 9x and Me are terrible on memory management. So, Microsoft has improved a lot its operational system.
It's natural that an application that has a lot of impact in the system, like an antivirus, could use resources that are now well-managed...
Troubles could happen (although I've used avast in Windows 98 for two years without having the icons disappearing).

Lessa said that the problem was gone  ???


OKay perhaps I was a bit strident in my first post.
Sorry about that, I am the analytical argumentative type that  tends to want raw facts b4 I accept anything!!

As I am typing this my icons are gone just like in Lessa's  screenshot.
It happened when I wanted scan a folder which  had
a small zip file ~ 3MB

I had scanned it first with Avast and it came up clean
I subsequently scanned it with an on demand scanner
AntivirPE classic.
(I make sure It does not stay in mem - used prcview to verify.)
AntirvirPE gave an alert in one of the archives as  containing a Trojan.
So I went back and checked the settings,in Avast  and The scan level was on standard
I turned the slider up to thorough (I rember on a previous occasion that you set Avast to scan archives but I couldn't find it)
Scanned again; agin it was clear
I then unchecked use skins for simple interface
selected scan archives.

and scanned again (came up clean again)

Then I noticed that  my windows Explorer shell icons had disappered,the quick launch icons had disappered too.
The systray icons on the  the right were okay and so were icons for all non operating system programs.

The history panel in internet explorer were effected wheresas the standard buttons were not.

This problem happened on a previous occasion 4 months ago when scanning  archives with skins unchecked.

Lessa has managed to get the icons back .
I will too once I reboot.

1/  Is Lessa saying that he no longer gets disappearing icons when he uses Avas to scan in the same way that he/she did in the first instance.

2/ Please explain how memory mangagement issues in win9x causes the icon disapppearance.
Does it crash Explorer  what is going on exactly?
Why does it occur with Avast but not AntivirPE


You used the terms "memory  management " and "resources"
I understand resources to be

System resources
user resources
GDI resources

the windows resource meter level was 3 green bars
durring the scan.



Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: new to avast- where did all my icons go?
« Reply #12 on: January 17, 2007, 07:52:21 PM »
I had scanned it first with Avast and it came up clean
I subsequently scanned it with an on demand scanner AntivirPE classic.
Are you using two antivirus at the same time?  ::)
Disable is not enough (never was). You need to uninstall (fully, completely, no files or trash registry keys left behind) one of them.
Crashes and conflicts will appear, sooner or later...

2/ Please explain how memory mangagement issues in win9x causes the icon disapppearance.
Does it crash Explorer  what is going on exactly?
DLL (libraries) are bad removed from memory after being used, low-memory systems, etc. are some reasons for bad memory management of Windows 98.
I'm not a hardware or operational system specialist... I'm just an user that could say with some experience: Windows 9x and Me have lots of problems that were solved in NT systems (2000 or XP) and others in Vista.

Why does it occur with Avast but not AntivirPE
Maybe Antivir works better on Windows 98.
But, take care, the support of Windows 98 by Antivir will end on June...
http://www.free-av.com/antivirus/allinonen.html
The best things in life are free.

sebon

  • Guest
Re: new to avast- where did all my icons go?
« Reply #13 on: January 18, 2007, 12:18:25 PM »
2/ Please explain how memory mangagement issues in win9x causes the icon disapppearance.
Does it crash Explorer  what is going on exactly?
DLL (libraries) are bad removed from memory after being used, low-memory systems, etc. are some reasons for bad memory management of Windows 98.
I'm not a hardware or operational system specialist... I'm just an user that could say with some experience: Windows 9x and Me have lots of problems that were solved in NT systems (2000 or XP) and others in Vista.

Why does it occur with Avast but not AntivirPE
Maybe Antivir works better on Windows 98.
But, take care, the support of Windows 98 by Antivir will end on June...
http://www.free-av.com/antivirus/allinonen.html
Quote


If you are using one antivirus  for your main antivirus resident protection and the other for for on-demand access only there is no problem such as the conflicts you mention.You'll find that  is common practice
Yes you will have probs if you you are using 2 resident guards together but that is not want i am doing.

I  hardly get any crashes  at all with my winME setup and I run it for long periods of time without reboot 2 -3  days or so.

The disappearing icons has been mentioned elsewhere

http://forum.avast.com/index.php?PHPSESSID=3764141d288a236daed995733e4f14a7&topic=22604.msg187655#msg187655

in which the only programs installed were win98 and Avast.

Also it seems to only occur only when you scan from the main
scanner program and select scan folders.
SEE
http://forum.avast.com/index.php?topic=23914.msg196785#msg196785

If you rightclick the folder and select scan with Avast
it scans all the files in the folder including inside archives.

WITH NO LOSS OF ICONS AT ALL

Can you explain that? It is the same setting.
ie thorough and scan archives
yet one method causes the loss of your icons the other does not

Finally A reason to have another on-demand scanner

I scanned an archive with AntivirPE - It came up clean
I scanned it with Avast and it detected a Trojan.

Like I said b4 I not trying to be confrontational. I just want to get to the bottom of this problem.

As I said earlier, how exactly is it happening. Now I am not an  a computer tech, but isn't there a way to test this: a debugger or process program that would capture the process to file to see How The scanner is interacting with the windows/internet  explorer shell to see where and how this adverse reaction is taking place.
« Last Edit: January 18, 2007, 06:14:11 PM by sebon »

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89244
  • No support PMs thanks
Re: new to avast- where did all my icons go?
« Reply #14 on: January 18, 2007, 03:25:36 PM »
How come your last two posts double quote, can you not edit/modify them.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.4.6112 (build 24.4.9067.762) UI 1.0.803/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security