Author Topic: Avast! won't stop flagging Serv-U  (Read 3664 times)

0 Members and 1 Guest are viewing this topic.

Offline johnd126

  • Newbie
  • *
  • Posts: 4
Avast! won't stop flagging Serv-U
« on: May 07, 2007, 11:44:55 PM »

I'm using Serv-U as my ftp server program and have entered the path to the servudeamon executable into both of the Exclusion locations in avast 4.7 but it's still not allowing the service to start and popping up a dire warning dialog about it.  How do I get it to keep from incorrectly flagging this file as a trojan?  I have restarted the computer to make sure the settings were loaded correctly. 

Also, there should be a 'This file is ok' button on the warning dialog rather than just a button that won't allow the program to start.





Offline Hawk

  • Jr. Member
  • **
  • Posts: 44
  • Avast mateys!
Re: Avast! won't stop flagging Serv-U
« Reply #1 on: May 08, 2007, 01:12:34 AM »
Did you entered here the exclusion path?
Also you cand password protect this file with the password "virus" and send it to virus(at)avast.com so they can remove it from the database.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67255
Re: Avast! won't stop flagging Serv-U
« Reply #2 on: May 08, 2007, 01:15:53 AM »
Also, there should be a 'This file is ok' button on the warning dialog rather than just a button that won't allow the program to start.
Ok, this suggestion was deeply considered before. People who don't know what are doing when the virus alert appear will mess the avast installation. It will be another option in a crowded window. False positives could be managed by the convenient entry in the both avast Exclusion lists (on-demand and on-access).
The best things in life are free.

Offline johnd126

  • Newbie
  • *
  • Posts: 4
Re: Avast! won't stop flagging Serv-U
« Reply #3 on: May 08, 2007, 06:52:29 PM »
Did you entered here the exclusion path?
Also you cand password protect this file with the password "virus" and send it to virus(at)avast.com so they can remove it from the database.

I entered it in both exclusion file locations.  I tried it with and without quotes (it's located in the 'Program Files' tree) with no success.  I also restarted the computer after each change to make sure it was read. 

I'll send a copy of the file to the virus address...



Offline johnd126

  • Newbie
  • *
  • Posts: 4
Re: Avast! won't stop flagging Serv-U
« Reply #4 on: May 08, 2007, 06:53:48 PM »
Also, there should be a 'This file is ok' button on the warning dialog rather than just a button that won't allow the program to start.
Ok, this suggestion was deeply considered before. People who don't know what are doing when the virus alert appear will mess the avast installation. It will be another option in a crowded window. False positives could be managed by the convenient entry in the both avast Exclusion lists (on-demand and on-access).

Could there be an 'advanced' option to display these types of things?  I'm getting kind of tired of doing without options in programs because the writers have to pander to the lowest common denominator...


Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 84912
  • No support PMs thanks
Re: Avast! won't stop flagging Serv-U
« Reply #5 on: May 08, 2007, 07:38:03 PM »
Well the Program Settings, Exclusions, has an option to browse, use that to find the file you want to exclude and select it. That will import the path into Selected paths: box, before clicking OK, copy that path and use that in the standard shield exclusions.

The advanced options were also considered and I believe for the same reasons that the exclusions sections have been catered for any advanced option didn't progress.

I don't know what programs that you are using that have avast continue to detect them as malware. I have only two exclusions in the Program Settings, only three in the standard shield exclusions and that is in over three years of use. So I haven't found that it is so frequent that I need an advanced option to save adding them manually.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67255
Re: Avast! won't stop flagging Serv-U
« Reply #6 on: May 08, 2007, 07:52:19 PM »
I entered it in both exclusion file locations.  I tried it with and without quotes (it's located in the 'Program Files' tree) with no success.  I also restarted the computer after each change to make sure it was read.
For any reason, does the detected virus is shown into its short path?
I mean: C:\Progra~1\... instead of C:\Program Files\
Did you use wildcards?
The best things in life are free.

Offline johnd126

  • Newbie
  • *
  • Posts: 4
Re: Avast! won't stop flagging Serv-U
« Reply #7 on: May 08, 2007, 08:48:36 PM »
I entered it in both exclusion file locations.  I tried it with and without quotes (it's located in the 'Program Files' tree) with no success.  I also restarted the computer after each change to make sure it was read.
For any reason, does the detected virus is shown into its short path?
I mean: C:\Progra~1\... instead of C:\Program Files\
Did you use wildcards?

Bah, it was using the short path.  I modified the exclusion paths and it's now working properly.  Thanks for the tip but I'm bit surprised I've had to do this...

Thanks!

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67255
Re: Avast! won't stop flagging Serv-U
« Reply #8 on: May 08, 2007, 09:23:57 PM »
But I'm bit surprised I've had to do this...
The string is tested as text, so the 'text' of the short path is different form the 'text' of the long...
Glad I could help.
The best things in life are free.