Author Topic: Problems with avast program&vps updating  (Read 9142 times)

0 Members and 1 Guest are viewing this topic.

Offline Joeloucyn

  • Jr. Member
  • **
  • Posts: 92
  • Ouch, Microsoft bites me again!
Problems with avast program&vps updating
« on: January 14, 2007, 03:43:33 AM »
I noticed that avast is now 4.7.936 so I tried manual update on my Windows XP Home, Windows XP Pro and Windows 98se computers. The update was extremely slow even though I am on a 5meg High Speed connection so I have stopped the updates. What is happening? Updates were fast downloading in the past!
Then I tried updating through complete download of avast (took 8 seconds for whole download of 12.6 MB),shut down my internet connection through my router and successfully updated all three computers.
But avast now can not do a VPS update (it just hangs) on all my computers which includes the XP Home, XP Pro and 98se.
« Last Edit: January 14, 2007, 04:32:06 AM by Joeloucyn »

Offline Joeloucyn

  • Jr. Member
  • **
  • Posts: 92
  • Ouch, Microsoft bites me again!
Re: Problems with avast program&vps updating
« Reply #1 on: January 14, 2007, 05:05:46 AM »
The Windows 98se was just able to do a VPS update but took 10 MINUTES ! Both XP computers still are unable to do a VPS update as the update stalls! Very slooowwww VPS downloads.

Offline mauserme

  • Massive Poster
  • ****
  • Posts: 2475
Re: Problems with avast program&vps updating
« Reply #2 on: January 14, 2007, 05:16:11 AM »
The Windows 98se was just able to do a VPS update but took 10 MINUTES !
I've just started experiencing that on an XP Home box.  The update seamed to hang but in reality it took forever (many minutes) between clicking on Update and the appearance of the update window, then many more minutes to finish checking for updates.

What firewall are you using?
"If at first you don't succeed keep on sucking 'till you do succeed" - Curley Howard in Movie Maniacs (1935)

Offline Joeloucyn

  • Jr. Member
  • **
  • Posts: 92
  • Ouch, Microsoft bites me again!
Re: Problems with avast program&vps updating
« Reply #3 on: January 14, 2007, 05:33:37 AM »
I am using the hardware firewall in my D Link router and Look'N'Stop firewall in application filtering. The updating window appeared very fast on all the computers but only the Windows 98se was able to do a VPS update taking 10 minutes as shown in the update complete window . The XP computers still have not been able to complete a VPS update now timing out at 15 minutes. This is not a firewall problem as you can see from my original post. I dropped both my hardware and software firewalls as confirmation.
« Last Edit: January 14, 2007, 05:41:05 AM by Joeloucyn »

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: Problems with avast program&vps updating
« Reply #4 on: January 14, 2007, 08:27:09 AM »
On one of my machines (Windows XP Pro SP2 - Windows XP firewall) I installed 4.7.936 as soon as it became available (I had been running the beta).

No problems here on running manual VPS updates, necessary files are downloaded and I am told I am up to date.  All pretty much instantaneous.

The same is true if a manual program update is requested.

I have another machine (Windows XP Pro SP2 - ZoneAlram firewall) that had not been updated with avast.  I just ran a manual program update on that machine - program update files, VPS files all downloaded and installed rapidly.  On restarting that system after the install a request for a manual VPS updates instantly downloads the files and reports that VPS is up to date - again pretty much instantly. 

I am not doubting the hangs being experienced but they are not universal. 

Just wondering if there might be any other issues (as there were the last time avast provided a program update) like any anti-spyware program that is being run on your systems.

What is the avast setup log showing?   

Offline Joeloucyn

  • Jr. Member
  • **
  • Posts: 92
  • Ouch, Microsoft bites me again!
Re: Problems with avast program&vps updating
« Reply #5 on: January 14, 2007, 09:17:42 AM »
My setup logs are so large that I think I will stay away from there (they date from 2002), have to take time to clean them up to a more sensible size! Anyways what I am getting at is one or more of avast's servers is not functioning properly.  I had no problems with vps or program update download speeds with previous official program updates.I had a vps update hours before this program update that was very fast (3 seconds). I had problems with the download speed of the last betas (925, etc took hours so I gave up) which did not occur with previous betas. I really believe avast needs to check and reboot one or two of their servers.

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: Problems with avast program&vps updating
« Reply #6 on: January 14, 2007, 09:21:08 AM »
How about the last 50 lines or so of the setup log? 

Might you post that here?

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Problems with avast program&vps updating
« Reply #7 on: January 14, 2007, 01:28:13 PM »
Joeloucyn, current 4.7.936 version has troubles with updates into Windows 9x and Me.
Today is scheduled a new version to solve this problems.
Servers were busy while a lot of users were trying to upgrade from 4.7.892 to 4.7.936 yesterday.
So, after a new upgrade today, please, post again if the problem persists...
The best things in life are free.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83301
  • No support PMs thanks
Re: Problems with avast program&vps updating
« Reply #8 on: January 14, 2007, 02:55:54 PM »
If you need to you could try the avast! VPS Update - Manual Download and run the exe to install a complete VPS update rather than the incremental one that isn't working for you.

The latest VPS is 0703-0 13-1-2007
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.5.2415 (build 20.5.5410.561) UI-1.0.532/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline mauserme

  • Massive Poster
  • ****
  • Posts: 2475
Re: Problems with avast program&vps updating
« Reply #9 on: January 14, 2007, 03:45:23 PM »
Servers were busy while a lot of users were trying to upgrade from 4.7.892 to 4.7.936 yesterday.
I didn't think of that but it might be the source of my problem.  After updating from the avast! beta to 4.7.936 I was getting 97%-99% cpu usage by cmdagent.exe (Comodo Firewall) with both the current Comodo release and RC4.  I thought there might be a conflict (its been reported by Snowhite and others in the past).  But if avast! was contnually trying to check for updates that could explain it.
"If at first you don't succeed keep on sucking 'till you do succeed" - Curley Howard in Movie Maniacs (1935)

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Problems with avast program&vps updating
« Reply #10 on: January 14, 2007, 03:49:58 PM »
I didn't think of that but it might be the source of my problem.  After updating from the avast! beta to 4.7.936 I was getting 97%-99% cpu usage by cmdagent.exe (Comodo Firewall) with both the current Comodo release and RC4.  I thought there might be a conflict (its been reported by Snowhite and others in the past).  But if avast! was contnually trying to check for updates that could explain it.
I hope this is not the old Comodo bug reported before.
http://forum.avast.com/index.php?topic=25287.msg207204#msg207204
http://forum.avast.com/index.php?topic=25981.msg212327#msg212327

I'm using version 2.4.10.131 beta... I'm tired to uninstall and install one new version of Comodo every day... I did not test any RC version.
It will be a pity that the bug comes back again  :'(
The best things in life are free.

Offline mauserme

  • Massive Poster
  • ****
  • Posts: 2475
Re: Problems with avast program&vps updating
« Reply #11 on: January 14, 2007, 03:57:49 PM »
I tried Comodo 2.4.14.157 RC4  beta after running into problems with the regular version but have no firewall installed at the moment (just the Windows Firewall and my router).   For some reason I couldn't get Zone Alarm to install but I'll try again today.
"If at first you don't succeed keep on sucking 'till you do succeed" - Curley Howard in Movie Maniacs (1935)

Offline chasrome

  • Newbie
  • *
  • Posts: 4
Re: Problems with avast program&vps updating
« Reply #12 on: January 14, 2007, 04:04:34 PM »
This is a Win98 problem only.  Not sure when it started.  WinXP updates normal.  WinXP (on same hi-speed internet conn) takes normal LT 60 seconds.  Win 98 now taking up to EIGHT HOURS to complete ANY size update.  Manual download and remove old, add new, ditto.  Update always works.  Seems like computer is hung but it eventually completes update with no messages.  Looks like some XP code is getting in the way of Win98.  Hope we see a corrected update soon.  Win98 utilities getting scarce but Win98 is much better than XP for working with audio.  Need to keep it safe!

Offline mauserme

  • Massive Poster
  • ****
  • Posts: 2475
Re: Problems with avast program&vps updating
« Reply #13 on: January 14, 2007, 04:10:26 PM »
This is a Win98 problem only.
Yeah - I think my problem goes back to an unrelated issue.
"If at first you don't succeed keep on sucking 'till you do succeed" - Curley Howard in Movie Maniacs (1935)

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11747
    • AVAST Software
Re: Problems with avast program&vps updating
« Reply #14 on: January 14, 2007, 04:26:16 PM »
That's actually an important question... we have been able to reproduce the problem on Windows 9x, and also fixed it somehow, but right now we are not aware of the same problem on Windows NT/2000/XP.
So, your XP computer still shows the same symptoms when attempting to update?
Thanks.