Author Topic: Problems with avast program&vps updating  (Read 9179 times)

0 Members and 1 Guest are viewing this topic.

Offline mauserme

  • Massive Poster
  • ****
  • Posts: 2475
Re: Problems with avast program&vps updating
« Reply #15 on: January 14, 2007, 04:30:42 PM »
Updates are fine with no firewall. 

Do you want me to reinstall Comodo and try again?
"If at first you don't succeed keep on sucking 'till you do succeed" - Curley Howard in Movie Maniacs (1935)

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11752
    • AVAST Software
Re: Problems with avast program&vps updating
« Reply #16 on: January 14, 2007, 04:34:30 PM »
Well, if it's not a problem for you...
What I would like to know is whether the updates are blocked completely, or if the problem is really the same as on Win9x - i.e. that the updates are only VERY slow.

Offline mauserme

  • Massive Poster
  • ****
  • Posts: 2475
Re: Problems with avast program&vps updating
« Reply #17 on: January 14, 2007, 04:37:22 PM »
No problem at all.

Last night the updates were exremely slow with either version of Comodo.  I'll be back in a few after reinstalling and trying again.
"If at first you don't succeed keep on sucking 'till you do succeed" - Curley Howard in Movie Maniacs (1935)

Offline Marc57

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1944
  • KISS Rules The World!!!
    • KISS Army
Re: Problems with avast program&vps updating
« Reply #18 on: January 14, 2007, 05:10:23 PM »
Hey igor,
 I don't know if this will help, but I was having problems updating Avast after installing the latest version on my windows media center 2005 PC.

I have two connections under Network connections, (I just got this computer in Dec so I'm still learning about it) One is the actual connection I use, and the other is called a 1394 Net adapter which is not in use.

For some reason the new Avast was trying to update through the 1394 connection first, Which means it would keep trying to update with no effect.

The way I fixed this was to disable the 1394 connection, reboot, then re enable that connection. From then on Avast used the right connection and updated fine.
You Wanted the Best You Got the Best the Hottest Band in the World KISS!!!

Offline mauserme

  • Massive Poster
  • ****
  • Posts: 2475
Re: Problems with avast program&vps updating
« Reply #19 on: January 14, 2007, 05:24:02 PM »
Sorry this took so long.  I downloaded and installed a fresh copy of Comodo 2.3.6

After reboot cmdagent.exe was immediately in the high 90% cpu usage range.

Here's what I got doing a manual avast! update (using the clock in the system tray for timing)

9:45  Clicked Update
9:48  Comodo reports setup.avast wants a connection (Comodo logged this as a high alert at 9:48:07)
9:49  Comodo again reports setup.avast wants a connection (logged by Comodo at 9:48:53)
9:56  The avast! AntiVirus Setup window appears
9:57  Comodo reports that avast! antivirus update is trying to connect (nothing is logged)
9:59  The avast! Antivirus Setup window disappears
10:02 The avast! Antivirus Summary window appears

Total Time = 10:41
Downloaded Files = 3 (0.03KB)
Download Time = 1:19

I'm on a 3mbps adsl connection.  Still in the high 90% range for cmdagent.exe though I saw it drop briefly to 51%.
"If at first you don't succeed keep on sucking 'till you do succeed" - Curley Howard in Movie Maniacs (1935)

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Problems with avast program&vps updating
« Reply #20 on: January 14, 2007, 06:05:16 PM »
Sorry this took so long.  I downloaded and installed a fresh copy of Comodo 2.3.6
Sorry, this is a known buggy version that conflict with avast...
I've posted before two links about that...
The best things in life are free.

Offline mauserme

  • Massive Poster
  • ****
  • Posts: 2475
Re: Problems with avast program&vps updating
« Reply #21 on: January 14, 2007, 06:12:11 PM »
I realize the version I removed last night after this problem started was 2.3.4.

Do you know of a "good" version I might try.  Filehippo probably has old versions if you can give me a version number. 
"If at first you don't succeed keep on sucking 'till you do succeed" - Curley Howard in Movie Maniacs (1935)

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Problems with avast program&vps updating
« Reply #22 on: January 14, 2007, 06:30:38 PM »
Do you know of a "good" version I might try.
http://www.filehippo.com/download_comodo/
Comodo Firewall 2.4.10.131 Beta
I'm using it.
The best things in life are free.

Offline mauserme

  • Massive Poster
  • ****
  • Posts: 2475
Re: Problems with avast program&vps updating
« Reply #23 on: January 14, 2007, 07:49:41 PM »
Still the same with Comodo Firewall 2.4.10.131 Beta  :(

I didn't time the whole thing this time, but roughly 2 to 3 minutes to start the update process, then



cmdagent.exe is again at 97%+
« Last Edit: January 14, 2007, 07:51:12 PM by mauserme »
"If at first you don't succeed keep on sucking 'till you do succeed" - Curley Howard in Movie Maniacs (1935)

Offline mauserme

  • Massive Poster
  • ****
  • Posts: 2475
Re: Problems with avast program&vps updating
« Reply #24 on: January 14, 2007, 08:07:43 PM »
Aha !

I'm still with Comodo Firewall 2.4.10.131 Beta  but this time I renamed the avast! antikill driver from antikill.sys to antikill.old.  Everything is back to normal through 2 reboots.

I forgot that I downloaded the antikill code shortly after updating to 4.7.936 because of the bagle rootkit that's making the rounds.  It was not previously on this computer.
"If at first you don't succeed keep on sucking 'till you do succeed" - Curley Howard in Movie Maniacs (1935)

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Problems with avast program&vps updating
« Reply #25 on: January 14, 2007, 10:41:53 PM »
I forgot that I downloaded the antikill code shortly after updating to 4.7.936 because of the bagle rootkit that's making the rounds.  It was not previously on this computer.
I hope this *problem* was not present in the future avast 5.
Using an antikill feature that 'crashes' the firewall won't be a good thing.
I've give up on avast antikill features because I've lost skinned interface and have other problems with it...  :-\
The best things in life are free.

Offline Joeloucyn

  • Jr. Member
  • **
  • Posts: 92
  • Ouch, Microsoft bites me again!
Re: Problems with avast program&vps updating
« Reply #26 on: January 15, 2007, 12:20:31 AM »
I have been able to locate my update problems. By doing a traceroute, I found network problems with a router in North America specifically peer-1-networks.ChicagoEquinix.savvis.net which showed extreme packet loss. So I can not blame avast's servers as it is a network problem! For some reason avast update servers only are being routed to my location through this bad router but I can do a complete full download of avast program or vps and manual install on my Windows XP plus Windows 98 without any problems. So this is not an avast problem in my case, I will have to hold off until the network problems at this particular router are corrected before offering any further comment. I also had avast antikill driver on my both Windows XP boxes so I have renamed antikill.sys to antikill.old to prevent any problems as mauserme. So all I can do is wait out the routing through router peer-1-networks.ChicagoEquinix.savvis.net then I will offer more comments!
« Last Edit: January 15, 2007, 12:26:40 AM by Joeloucyn »

Offline mauserme

  • Massive Poster
  • ****
  • Posts: 2475
Re: Problems with avast program&vps updating
« Reply #27 on: January 15, 2007, 01:34:02 AM »
Thanks for the update Joeloucyn. 

I'm sorry I ended up hijacking your thread - I really didn't mean to.  At least some of what helped me may prevent problems for you  :)
"If at first you don't succeed keep on sucking 'till you do succeed" - Curley Howard in Movie Maniacs (1935)

Offline Joeloucyn

  • Jr. Member
  • **
  • Posts: 92
  • Ouch, Microsoft bites me again!
Re: Problems with avast program&vps updating
« Reply #28 on: January 15, 2007, 01:43:36 AM »
I thank you mauserme  :). I think you have prevented me from having problems with the avast antikill driver! Unfortunately I was unable to even get into the avast forums until this afternoon, I kept getting server busy errors (probably because of the same poor routing at my end)!

Offline Joeloucyn

  • Jr. Member
  • **
  • Posts: 92
  • Ouch, Microsoft bites me again!
Re: Problems with avast program&vps updating
« Reply #29 on: January 15, 2007, 08:00:32 PM »
Update- The network problems seem to have been corrected, both of my Windows XP computers and my Windows 98 have been able to update to 4.7.938 on automatic update setting!
I tried manual update to check download speed and everything seems to be back to normal. The new version is lighter on CPU  and ram usage!  8)