Author Topic: email: "port 25 in use" ...? help!!  (Read 12029 times)

0 Members and 1 Guest are viewing this topic.

Offline garbanzo

  • Newbie
  • *
  • Posts: 3
email: "port 25 in use" ...? help!!
« on: February 10, 2004, 08:56:41 AM »
Hi,

every time I start the computer, Avast tells me that "Port 25 is already in use, specify another port value" for the outgoing SMTP mail protection.

this is before I start up my email client (OE6).

why would port 25 be unavailable already?  (I had AVG still running when I installed AVAST, but it's uninstalled now)

thanks for any pointers...

Garbanzo   :)

Offline Culpeper

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1187
Re:email: "port 25 in use" ...? help!!
« Reply #1 on: February 11, 2004, 02:04:03 AM »
Try using a different port number.
The wind in the wires made a tattletale sound
And a wave broke over the railing
And every man knew, as the Captain did, too,
T'was the witch of November come stealing.

Offline techie101returns

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1900
Re:email: "port 25 in use" ...? help!!
« Reply #2 on: February 11, 2004, 07:09:15 AM »
garbanzo,

Firstly, you cannot arbitrarily change port numbers in Avast.  The .ini file must be changed, and then your email client profile matched accordingly.

What Avast is telling you is that you have another program which is using Port 25.  This is not uncommon.

However, Port 25 is normally reserved for Simple Mail Transer.

Do you still have AVG installed?  Avast and AVG cannot be on the same computer.  Both run resident.  You must uninstall AVG for Avast to run correctly.
AVG monitors email also, and has most likely "trapped" port 25 for its own use.

techie

« Last Edit: February 11, 2004, 07:09:57 AM by techie101 »

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11665
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:email: "port 25 in use" ...? help!!
« Reply #3 on: February 11, 2004, 07:19:25 AM »
garbanzo, if you're using Windows 2000 or XP, you can find out which application is listening on port 25 by running this tool: http://www.sysinternals.com/files/tcpview.zip

Hope this helps,
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline garbanzo

  • Newbie
  • *
  • Posts: 3
Re:email: "port 25 in use" ...? help!!
« Reply #4 on: February 11, 2004, 10:58:50 AM »
thanks folks.  I uninstalled AVG when it was obvious that the 2 were'nt happy together.  Still got the "port 25 busy" message when I booted up.

So, I've simply changed the AVAST settings to not do the mail.  I don't have a clue what's taking over port 25.  There must be a system process that logs onto POP3 (ie, in XP, it tells me before I log on if I have new email messages).

I've had TCPview for a while.  So I fired it up.  Not sure if it's "process" or "local address" that I am looking for, but there's no port 25 listed at all. Local TCP's start at 1033 and "Process" listings start at 356 (ie, "tcpsvcs.exe:356").

Netstat -an (in the DOS screen) reports 25 as an active connection, but does not list the app using it.  It just says, "0.0.0.0:25" to "0.0.0.0:0" Listening.

That's the extent of my technical know-how and my visionary perspective at this wee hour.

garbanzo

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11665
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:email: "port 25 in use" ...? help!!
« Reply #5 on: February 11, 2004, 11:57:02 AM »
Do you have the latest version of TCPView?

Anyway, what you're looking for is the Local Address column. You can sort it. Additionaly, you won't see the number 25 because TCPView knows about this port and will display the word "smtp" instead.

So basically, what you're looking for is something like
<yourcomputername>:smtp
in the Local Address column. That will be your process.

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline techie101returns

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1900
Re:email: "port 25 in use" ...? help!!
« Reply #6 on: February 11, 2004, 05:30:02 PM »
garbanza,

There are 2 ways we can try to fix this:
1.  Reassign new port numbers to Avast and your email client.
2.  Find the program using Port 25 and see if it is essential to have running at startup.

Follow VLK's advice and look over the TCP report and see if any other instance of STMP is listed.

Then, I would run MSCONFIG and go the Startup tab.
Review the list for any program that you are not familiar with.

Also, what email client do you use?
Is it set to load with Windows?

Although Netstat is useful, it does not give you a clear picture of who is using what.
TCP is nice, but unless you know how to interpret the data, you still don't know what your looking at.

I had a nice Port scanner program somewhere that I will have to find for you.

Anyway, try the above and let us know.

techie

Offline Culpeper

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1187
Re:email: "port 25 in use" ...? help!!
« Reply #7 on: February 11, 2004, 09:25:20 PM »
This would drive me crazy.  I would HAVE to know what other system was taking over my default port number.
The wind in the wires made a tattletale sound
And a wave broke over the railing
And every man knew, as the Captain did, too,
T'was the witch of November come stealing.

Offline techie101returns

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1900
Re:email: "port 25 in use" ...? help!!
« Reply #8 on: February 12, 2004, 06:57:25 AM »
garbanza,

Ok, here are my picks for Port Scanners that you can try and they are all Freeware

1.  Super Scan from www.foundstone.com
This is a highly effective program, but a bit on the advanced side.  Takes a bit of learning.

2.  Active Ports from www.ntutility.com
This is a straightforward, easy to use program that tells you what you want to know.  Nice interface.

3.  Local Port Scanner by www.jpsoft.dk
Nice program.  Again, it tells you only the basics but that is all  YOU want right now.

4.  AntiyPorts by www.antiy.net
Simple and easy to use.

All of the programs are equally effective.  Pick what you feel you can work with.

Now, you can pick one and find out "who" is using Port 25.  Then we can figure out what to do about it.

Let me know.
techie

Offline petak

  • Newbie
  • *
  • Posts: 2
Re:email: "port 25 in use" ...? help!!
« Reply #9 on: February 16, 2004, 09:29:11 AM »
 ???
Have just discover this other world of Ports.-Avast talks about Port 25, as this discussion mentions. Have used one of these port finders, and yes port 25 is open. Have just read some info on this on another site, but still in the dark-how do I remove, change this port usage, or do I have to print out reams of instructions, and read past midnight.
Hope for some help, love AVast. Thank you.
PetaK..

Offline Jazhawk

  • Jr. Member
  • **
  • Posts: 44
    • Jazhawk's Forums
Re:email: "port 25 in use" ...? help!!
« Reply #10 on: February 16, 2004, 11:00:06 PM »
I am trying to run ihatespam but avast dominates port 25.  The only way I can get ihatespam to work is to stop the process manually because telling avast not to touch my Outlook Express directly doesn't work.

Anybody have a solution to this?

Anybody running Ihatespam wanna offer some help here?

-Jazhawk

Offline techie101returns

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1900
Re:email: "port 25 in use" ...? help!!
« Reply #11 on: February 17, 2004, 01:07:49 AM »
jaz,

Avast normally uses Port 25 which is the common port for email.

However, you can try resetting Avast POP3 to 26 and SMTP to 111.
The Avast .ini file will need to correspond to these ports as well.

I have not used IHateSpam but you can try the settings above to see if they will work for you.  

You can't really tell Avast not to bother with OE if it has been configured to scan the email.

Shutting down Avast is not a good idea just to use IHateSpam.  I would really try another anti-spammer that does not use the email port.

Good Luck
techie

Offline Culpeper

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1187
Re:email: "port 25 in use" ...? help!!
« Reply #12 on: February 17, 2004, 01:32:09 AM »
There was another user of this spam program on the forums that was unable to get it work with Avast.  He switched to SpamPal.
The wind in the wires made a tattletale sound
And a wave broke over the railing
And every man knew, as the Captain did, too,
T'was the witch of November come stealing.

Offline Jazhawk

  • Jr. Member
  • **
  • Posts: 44
    • Jazhawk's Forums
Re:email: "port 25 in use" ...? help!!
« Reply #13 on: February 17, 2004, 04:52:19 PM »
Techie 101

I'll give it a shot because I need the protection and I'm trying to keep spam at bay.  When Cox switched me from cox.com to cox.net, the spam floodgates opened.  I've never used my cox.net email addy ANYWHERE on the net, but spam is rolling all of a sudden.

They claim they are not responsible for it but that response was expected.  They lie!

Anyway, I'll keep you posted but I may need to holla back at you in case I have problems.

@Culpeper

I downloaded Spampal but I'll need to check it's background and success rate before I install it.  The best part is it's free.  But that also means they don't have to really be accountable for a poorly functioning product but again, thanx for the heads up.

-Jazhawk

Offline Culpeper

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1187
Re:email: "port 25 in use" ...? help!!
« Reply #14 on: February 18, 2004, 01:44:29 AM »
No problem!  SpamPal has it's own support forum.  I've been using it for a long time.  So much so, that I now just let it delete messages flagged as spam.  
The wind in the wires made a tattletale sound
And a wave broke over the railing
And every man knew, as the Captain did, too,
T'was the witch of November come stealing.