Author Topic: No Internet Access  (Read 10316 times)

0 Members and 1 Guest are viewing this topic.

Offline pjapma

  • Newbie
  • *
  • Posts: 16
No Internet Access
« on: March 11, 2007, 05:40:51 PM »
Hi,
I have an older Toshiba laptop with Win ME and no virus protection on it. I have downloaded Avast 4.7 and I'm unable to load either Firefox or IE. If I uninstall 4.7 then I'm able to surf the net. Please help. I hate surfing the web without any virus protection.
Thanks.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 83338
  • No support PMs thanks
Re: No Internet Access
« Reply #1 on: March 11, 2007, 06:10:18 PM »
Do you mean you are unable to browse rather than unable to load IE or firefox ?

I assume that is the case, what is your firewall (?) and does it allow ashWebSv.exe internet access ?

Have you manually set-up your browsers to use the avast web shield proxy ?
What errors are you getting ?
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.5.2415 (build 20.5.5410.561) UI-1.0.532/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline pjapma

  • Newbie
  • *
  • Posts: 16
Re: No Internet Access
« Reply #2 on: March 11, 2007, 07:03:52 PM »
Hi Again,
Both browsers will not load...thus no internet capability. I have no firewall. I wasn't aware that I had to configure Avast for each browser. I assume there is a help assistance topic to assist.
Thanks!

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: No Internet Access
« Reply #3 on: March 11, 2007, 07:14:10 PM »
I assume there is a help assistance topic to assist.
For Windows 9x and Me, you have to manually configure the browser proxy, as described here: http://www.avast.com/eng/faq-home-webshield.html
The best things in life are free.

Offline t l s

  • Sr. Member
  • ****
  • Posts: 248
  • huh?
Re: No Internet Access
« Reply #4 on: March 11, 2007, 08:04:28 PM »
You also need a firewall in addition to avast!  Free firewalls that support Win98 (and WinME) include

 Jetico  http://www.jetico.com/index.htm#/jpfirewall.htm
 Outpost free http://www.agnitum.com/products/outpostfree/index.php
 and Sygate Personal Firewall www.filehippo.com/download_sygate_personal_firewall/

My daughter's old Win98SE computer has had Outpost free installed for more than a year now, along with avast! home and some free anti-spyware programs, and no problems.  Jetico appears to require more knowledge than I have, so I didn't try it.  A setup guide for Sygate is available at www.kotiposti.net/string/SPF_eng/SPFGuide.html
Pentium Dual-Core 2.5 GHz, 250GB HDD, 2 GB RAM, WinXP Pro SP3, reasonable caution/adequate paranoia, Mozy, Firefox, IE8, CCleaner, Avast! Internet Security

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 83338
  • No support PMs thanks
Re: No Internet Access
« Reply #5 on: March 11, 2007, 08:20:42 PM »
Hi Again,
Both browsers will not load...thus no internet capability. I have no firewall. I wasn't aware that I had to configure Avast for each browser. I assume there is a help assistance topic to assist.
Thanks!

That is unfortunately a totally different problem and one that I doubt avast is directly involved in. If you haven't manually set the browsers to use the web shield proxy then there should be no interaction between your browser and avast, other than avast will scan the executable as you launch your browser.

avast! only scans it doesn't block, it only alerts to infection.

The only think I can think of is your system may be running out of resources and that may stop the loading of other programs, though I would have expected to at least see some errors, that was why I asked.

What other programs do you have start on boot ?
You need to only load those programs that are essential, some programs automatically set-up to load on boot when installed and they don't need to, like media players.

What is your processor and how much RAM does your laptop have ?

There is the avast help file, which contains a lot of information, including the info on the link Tech gave.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.5.2415 (build 20.5.5410.561) UI-1.0.532/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: No Internet Access
« Reply #6 on: March 11, 2007, 09:27:28 PM »
I have recently resurrected my 10 year old Toshiba laptop. 

I have installed Win ME anew and I have loaded the current release of avast on it.  This machine has only 96Mb of memory but I am having no problems running IE or Firefox with scanning by avast.  It's certainly quite slow - but it works. 

Offline pjapma

  • Newbie
  • *
  • Posts: 16
Re: No Internet Access
« Reply #7 on: March 12, 2007, 02:16:34 PM »
Hi Everyone,
Thank you for your fast replies.
I configured my browsers and that correct part of the problem.
When Avast went to update I got a popup box with:
"Avast Antivirus Setup
Downloading Packages
Downloadinf file:servers.def.vpu
0%"
The system just "hangs there" ...no downloading occurs.
I then closed out of that box and got another smaller one:
"The system cannot find the file specified"   

I tried to post the error files...but it exceeded the 1000 letter limit. I do not know how to break up the info when it is posted to the notepad and in return to copy to this forum.
Thanks again for your help!

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: No Internet Access
« Reply #8 on: March 12, 2007, 03:12:04 PM »
Downloadinf file:servers.def.vpu
0%"
The system just "hangs there" ...no downloading occurs.
You can try and download the servers.def file, http://files.avast.com/iavs4x/servers.def and replace the one in the avast setup folder: C:\Program Files\Alwil Software\Avast4\Setup\servers.def

I tried to post the error files...but it exceeded the 1000 letter limit. I do not know how to break up the info when it is posted to the notepad and in return to copy to this forum. Thanks again for your help!
Post last 100 lines of it, for instance.
The best things in life are free.

Offline pjapma

  • Newbie
  • *
  • Posts: 16
Re: No Internet Access
« Reply #9 on: March 13, 2007, 03:13:54 PM »
Hi Again,
I think am 98% corrected. Avast is now loaded....have the 2 blue balls in my taskbar...but the one with the "A" has a small red circle with a line thru it. I'm  able to manually upload to obtain the latest fies. Currently I have program versions 4.7.942 and VPS of 000723-1. The On-Access Protection Control can not be enabled.
Once again here's my system: Win ME, DSL, no firewall, Firefox 2.0, also have the following: Spyware Blaster, Ad-Aware SE and Spybot.
Thanks for your assistance.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: No Internet Access
« Reply #10 on: March 13, 2007, 06:42:37 PM »
Have the 2 blue balls in my taskbar...
The one is an 'i' (VRDB icon) and not an 'a'.

But the one with the "A" has a small red circle with a line thru it.
A red cross means avast is not enable...

Please, post the last 50-100 files of avast log files:
C:\Program Files\Alwil Software\Avast4\DATA\log\Setup.log
C:\Program Files\Alwil Software\Avast4\Setup\setup.log
The best things in life are free.

Offline pjapma

  • Newbie
  • *
  • Posts: 16
Re: No Internet Access
« Reply #11 on: March 13, 2007, 07:50:40 PM »
Hi,
For the 1st..."setup.log"

13.03.2007   09:50:30.000   1173797430   general   Started: 13.03.2007, 09:50:30
13.03.2007   09:50:30.000   1173797430   general   Running setup_av_pro-3ae (942)
13.03.2007   09:50:30.000   1173797430   system   Operating system: WindowsMe ver 4.90, build 3000 [ ]
13.03.2007   09:50:30.000   1173797430   system   Computer WinName: LAPTOP
13.03.2007   09:50:30.000   1173797430   system   Windows Net User: Peter
13.03.2007   09:50:30.000   1173797430   general   Cmdline: /downloadpkgs /noreboot /silent /progress 
13.03.2007   09:50:30.000   1173797430   general   DldSrc set to inet
13.03.2007   09:50:30.000   1173797430   general   Operation set to INST_OP_UPDATE_GET_PACKAGES
13.03.2007   09:50:30.000   1173797430   general   Old version: 3ae (942)
13.03.2007   09:50:30.000   1173797430   general   SGW32P::CheckIfInstalled set m_bAlreadyInstalled to 1
13.03.2007   09:50:30.000   1173797430   system   Computer DnsName: laptop.gateway.2wire.net
13.03.2007   09:50:30.000   1173797430   system   Computer Ip Addr: 192.168.1.65
13.03.2007   09:50:30.000   1173797430   internet   SYNCER: Type: use IE settings
13.03.2007   09:50:30.000   1173797430   internet   SYNCER: Auth: another authentication, use WinInet
13.03.2007   09:50:30.000   1173797430   package   Part prg_av_pro-3ae is installed
13.03.2007   09:50:30.000   1173797430   package   Part vps-72301 is installed
13.03.2007   09:50:30.000   1173797430   package   Part news-4b is installed
13.03.2007   09:50:30.000   1173797430   package   Part setup_av_pro-3ae is installed
13.03.2007   09:50:30.000   1173797430   general   Old version: 3ae (942)
13.03.2007   09:50:35.000   1173797435   file   SetExistingFilesBitmap: 937->125->125
13.03.2007   09:50:35.000   1173797435   general   GUID: c1a0dcb1-fc4b-4250-a006-1a06e860ca24
13.03.2007   09:50:35.000   1173797435   general   Server definition(s) loaded for 'main': 105 (maintenance:0)
13.03.2007   09:50:35.000   1173797435   general   SelectCurrent: selected server 'Download92 AVAST server' from 'main'
13.03.2007   09:50:35.000   1173797435   package   GetPackages - set proxy for inet
13.03.2007   09:50:35.000   1173797435   internet   SYNCER: Type: use IE settings
13.03.2007   09:50:35.000   1173797435   internet   SYNCER: Auth: another authentication, use WinInet
13.03.2007   09:50:35.000   1173797435   general   Used server: http://download92.avast.com/iavs4x
13.03.2007   09:50:35.000   1173797435   general   Server definition(s) loaded for 'main': 105 (maintenance:0)
13.03.2007   09:50:35.000   1173797435   general   SelectCurrent: selected server 'Download76 AVAST server' from 'main'
13.03.2007   09:50:35.000   1173797435   package   GetPackages - set proxy for inet
13.03.2007   09:50:35.000   1173797435   internet   SYNCER: Type: use IE settings
13.03.2007   09:50:35.000   1173797435   internet   SYNCER: Auth: another authentication, use WinInet
13.03.2007   09:50:36.000   1173797436   general   Used server: http://download76.avast.com/iavs4x
13.03.2007   09:50:36.000   1173797436   general   Used server: http://download76.avast.com/iavs4x
13.03.2007   09:50:36.000   1173797436   general   Part of license key: W34289965H4000A1106
13.03.2007   09:50:36.000   1173797436   package   Load C:\Program Files\Alwil Software\Avast4\Setup\prod-av_pro.vpu
13.03.2007   09:50:36.000   1173797436   package   LatestPartInfo: news = news-4b
13.03.2007   09:50:36.000   1173797436   package   LatestPartInfo: program = prg_av_pro-3ae
13.03.2007   09:50:36.000   1173797436   package   LatestPartInfo: setup = setup_av_pro-3ae
13.03.2007   09:50:36.000   1173797436   package   LatestPartInfo: vps = vps-72301
13.03.2007   09:50:36.000   1173797436   package   FilterOutExistingFiles: 125 & 125 = 0
13.03.2007   09:50:36.000   1173797436   package   FilterOutExistingFiles: 125 & 125 = 0
13.03.2007   09:50:52.000   1173797452   package   vps: same as previous [072301]
13.03.2007   09:50:52.000   1173797452   package   FilterOutExistingFiles: 125 & 125 = 0
13.03.2007   09:50:52.000   1173797452   package   FilterOutExistingFiles: 125 & 125 = 0
13.03.2007   09:50:53.000   1173797453   package   Transferred files: 3
13.03.2007   09:50:53.000   1173797453   package   Transferred bytes: 30
13.03.2007   09:50:53.000   1173797453   package   Transfer time: 496 ms
13.03.2007   09:50:53.000   1173797453   file   NeedReboot=false
13.03.2007   09:50:53.000   1173797453   general   Return code: 0x20000001 [Nothing done]
13.03.2007   09:50:53.000   1173797453   general   Stopped: 13.03.2007, 09:50:53



Offline pjapma

  • Newbie
  • *
  • Posts: 16
Re: No Internet Access
« Reply #12 on: March 13, 2007, 07:58:10 PM »
And for the 2nd: setup\setup.log

13.03.2007   09:50:30.000   1173797430   general   Started: 13.03.2007, 09:50:30
13.03.2007   09:50:30.000   1173797430   general   Running setup_av_pro-3ae (942)
13.03.2007   09:50:30.000   1173797430   system   Operating system: WindowsMe ver 4.90, build 3000 [ ]
13.03.2007   09:50:30.000   1173797430   system   Computer WinName: LAPTOP
13.03.2007   09:50:30.000   1173797430   system   Windows Net User: Peter
13.03.2007   09:50:30.000   1173797430   general   Cmdline: /downloadpkgs /noreboot /silent /progress 
13.03.2007   09:50:30.000   1173797430   general   DldSrc set to inet
13.03.2007   09:50:30.000   1173797430   general   Operation set to INST_OP_UPDATE_GET_PACKAGES
13.03.2007   09:50:30.000   1173797430   general   Old version: 3ae (942)
13.03.2007   09:50:30.000   1173797430   general   SGW32P::CheckIfInstalled set m_bAlreadyInstalled to 1
13.03.2007   09:50:30.000   1173797430   system   Computer DnsName: laptop.gateway.2wire.net
13.03.2007   09:50:30.000   1173797430   system   Computer Ip Addr: 192.168.1.65
13.03.2007   09:50:30.000   1173797430   internet   SYNCER: Type: use IE settings
13.03.2007   09:50:30.000   1173797430   internet   SYNCER: Auth: another authentication, use WinInet
13.03.2007   09:50:30.000   1173797430   package   Part prg_av_pro-3ae is installed
13.03.2007   09:50:30.000   1173797430   package   Part vps-72301 is installed
13.03.2007   09:50:30.000   1173797430   package   Part news-4b is installed
13.03.2007   09:50:30.000   1173797430   package   Part setup_av_pro-3ae is installed
13.03.2007   09:50:30.000   1173797430   general   Old version: 3ae (942)
13.03.2007   09:50:35.000   1173797435   file   SetExistingFilesBitmap: 937->125->125
13.03.2007   09:50:35.000   1173797435   general   GUID: c1a0dcb1-fc4b-4250-a006-1a06e860ca24
13.03.2007   09:50:35.000   1173797435   general   Server definition(s) loaded for 'main': 105 (maintenance:0)
13.03.2007   09:50:35.000   1173797435   general   SelectCurrent: selected server 'Download92 AVAST server' from 'main'
13.03.2007   09:50:35.000   1173797435   package   GetPackages - set proxy for inet
13.03.2007   09:50:35.000   1173797435   internet   SYNCER: Type: use IE settings
13.03.2007   09:50:35.000   1173797435   internet   SYNCER: Auth: another authentication, use WinInet
13.03.2007   09:50:35.000   1173797435   general   Used server: http://download92.avast.com/iavs4x
13.03.2007   09:50:35.000   1173797435   general   Server definition(s) loaded for 'main': 105 (maintenance:0)
13.03.2007   09:50:35.000   1173797435   general   SelectCurrent: selected server 'Download76 AVAST server' from 'main'
13.03.2007   09:50:35.000   1173797435   package   GetPackages - set proxy for inet
13.03.2007   09:50:35.000   1173797435   internet   SYNCER: Type: use IE settings
13.03.2007   09:50:35.000   1173797435   internet   SYNCER: Auth: another authentication, use WinInet
13.03.2007   09:50:36.000   1173797436   general   Used server: http://download76.avast.com/iavs4x
13.03.2007   09:50:36.000   1173797436   general   Used server: http://download76.avast.com/iavs4x
13.03.2007   09:50:36.000   1173797436   general   Part of license key: W34289965H4000A1106
13.03.2007   09:50:36.000   1173797436   package   Load C:\Program Files\Alwil Software\Avast4\Setup\prod-av_pro.vpu
13.03.2007   09:50:36.000   1173797436   package   LatestPartInfo: news = news-4b
13.03.2007   09:50:36.000   1173797436   package   LatestPartInfo: program = prg_av_pro-3ae
13.03.2007   09:50:36.000   1173797436   package   LatestPartInfo: setup = setup_av_pro-3ae
13.03.2007   09:50:36.000   1173797436   package   LatestPartInfo: vps = vps-72301
13.03.2007   09:50:36.000   1173797436   package   FilterOutExistingFiles: 125 & 125 = 0
13.03.2007   09:50:36.000   1173797436   package   FilterOutExistingFiles: 125 & 125 = 0
13.03.2007   09:50:52.000   1173797452   package   vps: same as previous [072301]
13.03.2007   09:50:52.000   1173797452   package   FilterOutExistingFiles: 125 & 125 = 0
13.03.2007   09:50:52.000   1173797452   package   FilterOutExistingFiles: 125 & 125 = 0
13.03.2007   09:50:53.000   1173797453   package   Transferred files: 3
13.03.2007   09:50:53.000   1173797453   package   Transferred bytes: 30
13.03.2007   09:50:53.000   1173797453   package   Transfer time: 496 ms
13.03.2007   09:50:53.000   1173797453   file   NeedReboot=false
13.03.2007   09:50:53.000   1173797453   general   Return code: 0x20000001 [Nothing done]
13.03.2007   09:50:53.000   1173797453   general   Stopped: 13.03.2007, 09:50:53



Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: No Internet Access
« Reply #13 on: March 13, 2007, 11:21:14 PM »
I see no problems with your logs... although I'm not an expert on them  :-[

Sorry, but as your problem is on connection, maybe you could activate logging in WebShield:
1. Edit <avast>\data\avast4.ini file
2. Find the section [WebScanner]
3. Add the line:
    EnableLogging=1
4. Restart Web Shield in XP (terminate and start again) or whole PC in case of Win98
5. Browse (trying to access some webpages)

The log file are <avast>\data\log\ashwebsv.log and ashwebsv.ws.
They would be accessible when WebShield is terminated again.
Post them here or send by mail to rypacek (at) asw.cz
After that, disable the logging to avoid a big log file.
The best things in life are free.

Offline pjapma

  • Newbie
  • *
  • Posts: 16
Re: No Internet Access
« Reply #14 on: March 14, 2007, 02:13:37 PM »
Hi Again,
Thanks for your recent posting.
I'm able to find the files you mention by doing a search on my hard drive "C" but when I open the files up ...it is posted in "notepad".
How am I able to edit and add the requested line.
Regards!