Author Topic: Can someone please tell me how to set this [GrimeFighter]: ScanFrequency=999 in  (Read 1027 times)

0 Members and 1 Guest are viewing this topic.

Offline MikeFromSomeWhere

  • Newbie
  • *
  • Posts: 5
Can someone please tell me how to set this [GrimeFighter]: ScanFrequency=999 in the registry?

It's driving me nuts !!!

I tested a lot of things the past month in search of why my pc lags a lot of time, the answer is Avast!
When i launch battlefield 4, in main menu, avast make my cpu go 100% (not avast alone, bf4 is at abt 50, rest goes up like services and other stuff) but i tested it, and it is avast causing it.
I removed avast completely, ran bf4, cpu usage 25% and no lag at all.
Reinstalled avast.
Found a fix for it, adding punkbuster A & B in whitelist/allowed apps, this fixed my issue, but my other programs i use are still affected, for example my FL Studio, i also tryed to whitelist everything i use a lot, but it does not work at all.
The only thing that helped was for bf4.

Unistalling avast fixes the problem for every program i use, even my desktop and mouse input does not lag anymore ...

Please fix this, this stuff took me months to figure out!
Now i want help to edit registry for [GrimeFighter]: ScanFrequency=999 to see if it fixes my problems.

OS win 7 Ultimate x64 Sp1
CPU Fx 8350 Def 4.0 Ghz
Ram 32 1600
Gpu Radeon VII Def 1800
SSD & HDD
Triple 4k monitor setup. 60hz
Avast FREE 21.4.2464 (build 21.4.6266.561)
(almost everything left on default settings, except ask me what to do when i find virus or malware, and i password protected the app so no changes can be made)
, no Avast Cleanup Tool.
And before you ask, yes everything is updated, and so are the drivers.

Since i have no more avast5.ini file, itryed adding trough win10 on my win7, i could create a new avast5.ini file and add [GrimeFighter]: ScanFrequency=999 in it.
But as soon i boot win 7, the file is gone.

Yes i still use win7 because i have a lot of programs depending on it.

Ya the machine i use is powerful, so avast should be less cpu hungry idk?
I have the same config on win10, there avast for some reason is more stable.

My pc can handle a lot i throw at it, 4k games (latest ones) , real time editing and all stuff like that, but since avast changed something, it all went to crap.
Please understand my months of frustration, i want my pc to perform like it was before.

EDIT : And my Battlefield 4 LAG is BACK. *Frustrated*
So adding punkbuster A & B in whitelist/allowed apps does not fix it ... Or at least it did for 1 time, then back to lagging like crap.
Uninstalled Avast, tryed about 5 times to play it, no lag at all.
Installed avast again, the lag is back again ... pffffff

Can't exactly run my pc without antivirus ... Someone else got the same problem i have?
« Last Edit: May 24, 2021, 03:14:24 PM by MikeFromSomeWhere »

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 76118
  • Urlaub/Vacation
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
- Which Avast..? (Free/Premium)
- Which version/build of Avast..?
- OS..? (32/64 Bit..? - which SP/Build..?)
- Other security related software installed..?
- Which AV(s) did you use before Avast..?
W8.1 [x64] - Avast PremSec 22.7.7366.BC [UI.713] - Firefox ESR 91.11 [NS/uBO/PB] - Thunderbird 91.11
Avast-Tools: Secure Browser 103.0 - Cleanup 22.2 - SecureLine 5.18 - DriverUpdater 22.2 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline MikeFromSomeWhere

  • Newbie
  • *
  • Posts: 5
Avast FREE 21.4.2464 (build 21.4.6266.561) (almost everything left on default settings, except ask me what to do when i find virus or malware, and i password protected the app so no changes can be made)

Win7 Ultimate x64 Sp1 , i do not know where i can find the os buildnumber.

Yes i have other security programs running:
Malwarebytes.
I do not use win deffender or how it's called.

I have the exact same setup on both win 7 and win 10 with the exact same av & amw settings, win 10 runs fine, win7, as soon i install avast, not.
When i used avast before they changed settings to reg instead of ini, i did not have that problem.
I do not remember what avast free build it was back then, but i usualy do not update the engine, only the defenitions, just to avoid problems like this, but one day, avast updated the engine anyway and the troubles started to begin.

Yesterday i did tested out other antiviruses to test if it is avast only and yes it is.
So i removed avast and tested with avg instead, no problem at all, but because i don't like avg, i putted avast back on, because i use avast for 3year+ on al my pc's, with avg i had more problems in the past, that's why i don't like avg.
But i have to say i saw avg & avast looks nearly the same in the UI.
Almost everything is the same, it's like they copy pasted the program or something, except used other logo and a few colors here and there. :/
It's clear that avast has more options then avg.

I also noticed that i have less problems when i run avast in passive mode, i still have lagging spikes but way less.
I also noticed something else, when avast is installed, it produces disk errors on all my drives, so when i boot the next time, it ask to check all the drives for consistency or whatever it's called, when avast is not installed, and i boot up, it does not ask to check for errors.
Also, because i think avast produces disk errors, my system restore won't work until i scanned all the drives for errors witch is very time consuming if you have large drives.


For bf4, i know my cpu usage is roughly 25/50% at max , everything on highest settings 4k 60 hz and stable 60fps. i gamed like this for years, but now avast make it impossible for me, you notice mouse input lag a lot.
not only in gaming but also just on the desktop moving my mouse around.

So what basicly happens with other baground processes, when i launch heavy programs or online games (with nothing else open) :
Services.exe is consuming a lot more then usual, but it also make other processes consume a lot more like for example: displayfusion, speedfan , audiodg.exe , explorer.exe, (those are processes that does not consume a lot at all), but somehow it start to make it uses all 10-15% of cpu per process, + bf4 at 60-70 % (or the other heavy program i wanna use) , so if you add everything up, you got 100% at all time and with very ugly lagging with the mouse.

And yes i did test to recreate everything without avast installed and all the processes i mentioned before are like 0-2% in usage only and nothing lags.

I scanned my computer for virusses - malware - spyware and whatever everything, there is nothing on it at all.
And yes i scanned with a lot of different software to see i maybe one of em missed something, nope nothing at all.

So the software that i tested is:

Avast
Avg
Malwarebytes (this the only one that keeps running in the background) - i also tested with malwarebytes disabled, but avast keeps lagging/freezing everything i do that is a lil bit demanding.
Iobit Malwarebytes
Spybot
Hitmanpro


I never had issues with fl studio before, even with avast on before, reinstalled avast today, now fl studio is almost unusable.
And yes FL Studio can be heavy, it runs a lot of plugins.

It pains to say me but my workflow is almost completely destroyed now because of lagging / freezing issues avast is making.

It also pains me that i have almost no other option then choosing an other av for until its solved, i realy do hate other av's, from all those i ussed, avast has always been the best one.

I also reinstalled a bunch of stuff before because i did not knew avast was causing it,
i reinstalled/updated the following:

Complete mobo drivers
Lan
GPU
USB
Monitors
Mouse (tryed different mouses to since my mouse lags a lot)
Vcredist packs
DirectX11



I try my best to explain a bit what is happening, i hope you got the info you need. Idk how else to explain it.
Believe me when i say my pc can handle a lot but for some reason not anymore now.

i will try and screenshot what is happening with bf4 as example (nothing else open, just bf4, and some background things like speedfan , displayfusion, nothing demanding at all) and see how everything start to consume cpu way more then it should.
I attached a screenshot, not sure if you can see it here.



Offline MikeFromSomeWhere

  • Newbie
  • *
  • Posts: 5
I did the same test again like on the previous ScreenShot, the only difference is that i uninstalled Avast and Installed AVG instead.
Look at the difference.
It's huge, and stable!
No lag at all.
You can clearly see the problems is from Avast.

As you can see in the screenshot, bf4 takes only 20% of my cpu , the background processes consumes nearly nothing.

« Last Edit: May 24, 2021, 08:25:20 PM by MikeFromSomeWhere »

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 7127
  • When you think you know, Think Again
I'm curious, have your uninstalled 'Mbam' in your testing to see if the issue persists with Mbam uninstalled??
***HP ENVY 15K LT W10 Pro 21H2 64Bit/250GB SSD/16GB Ram/ADU v.22.3b/VS/SANDBOXIE-plus/MailWasherPRO
**HP Compaq 8510p LT W10 Pro 21H2 64Bit/1TB HD/8GB Ram/ADU v.22.3b/VS/SANDBOXIE/HotSpot Shield
 Avast Mobile Security (Android)
LAYERED SECURITY SOFTWARE

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86941
  • No support PMs thanks
@  MikeFromSomeWhere
I don't know where you are getting this "[GrimeFighter]" from ?

The actual [GrimeFighter] product no longer exists, it is called Avast Cleanup now and it is a paid product not part of Avast unless you have Avast Ultimate.  Since you have Avast FREE 21.4.2464 (build 21.4.6266.561)  according to the information you gave, you shouldn't have GrimeFighter or Avast Cleanup.  This should be the same in Avast or AVG Free.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.9.6034 (build 22.9.7554.734) UI 1.0.728/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline MikeFromSomeWhere

  • Newbie
  • *
  • Posts: 5
i only looked on google for some answers and almost every thing i visited sayd something about about grimefighter,
not sure what it is or if i have or not but that was the last thing i could think of that i could try, but since it's not in the Free then idk what to do.
And i used to have paid version a while ago for free or trial or whatever it's called for a limited time, so i think there should be maybe something about grimefighter idk?
1 thing i do know is that cleanup tool was installed (at least i think it was cleanup) and it caused problems, like programs not starting up anymore if i remember it right, and since then i make sure it's not installed anymore.
Something is wrong, that i know for sure. And i also had avast for more then 3 years, 6-7 years i think on this pc.

I did test with malware bytes completely disabled (not uninstalled, but every processes shut off), not running at all.

But like you see in the screenies, there is a huge difference and impact, on almost everything i do, the worst thing is the mouse input lag. Prob. because the cpu spikes often.
I'm not an antivirus expert or whatever, but after a few months, i finaly found the problem, i even reinstalled my os backup a few times, all trouble i should not have had in the first place.

Anyway i'm not sure i can help with more info then that guys, that sums about all i know.

Let me know if any of you have similar problems and if you found a fix.

Thx.

Offline MikeFromSomeWhere

  • Newbie
  • *
  • Posts: 5
@  MikeFromSomeWhere
I don't know where you are getting this "[GrimeFighter]" from ?

The actual [GrimeFighter] product no longer exists, it is called Avast Cleanup now and it is a paid product not part of Avast unless you have Avast Ultimate.  Since you have Avast FREE 21.4.2464 (build 21.4.6266.561)  according to the information you gave, you shouldn't have GrimeFighter or Avast Cleanup.  This should be the same in Avast or AVG Free.

a lot of google searches always end up with a page similar to this :

https://www.softlay.com/how-to/fix-avast-service-high-cpu-usage-windows.html

where they say it has something to do maybe with grimefighter whatever that is.

So thats why i wanted to test this if it helps or not, now im not even sure i have this or not in the free version.

So ya, i'm back to square one i guess. :/

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86941
  • No support PMs thanks
Well if you haven't got GrimeFighter or Avast Cleanup installed then it would be a coincidence, but unrelated to GrimeFighter.

So that would lead me to believe that there wouldn't be a registry entry for it, or even by any remote chance there was an entry, it would effectively be inert so changing the value would be very unlikely to mage any difference.

The article also mentions, Remove Avast Cleanup Tool, which you haven't got, nor Have you got 'Avast Premier' (which is an old program/name, Now Avast Premium, which doesn't have Avast CleanUp.  Considering this article is dated Mar 19, 2021, it is peddling old information.

Personally I would completely uninstall MBAM as I don't feel it brings much to the table and unless you set up exclusions in both MBAM and Avast (for each others processes), then conflict could occur.

I would suggest that you do a clean reinstall of Avast.
1. - Download the avast! Uninstall Utility, avastclear.exe https://www.avast.com/uninstall-utility and save it to your HDD. Make a note of the steps required or print the page.
2. - Download the latest Avast off-line installation file for your Avast Program (see https://forum.avast.com/index.php?topic=273698.0) and save to your HDD.

Follow the instructions in the link in 1.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.9.6034 (build 22.9.7554.734) UI 1.0.728/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security