Author Topic: Cannot send receve with Avast email provider on  (Read 19704 times)

0 Members and 1 Guest are viewing this topic.

Offline ThorAsguard

  • Newbie
  • *
  • Posts: 18
Cannot send receve with Avast email provider on
« on: April 14, 2007, 07:49:58 PM »
I use Incredimail and have looked at previous posts but they are full of arguments and no help to the problem as far as I can see. Please can anyone help in getting Avast Pro to allow receive and send of email. If I turn off the Internet mail provider it will then come in and I can then send. I have tried different levels of the security on the email provider and still no help to this problem. I have turned of the add message to the emails and it still makes no difference. I have the latest version of Avast I believe and this is 4.7.942. I also had the same problem with Avast free home. ???

Your help will be much appreciated thank you
ThorAsguard

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re: Cannot send receve with Avast email provider on
« Reply #1 on: April 14, 2007, 08:01:22 PM »
Do you use a firewall?
Which is your Windows?
The best things in life are free.

Offline ThorAsguard

  • Newbie
  • *
  • Posts: 18
Re: Cannot send receve with Avast email provider on
« Reply #2 on: April 15, 2007, 12:38:31 AM »
I use windows xp home and the firewall with it. I have checked windows firewall and it has Incredimail in there allowing it to work.

THANKS

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83749
  • No support PMs thanks
Re: Cannot send receve with Avast email provider on
« Reply #3 on: April 15, 2007, 12:44:57 AM »
I use Incredimail and have looked at previous posts but they are full of arguments and no help to the problem as far as I can see. Please can anyone help in getting Avast Pro to allow receive and send of email.
<snip>

What error messages are you getting ?
If any please post the complete error text or post a screenshot of the error.

What is your ISP ?
Do you have to use SSL/TLS secure encrypted email ?
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline mcmurdo

  • Newbie
  • *
  • Posts: 1
Re: Cannot send receve with Avast email provider on
« Reply #4 on: April 16, 2007, 07:44:57 PM »
I have a similar problem. I just installed avast! 4.7 and have no problem with accessing the internet (using IE 6 and Firefox running under Windows XP Home Edition). However, I can't send or receive email under Outlook Express unless I turn avast! off.

If I can't overcome this problem I'll have to go back to my previous anti-virus program which i don't particularly care for.

Offline oldman

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4143
  • Some days..... MOS...this bug's for you
Re: Cannot send receve with Avast email provider on
« Reply #5 on: April 16, 2007, 07:55:34 PM »
If you have a firewall, does it allow ashmaisv.exe to connect to the internet?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83749
  • No support PMs thanks
Re: Cannot send receve with Avast email provider on
« Reply #6 on: April 16, 2007, 08:06:07 PM »
For the same problem can you answer the same questions asked by Tech and I.

What was your previous AV and how did you get rid of it ?

You don't have to turn off avast, just the Internet Mail provider, leaving the remainder of the avast protection intact. If terminating the Internet Mail provider allows you to send and receive email the likelihood is it is being blocked by your firewall. However, we need your answers to make any determination as to the true cause.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline ThorAsguard

  • Newbie
  • *
  • Posts: 18
Re: Cannot send receve with Avast email provider on
« Reply #7 on: April 19, 2007, 12:39:11 PM »
I have in the internet options ssl2 ssl 3 and tls1 all ticked it is not necessary as far as I know to have them all ticked so please advice. I get no error message when I try to recieve or send when I swith off the internet mail section but I do get one when ever I switch the pc on if the internet mail provider is on if it is off I do not get it so I am waiting to post the screen shot for you when it happens.
Thanks

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83749
  • No support PMs thanks
Re: Cannot send receve with Avast email provider on
« Reply #8 on: April 19, 2007, 02:28:30 PM »
Quote
I have in the internet options ssl2 ssl 3 and tls1 all ticked it is not necessary as far as I know to have them all ticked so please advice.

These are internet explorer options and unrelated to the email SSL/TLS options, check your email account settings. In my IE6 settings only the use ssl2 and ssl3 options are ticked and not use tls1, I don't know if this is different if you are using IE7.

Please, please post the full text or the error message you are receiving when the internet mail provider is enabled, this will hopefully help us to help you. Enable the Internet Mail provider and check for email, that should generate the error rather than wait.

Your firewall should also allow ashMaiSv.exe the avast email scanner.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline Texasborn

  • Newbie
  • *
  • Posts: 2
Re: Cannot send receve with Avast email provider on
« Reply #9 on: April 19, 2007, 02:58:44 PM »
I use Windows ME and have Outlook 2000 and Avast Home Edition.  As of what i assume was the last update, I am now getting the following when trying to open new mail messages of send messages:

"Avast cannot scan the message body.
Error code is 80004005.
Unspecified error
OpenStreamOnFile failed"

also, icon "avast! MS Outlook / Exchange provider" is working is constantly on now, which i don't remember in the past.

If i turn Avast email scanner off, these problems go away

what happened?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83749
  • No support PMs thanks
Re: Cannot send receve with Avast email provider on
« Reply #10 on: April 19, 2007, 03:09:41 PM »
If you can post this in a topic of its own (if my suggestion below doesn't help) as it would appear to be unrelated to the original topic (other that the title).

You don't say what the avast version is, there has been another update, 4.7.986, first do a manual update to that version (right click the avast icon, Updating, Program Update), reboot and test again. There has been one other "Avast cannot scan the message body" topic that I recall, which was resolved by an update to 4.7.986.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline Texasborn

  • Newbie
  • *
  • Posts: 2
Re: Cannot send receve with Avast email provider on
« Reply #11 on: April 19, 2007, 05:09:01 PM »
This indeed corrected the problem.. thanks much David.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83749
  • No support PMs thanks
Re: Cannot send receve with Avast email provider on
« Reply #12 on: April 19, 2007, 05:47:46 PM »
No problem, welcome to the forums.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline ThorAsguard

  • Newbie
  • *
  • Posts: 18
Re: Cannot send receve with Avast email provider on
« Reply #13 on: April 20, 2007, 01:05:21 PM »
Hi I have this log only from 12-13/4

12/04/2007 14:15:51   È‘|xn”`éT   1824   AAVM - initialization error: Unhandled exception in AavmProviderStop [Inner], MAIL. 
13/04/2007 18:33:00   È‘|ph„`é„   1832   AAVM - initialization error: Unhandled exception in AavmProviderStop [Inner], MAIL. 

I cannot remember what I was doing at the time
I am having no errors at the moment and have not had any for over a week now. My ssl settings are not ticked in the email settings I have put in the advanced tab on windows firewall ashMaiSv.exe and avast!antivirus programme. That is all windows firewall has I can add more but not sure if this is what I should be doing.

Quite simply this is obviously an on going problem from many months ago and no-one seems to know anything about it. I do find this quite extraordinary as this problem comes up time and again on here with Incredimail. I am trying my best to help you guy's.

As at the moment i have had the mail provider on for 3 days now not showing errors all it does is carry on scanning and not letting mail in or out. it does not stop it just carries on and on trying to scan in receive. If i pause it it will still not let the mail in or out but if i stop the mail provider I can receive and send. I really do not know what else I can tell you other than try the Incredimail programme yourselves and see if you get the same problem.

What other settings should I be checking in avast if any? Sorry guy's i am trying to help.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83749
  • No support PMs thanks
Re: Cannot send receve with Avast email provider on
« Reply #14 on: April 20, 2007, 03:01:50 PM »
I think we are as baffled as you since the windows firewall effectively doesn't block outbound connections, that may rule out the usual suspect that ashMaiSv.exe is being blocked by your firewall.

What kind of surprises me is you aren't getting any timeout issues as there will be no reply from your ISP email server. Is there any means in Incredimail to set a timeout delay as there is in OE, sorry I can be of no practical help as I have never used Incredimail. You could also enable the timeout in avast, Internet Mail, Customize, Advanced and set as the arrowed options in the image below.

Hopefully this should produce an error/notification pop-up with some information that may be useful.

Is there anything in common about the emails, attachments, large size, etc. that might cause the scanning to take a long time or does this hang occur for all emails, small size, no attachments, etc. ?

Can Incredimail turn off its bells an whistles and just send in text mode, if so try sending in text mode to see if that works. I know that kind of defeats the purpose of having Incredimail, but it will eliminate one possible interaction.

Do you still have another email program, if so testing that to see if it works.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro