Author Topic: Abnormal Behavior  (Read 780 times)

0 Members and 1 Guest are viewing this topic.

Offline chytharo

  • Newbie
  • *
  • Posts: 3
Abnormal Behavior
« on: June 04, 2021, 02:38:05 PM »
Hello,
I regulary have Avast showing some strange behavior since many months now and since it hasn't been fixed so far I thought maybe it's an issue on my end or an unnoticed bug.

Often when my PC is running for some time (around a few days) Avast Service starts showing really high fluctuating CPU usage. Sometimes it is accompanied by sudden RAM usage drops, that happen in intervals of a couple of seconds. Avast runs fine when I restart the PC but it usually starts behaving weirdly again after just a few days.
It makes my whole machine noticably slower and especially the Avast UI itself gets very sluggish: After the abnormal behavior started, if I don't restart the PC, after a week or two it will take around 2-3 minutes just opening the UI by double clicking the Avast logo in the tray. No other program/game/browser behaves like this. It sometimes goes away by itself for a hour or two, but it always starts happening again for many hours on end soon enough.
Here's a video recording of my task manager, so you can see for yourself what I mean (including the sudden RAM fluctuations of the process):
https://www.youtube.com/watch?v=8lz0hsXPxOU

I'm using Avast Free AV 21.4.2464 - the latest version with automatic updates activated on a Windows 8.1 machine. I don't have any other anti-virus programs installed.
Is there some function or setting that could cause this? Is there a way to exactly find out what Avast is using the CPU power for?

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 76125
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Abnormal Behavior
« Reply #1 on: June 04, 2021, 02:46:26 PM »
- Which Avast..? (Free/Premium)
- Which version/build of Avast..?
- OS..? (32/64 Bit..? - which SP/Build..?)
- Other security related software installed..?
- Which AV(s) did you use before Avast..?
W8.1 [x64] - Avast PremSec 22.6.7351.BC [UI.712] - Firefox ESR 91.10 [NS/uBO/PB] - Thunderbird 91.10
Avast-Tools: Secure Browser 102.1 - Cleanup 22.2 - SecureLine 5.18 - DriverUpdater 22.2 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline chytharo

  • Newbie
  • *
  • Posts: 3
Re: Abnormal Behavior
« Reply #2 on: June 04, 2021, 05:45:31 PM »
- Which Avast..? (Free/Premium)
- Which version/build of Avast..?
- OS..? (32/64 Bit..? - which SP/Build..?)
- Other security related software installed..?
- Which AV(s) did you use before Avast..?

I already answered half of these questions in my introduction post.

Regarding the other questions:
I never used any other AV on that machine before or together with Avast. No other security software installed aside from the normal windows firewall that always comes with the OS.
The 8.1 version is 64bit and the normal home version. I don't know where I can see the exact build number, but I have automatic updates activated and on the update history it says it installed the latest updates 2 weeks ago.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86649
  • No support PMs thanks
Re: Abnormal Behavior
« Reply #3 on: June 04, 2021, 08:19:23 PM »
<snip quotes>
The 8.1 version is 64bit and the normal home version. I don't know where I can see the exact build number, but I have automatic updates activated and on the update history it says it installed the latest updates 2 weeks ago.

Press the Windows key and R (run) together and type winver (Windows Version) and it will show the build number.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline chytharo

  • Newbie
  • *
  • Posts: 3
Re: Abnormal Behavior
« Reply #4 on: June 04, 2021, 08:24:16 PM »
Thank you.
It's Version 6.3 (Build 9600).

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86649
  • No support PMs thanks
Re: Abnormal Behavior
« Reply #5 on: June 04, 2021, 09:26:14 PM »
You're welcome.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 76125
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Abnormal Behavior
« Reply #6 on: June 05, 2021, 10:54:22 AM »
1. Download Avast Free Antivirus: https://files.avast.com/iavs9x/avast_free_antivirus_setup_offline.exe
2. Follow instructions: https://www.avast.com/uninstall-utility (Run this tool for all prior installed Avast versions..!!)
3. Reinstall Avast with the downloaded installer from point 1.
4. Reboot.
W8.1 [x64] - Avast PremSec 22.6.7351.BC [UI.712] - Firefox ESR 91.10 [NS/uBO/PB] - Thunderbird 91.10
Avast-Tools: Secure Browser 102.1 - Cleanup 22.2 - SecureLine 5.18 - DriverUpdater 22.2 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0