Author Topic: Date Format  (Read 3693 times)

0 Members and 1 Guest are viewing this topic.

Offline joey_365

  • Jr. Member
  • **
  • Posts: 21
Date Format
« on: February 27, 2004, 02:17:27 PM »
Hi

I have just got the latest updated version of avast, but now my date format has changed. I'm in the uk and my format should be day/month/year. However with the latest update, my format has changed to an american month/day/year format. Is there a way to get my old settings back, or is this the way avast will format my date from now on ??  Its only a small point, but when I attach a note in my emails I would like to see it was scanned using virus database 25/02/2004 and not 02/25/2004.

Regards.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11791
    • AVAST Software
Re:Date Format
« Reply #1 on: February 27, 2004, 02:26:29 PM »
Where exectly did the format change? User interface display, about box, mail inserted notes - or is it everywhere?

Offline joey_365

  • Jr. Member
  • **
  • Posts: 21
Re:Date Format
« Reply #2 on: February 27, 2004, 02:45:02 PM »
Hi igor

It has changed on the main user interface and in the mail notes, but curiously NOT in the vps section in the "about" section. That still says 25/02/2004 but from what I can see, almost everywhere else it says 02/25/2004

Regards.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11791
    • AVAST Software
Re:Date Format
« Reply #3 on: February 27, 2004, 03:10:36 PM »
Well...
Previously, the display of the date was not really correct. Now, it shows the date according to the format specified by Windows. The problem is that the format is used according to the current avast! language setting - and the "English" language in avast! is US - therefore, the US date format is used.
I'll try to think of something to do about it... right now, I'm not sure what it could be, though.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11791
    • AVAST Software
Re:Date Format
« Reply #4 on: February 27, 2004, 04:40:09 PM »
If you wish, you can try the following:
1. Open the file Data\avast4.ini (e.g. in Notepad)
2. Find the section [Languages]
3. Add the following line there: 0809=English
4. Change the line Engine=1033 to Engine=2057.

Now, avast! should use British locale setting (at least I hope so). Note that the avast! setup will probably put the original Engine value back when a next program update is installed.

Offline joey_365

  • Jr. Member
  • **
  • Posts: 21
Re:Date Format
« Reply #5 on: February 27, 2004, 05:04:26 PM »
Igor

Many many thanks ! your solution worked like a charm  ;D There is another setting in the avast4.ini (0409=English) as well as my added one. But as you did not mention to delete that I left it in there. Everything is back to as it was before, many thanks for your efforts.

Regards.