Author Topic: XP upgraded to SP2  (Read 8531 times)

0 Members and 1 Guest are viewing this topic.

Offline lrk1000

  • Jr. Member
  • **
  • Posts: 30
XP upgraded to SP2
« on: May 22, 2007, 03:17:09 PM »
Yesterday, the computer that is running AMS and the admin console was upgraded from WinXP SP1 to SP2.  It looks like the security settings of SP2 are now preventing the clients from connecting to the server. 

The computer discovery task is working on the server, put the clients appear off-line (with the yellow !).

Any ideas on what I need to change on the server computer to get the clients talking again?

Thanks...

Len

anwar_auctions

  • Guest
Re: XP upgraded to SP2
« Reply #1 on: May 23, 2007, 09:41:12 AM »
i also have the same problem. could anybody give me the right solution.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67236
Re: XP upgraded to SP2
« Reply #2 on: May 23, 2007, 05:08:48 PM »
Isn't it a problem into the firewall settings?
Just a guess that I hope could help...
The best things in life are free.

Offline lrk1000

  • Jr. Member
  • **
  • Posts: 30
Re: XP upgraded to SP2
« Reply #3 on: May 23, 2007, 05:17:12 PM »
I've opened up the firewall to aswUpdSv, aswServ and aswWebSv.  But wouldn't that be be for programs on the server getting out.  I'm thinking for programs on the clients trying to talk to the server, I need to open a port?  Didn't I read somewhere that the clients talk via POP protocol?  Do I need to open Port 110?

Anyone familiar with this?  I'm sure others are running the server on XP SP2...

Len

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67236
Re: XP upgraded to SP2
« Reply #4 on: May 24, 2007, 01:13:30 AM »
Into the firewall settings, the following programs should be allowed to connect:

C:\Program Files\Alwil Software\Avast4\ashWebSv.exe (avast! Web Scanner) (allow server rights; access to ports 80, 443; accept connections from localhost on ports 12080)
C:\Program Files\Alwil Software\Avast4\ashMaiSv.exe (avast! e-Mail Scanner Service) (allow email rights: outgoing on ports 110, 25 and 119; accept connections from localhost on ports 12110, 12025, 12119)
C:\Program Files\Alwil Software\Avast4\Setup\avast.setup (avast! Update executable). This is a temporary file that just appears when an update (check) is about to launch, and disappears again afterwards.

Don't need rights to connect:
C:\Program Files\Alwil Software\Avast4\ashServ.exe (avast! antivirus service)
C:\Program Files\Alwil Software\Avast4\aswUpdSv.exe (avast! Update Service)
The best things in life are free.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: XP upgraded to SP2
« Reply #5 on: May 24, 2007, 08:37:44 AM »
You need to open the AMS ports for INBOUND traffic.
Actually, AMS should be doing this automatically during installation... But since you upgraded to XP SP2 AFTER AMS was installed it might have not worked.

Can you please check the current Windows Firewall settings?

Cheers
Vlk

If at first you don't succeed, then skydiving's not for you.

Offline lrk1000

  • Jr. Member
  • **
  • Posts: 30
Re: XP upgraded to SP2
« Reply #6 on: May 24, 2007, 02:42:55 PM »
Thanks for the info...I just want to clear up some items...

1)  My file names begin with asw, not ash.  What is the difference.  Is this an issue?

2)  Vlk, you mention the AMS ports are not opened...what are the port numbers, are they the same as what Tech mentioned above: 80, 443, 12080, 110, 25, 119, 12110, 12025 and 12119?  Any others?

Thanks...

Len

PS, would it be simpler if I just re-installed the server and admin console again?  Would I loose settings?







/
« Last Edit: May 24, 2007, 02:51:58 PM by lrk1000 »

Offline lrk1000

  • Jr. Member
  • **
  • Posts: 30
Re: XP upgraded to SP2
« Reply #7 on: May 24, 2007, 03:30:42 PM »
Ok, I think I got it...

I found documentation that I need tcp/16111 and udp/6000 open on the server.  That seemed to help.  I also had one client that upgraded to SP2.  They still appear as "off-line".  I take it I'll have to open ports on their computer also?  What about 16109?

Len

Offline lrk1000

  • Jr. Member
  • **
  • Posts: 30
Re: XP upgraded to SP2
« Reply #8 on: May 24, 2007, 04:46:32 PM »
One other thing...I see from my firewall log files that all the clients are knocking at the door on Port 5033.  Do I need to open this also?  What is this one for?

Len

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: XP upgraded to SP2
« Reply #9 on: May 25, 2007, 12:40:15 PM »
There's a number of posts describing this. Here's a link to one of them: http://forum.avast.com/index.php?topic=24457.msg200483#msg200483

Please note that these are the ports the program LISTENS ON, i.e. the settings required for INBOUND-ONLY firewall (such as the XP SP2 one). If you have a firewall with inbound AND outbound protection, you need to create additional rules.

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

anwar_auctions

  • Guest
Re: XP upgraded to SP2
« Reply #10 on: May 30, 2007, 12:21:36 PM »
You need to open the AMS ports for INBOUND traffic.
Actually, AMS should be doing this automatically during installation... But since you upgraded to XP SP2 AFTER AMS was installed it might have not worked.

Can you please check the current Windows Firewall settings?

Anwar khan auctions