Author Topic: WinXP64 freezes at login screen  (Read 13487 times)

0 Members and 1 Guest are viewing this topic.

LittleBit

  • Guest
WinXP64 freezes at login screen
« on: June 27, 2007, 02:55:46 PM »
Hi there,

i have a problem with the login to my WinXP64 at the login screen what seemes to me related to Avast! 4.7 Home.

When WinXP64 has booted to the login screen i have a few seconds to select a user profile - when i enter the correkt password the system freezes - no mouse move - no disk activity - no softreboot by external reset.

I can allways login using "last known good configuration" at boottime. So i made a system wide scan - no results.

When i left the computer for a while at login screen (booted without any alternative option) a message has popped up that a process of Avast! has a problem and needs to be closed. I am sorry - i cant really remember the exact message (what a shame).

For testing i deinstalled Avast! - and so the login-problem disappeared. So i hoped this was only a tempory problem with an update and reinstalled Avast! All went fine - for about 3-4 days - and now i am back at the same situation. When i deinstalled Avast! again - all went fine again.

A found an other user with nearly exact the same trouble - and problem started nearly the same time. He also uses WinXP64 and Avast! virus scanner.


Is this a known problem ? Is there a solution to this ? Any suggestions welcome.

Thanks in advance,
Tom

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11811
    • AVAST Software
Re: WinXP64 freezes at login screen
« Reply #1 on: June 27, 2007, 03:08:30 PM »
No, this is certainly not a known issue, avast! should work correctly in WinXP x64.
I'm afraid we'd need some more info... is there anything in system Event Log (some more details about those crashes I mean - addresses, etc.)

LittleBit

  • Guest
Re: WinXP64 freezes at login screen
« Reply #2 on: June 27, 2007, 03:20:17 PM »
Thanks for your fast reply!

The System Event Log gives no hints - only information - some errors related to a unreadable CD.

In the Application Log there are some related to Avast! Allways the exactly the same:

Faulting application avast.setup, version 4.7.0.0, faulting module ntdll.dll, version 5.2.3790.3959, fault address 0x0004d233.


Servicepack2 for WinXP64 is installed - also all critical Updates provided by MS.

Hope that helps a bit more.

Cheers,
Tom

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86506
  • No support PMs thanks
Re: WinXP64 freezes at login screen
« Reply #3 on: June 27, 2007, 04:22:26 PM »
The real culprit is the faulting module ntdll.dll, that avast.setup just happened to be using, though I have no idea how to overcome that.

The avast.setup is the avast update process checking for updates, though why it is happening so early is strange (zero personal experience of XP64), probably you have a broadband connection and avast is trying to get out since the connection is established.

I wonder if editing the C:\Program Files\Alwil Software\Avast4\Data\avast4.ini file (notepad or other text editor) to delay the avast auto update check might help. Add the AlwaysConnectedWaitSeconds=120 (delays by 120 seconds, can be increased, default is 30) in the [InetWD] section of the avast4.ini file.

Quote
[InetWD]
AlwaysConnectedWaitSeconds=120

Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.2.6003 (build 22.2.7013.717) UI 1.0.697/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

LittleBit

  • Guest
Re: WinXP64 freezes at login screen
« Reply #4 on: June 27, 2007, 07:10:42 PM »
@DavidR

I have taken a look into the avast4.ini file. There is no entry AlwaysConnectedWaitSeconds and no group [InetWD]. I have done a fresh install on another machine to check whether this is related only to my own System - the other (XP32) also has none of those entries. Should i add them ? Version in both cases Avast! 4.7.1001 Home. Custom install - no OE-Support - no Skins - the rest by default.

Thanks for your answer,
Tom

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86506
  • No support PMs thanks
Re: WinXP64 freezes at login screen
« Reply #5 on: June 27, 2007, 07:48:28 PM »
There wouldn't be a line for AlwaysConnectedWaitSeconds (there are many default settings that don't appear in the avast4.ini) which is why I said to add it, though for it to have no [InetWD] section is most strange and certainly for winxp32 bit should be there.

You didn't confirm my assumption you connect to the internet using broadband ?
If so, try this, change the avast Program Settings (right click the avast icon) Update (Connections) so that it matches your connection, not both checked or both unchecked, just check the one that matches your connection. That because of the change may generate the [InetWD] section allowing the edit.

I guess it would be possible to create the [InetWD] section and then add the new line, the section is between the [Simple] and [Quick] sections. See an example of my settings, don't replicate mine as I'm on dial-up.

Quote
[Simple]
ShowHelpCheckList=1
SkinUseLayeredWindows=0
TimeOfLastScan=1182645453
[Chest]
MaxSize=512
[InetWD]
UseRAS=1
RASWaitSeconds=120
UpdatePeriod=240
[Quick]
EnableSkins=1
InfectionExitApp=0
ShowResults=1

Yours should/would look like
[InetWD]
AssumeAlwaysConnected=1
AlwaysConnectedWaitSeconds=120
UpdatePeriod=240
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.2.6003 (build 22.2.7013.717) UI 1.0.697/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

LittleBit

  • Guest
Re: WinXP64 freezes at login screen
« Reply #6 on: June 28, 2007, 12:22:43 PM »
Hi David,

i added the missing section by setting "use dialup connection" in the option and then edited with the values you recommended. So i have to wait to see if the application errors disappear.

Thanks for your help,
Tom

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86506
  • No support PMs thanks
Re: WinXP64 freezes at login screen
« Reply #7 on: June 28, 2007, 03:13:05 PM »
Your welcome.

But, are you using dial-up as your connection method (or did you do change it just to create the [IntWD] section) ?

If you are using dial-up then the suggested method won't work, which is why I have been banging on about what your connection method is ?

If it is dial-up then your {InetWD] section should look my example in the "quoted" section of my avast4.ini.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.2.6003 (build 22.2.7013.717) UI 1.0.697/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: WinXP64 freezes at login screen
« Reply #8 on: June 29, 2007, 03:40:18 AM »
No, this is certainly not a known issue, avast! should work correctly in WinXP x64.
I'm afraid we'd need some more info... is there anything in system Event Log (some more details about those crashes I mean - addresses, etc.)
I follow Igor... I can't see a correlation between update period and connection type with avast freezing Windows and ntdll.dll trouble... (By the way, is it ntldr.sys ???)
The best things in life are free.

LittleBit

  • Guest
Re: WinXP64 freezes at login screen
« Reply #9 on: July 04, 2007, 02:37:50 PM »
@DavidR

I am on a broadband connection - so i only used dialup to create the section and then to edit it.

There were no more avast.setup crashes. As they are not so frequently before i am not sure whether it solved that or not - but signs are good. Thanks

@Tech

it is ntdll.dll and not ntldr.sys.
Afaik ntldr.sys is Part of the early boot sequence while ntdll.dll is part of the kernel and is used by many applications.

In another forum i found two users with the same login problem. Both on WinXP64 and avast - one has confirmed to use also SP2 for XP64 - the other has not said about. The one using SP2 for XP64 has also confirmed that there were no problems before installing SP2 (cannot say whether it appears directly after installing SP2). So maybe a interference from SP2 and avast ?

Tom

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: WinXP64 freezes at login screen
« Reply #10 on: July 04, 2007, 03:22:46 PM »
So maybe a interference from SP2 and avast?
Tom, my knowledge does not go so further... we need Alwil team programmers help.
The best things in life are free.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86506
  • No support PMs thanks
Re: WinXP64 freezes at login screen
« Reply #11 on: July 04, 2007, 03:27:33 PM »
@DavidR
I am on a broadband connection - so i only used dialup to create the section and then to edit it.

There were no more avast.setup crashes. As they are not so frequently before i am not sure whether it solved that or not - but signs are good. Thanks
<snp>
Tom

Your welcome, fingers crossed it will remain that way.

Thanks for the feedback.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.2.6003 (build 22.2.7013.717) UI 1.0.697/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

mmmmna

  • Guest
Re: WinXP64 freezes at login screen
« Reply #12 on: July 06, 2007, 07:54:59 PM »
Same issue here: WinXP64Pro, Celeron 64 bit processor (yes, there are such things as 64 bit celerons, search for them before you post), 1 Gig system ram, some system ram is shared to on-board graphics, Avast Home edition installed (registered), worked fine in the beginning, now freezing.

I have some additional information to assist troubleshooters.

1] My PC is never left on all the time, it is powered off until I wish to use it.
When I wish to use the PC, I apply power to the PC, it goes through bootup process (normal for me is GRUB (because I dual boot with Linux), where I manually select Windows XP), booting to the Windows XP welcome screen.

2] From this point, I have 10-20% chance of logging in as my default user without ANY problems.

Important note: the other of the logins all fail no matter which user I elect to log in as.

It was suggested in another forum (TechIMO) that I should try a guest login (possibly they thought my normal user was the problem?). I have had no replies to that thread, after I posted that freezing does not matter which user I select.

3] Actually, the freezing occurs within 5 to 15 seconds of the login screen appearing, so sometimes I can click my icon AND type in my password and then I freeze, sometimes I can't even click my user icon and the system is frozen.

That timing makes me think the failure is NOT a user configuration file (many freezes take place before a user has logged in). To that end, troubleshooting should consider what XP system files are loaded (by windows) before anyone even logs in.

4] I am using SP1 only, it was included with my XP64 CD; no updates are permitted on this machine.

Why? I have heard horror stories about 32 bit XP getting REALLY trashed by service packs, so why would I want to take an even greater risk on updating the LESS popular 64 bit XP?


More:
Presently, I am using a selective startup to disable automatic starting of Avast until I can determine if Avast is the root cause. So far, I have succeeded in logging in once while Avast is not started. But this could also be part of my usual 10 - 20%.

I use DSL.

I use a wireless connection to my wireless router, that connection recently got misconfigured, but is working fine for the past 2 days; today, I had to reboot 6 times, due to freezing at login (I finally chose safe mode and activated the selective startup that I just mentioned). Back when the network was malfunctioning, I was not refused ANY logins, so I'd say the network being functional MIGHT be part of the problem (again, the 10 - 20% success thing might have let me in when the network was malfunctioning).

mmmmna

  • Guest
Re: WinXP64 freezes at login screen
« Reply #13 on: July 08, 2007, 01:14:37 PM »
No ideas, anyone?

(If I did something wrong by ADDING my problem to this persons IDENTICAL problem, maybe someone could PM me to tell me to start a new thread..... or maybe a moderator could split this thread).
« Last Edit: July 08, 2007, 01:16:53 PM by mmmmna »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: WinXP64 freezes at login screen
« Reply #14 on: July 08, 2007, 03:42:50 PM »
2] From this point, I have 10-20% chance of logging in as my default user without ANY problems.
Important note: the other of the logins all fail no matter which user I elect to log in as.
What does happen? Any error message? Can you boot in Safe Mode?

3] Actually, the freezing occurs within 5 to 15 seconds of the login screen appearing, so sometimes I can click my icon AND type in my password and then I freeze, sometimes I can't even click my user icon and the system is frozen.
That timing makes me think the failure is NOT a user configuration file (many freezes take place before a user has logged in). To that end, troubleshooting should consider what XP system files are loaded (by windows) before anyone even logs in.
Any new hardware added?
Any other antivirus installed (besides avast)?

4] I am using SP1 only, it was included with my XP64 CD; no updates are permitted on this machine.
Why can't you update?

Why? I have heard horror stories about 32 bit XP getting REALLY trashed by service packs, so why would I want to take an even greater risk on updating the LESS popular 64 bit XP?
Staying without update is dangerous and will make even unstable your system. I see no special reason for not to update a legit copy of Windows 64x.
The best things in life are free.