Author Topic: Wi-Fi inspector warning - Ignore button does not work.  (Read 2578 times)

0 Members and 1 Guest are viewing this topic.

Offline ddabrahim

  • Jr. Member
  • **
  • Posts: 66
Wi-Fi inspector warning - Ignore button does not work.
« on: August 06, 2021, 03:24:10 PM »
Hi.

Recently the Wi-Fi inspector warned me about my router is not secure because a port is open.
After investigation by my ISP and the Avast team, my ISP did reply that while they do understand why Avast consider the port being open is a security risk, they have no security concerns about it because of security measures they have in place to protect the port from being used in a malicious way.

Because it seems I've been using this router like this with the port being open for many years without any problems, for now I have no plans to take any immediate actions to resolve this problem that Avast is reporting.
So in the Wi-Fi inspector I have selected to 'Ignore' this warning after which the warning was labelled as 'Ignored' and was told a rescan of the network is required. However, after scanning the network again the warning comes back like before, nothing seems to change. What I was expecting to happen is that Avast no longer warn me about this port being open and report that my router is secure. But of course I would still want it to warn me if there is any other problem with the router or any other ports, but I prefer not to see any more warning regarding this particular port being open.

I don't know if its a bug or not.
In case it is not a bug and 'Ignore' only stop notifications about this problem, I would like to request the feature to also stop any red warning displayed in the GUI and report that the router is secure as normal and maybe just let me know in the device informations I have this warning ignored but only if I open the device info. Otherwise tell me it is secure, no problems. It is to avoid missing any other problems because of being used to see a red warning all the time.

Using Avast Premium Security 14.10 (ddd643fc9a1d)
macOS 11.5.1
This is the particular option I am referring to:


Thanks.
« Last Edit: August 07, 2021, 10:53:10 AM by ddabrahim »

Offline Radek Brich

  • Developer (Linux AV, Mac AV)
  • Moderator
  • Jr. Member
  • *
  • Posts: 56
Re: Wi-Fi inspector warning - Ignore button does not work.
« Reply #1 on: August 11, 2021, 06:23:25 AM »
Hi, thanks for the report. Currently, the ignored status is not remembered, but it's meant to work as you describe - the problem won't be reported anymore, when ignored. We have this feature planned for next release.

Offline ddabrahim

  • Jr. Member
  • **
  • Posts: 66
Re: Wi-Fi inspector warning - Ignore button does not work.
« Reply #2 on: August 11, 2021, 09:29:36 PM »
Thank you for the reply, it is sounds great!