Author Topic: Cannot turn Web Shield on  (Read 6116 times)

0 Members and 1 Guest are viewing this topic.

Offline peter952

  • Newbie
  • *
  • Posts: 9
Cannot turn Web Shield on
« on: August 31, 2021, 10:02:09 AM »
I have the exact same problem described at https://forum.avast.com/index.php?topic=238932.0
- A scan says there is one risk, that Web Shield is turned off
- It says to go into Accessibility settings, select Avast Mobile Security and "Turn the switch on".

That makes no sense. As per the other post, when I go to Settings then Accessibility (Samsung Galaxy S9, Android 10) there is no option to select any app or turn anything on. Accessibility on my phone and in that other post is all about things to do with helping blind and deaf people use the phone. Things like Visibility and Hearing enhancements and Interaction and Dexterity.

When I search in settings for Accessibility nothing else useful comes up.

Can someone please explain in detail which accessibility setting it it talking about and what I have to do to enable web shield.

Offline r@vast

  • Avast team
  • Super Poster
  • *
  • Posts: 2293
Re: Cannot turn Web Shield on
« Reply #1 on: August 31, 2021, 12:02:21 PM »
I have the exact same problem described at https://forum.avast.com/index.php?topic=238932.0
- A scan says there is one risk, that Web Shield is turned off
- It says to go into Accessibility settings, select Avast Mobile Security and "Turn the switch on".

That makes no sense. As per the other post, when I go to Settings then Accessibility (Samsung Galaxy S9, Android 10) there is no option to select any app or turn anything on. Accessibility on my phone and in that other post is all about things to do with helping blind and deaf people use the phone. Things like Visibility and Hearing enhancements and Interaction and Dexterity.

When I search in settings for Accessibility nothing else useful comes up.

Can someone please explain in detail which accessibility setting it it talking about and what I have to do to enable web shield.


Hi,

It is the correct location. Please scroll to the bottom and look for "installed services"

Offline peter952

  • Newbie
  • *
  • Posts: 9
Re: Cannot turn Web Shield on
« Reply #2 on: September 03, 2021, 12:06:49 AM »
That was the missing information that I needed thank you.
I think you should update the instructions to add the requirement to select Installed Services.

Offline r@vast

  • Avast team
  • Super Poster
  • *
  • Posts: 2293
Re: Cannot turn Web Shield on
« Reply #3 on: September 03, 2021, 11:38:45 AM »
That was the missing information that I needed thank you.
I think you should update the instructions to add the requirement to select Installed Services.

Hi,

Thank you for your suggestion.
Our developers will look into improving the instructions.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86498
  • No support PMs thanks
Re: Cannot turn Web Shield on
« Reply #4 on: September 03, 2021, 12:24:35 PM »
That was the missing information that I needed thank you.
I think you should update the instructions to add the requirement to select Installed Services.

Hi,

Thank you for your suggestion.
Our developers will look into improving the instructions.

On this subject, I get lots of notifications on this very issue.

But a visit to Accessibility > Installed Services > Avast Mobile Security - it is ON.

Point:
Is this only about the Avast Mobile Security or Specifically for the Web Shield.
My reasoning for this is that I still get notifications that the Web shield is off, even when this setting it ON.
Is this a big fat false negative or a bug ?

This issue has plagued me for a very long time.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.2.6003 (build 22.2.7013.717) UI 1.0.697/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline rocksteady

  • Super Poster
  • ***
  • Posts: 1270
Re: Cannot turn Web Shield on
« Reply #5 on: September 03, 2021, 02:55:04 PM »
That was the missing information that I needed thank you.
I think you should update the instructions to add the requirement to select Installed Services.

Hi,

Thank you for your suggestion.
Our developers will look into improving the instructions.

On this subject, I get lots of notifications on this very issue.

But a visit to Accessibility > Installed Services > Avast Mobile Security - it is ON.

Point:
Is this only about the Avast Mobile Security or Specifically for the Web Shield.
My reasoning for this is that I still get notifications that the Web shield is off, even when this setting it ON.
Is this a big fat false negative or a bug ?

This issue has plagued me for a very long time.

+1
« Last Edit: September 03, 2021, 02:56:56 PM by rocksteady »

Offline r@vast

  • Avast team
  • Super Poster
  • *
  • Posts: 2293
Re: Cannot turn Web Shield on
« Reply #6 on: September 03, 2021, 03:14:17 PM »

On this subject, I get lots of notifications on this very issue.

But a visit to Accessibility > Installed Services > Avast Mobile Security - it is ON.

Point:
Is this only about the Avast Mobile Security or Specifically for the Web Shield.
My reasoning for this is that I still get notifications that the Web shield is off, even when this setting it ON.
Is this a big fat false negative or a bug ?

This issue has plagued me for a very long time.

Hi,

If you experience this issue repeatedly, the issue is caused by a bug in Android, not the application.

Generally, if a background running app gets killed, in that case, Android automatically removes the Accessibility permission, and the user has to grant the Accessibility permission again (usually turn it off and back on). The only way to prevent this from happening is to "protect" the app from being killed. In most cases, the "Power saving features" (implemented by the manufacturer) are behind this "killing".
Depending on your make and model, you might have to Switch Power Saving Modes to Off and also add the app to No restrictions in "Background Settings" (this is only general information)

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86498
  • No support PMs thanks
Re: Cannot turn Web Shield on
« Reply #7 on: September 03, 2021, 07:10:46 PM »
Yes repeatedly on two phones Samsung A51 and backup Samsung A12.

The A51 is my main phone and has a sim card, the A12 has no sim and I use that when I go out for my daily exercise (GPS and fitness App).
Generally I only connect via WiFi at home and rarely on the A51, when I'm out I generally don't use the phone for browsing, calls and texts only.

Both of these phones are on Android 11, the strange thing is this seems only to be on the Samsung A51 phone (not the Samsung A12). I also had it on my Nexus 6P primary phone before I replaced it with the A51.

I can't understand why there would be a difference in the A51 and A12, Samsung general settings.

I think you can understand why users would blame Avast Mobile Security as there doesn't seem to be any clear explanation on why it might happen and how to clearly resolve it. 

All this back and forth only to find it is still a big fat Red Circle, trying the options you mentioned and have even just done a system restart!
A couple of back and forth actions, so much so that I really don't know how, but it is now enabled  :(
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.2.6003 (build 22.2.7013.717) UI 1.0.697/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline r@vast

  • Avast team
  • Super Poster
  • *
  • Posts: 2293
Re: Cannot turn Web Shield on
« Reply #8 on: September 07, 2021, 06:00:49 PM »
Yes repeatedly on two phones Samsung A51 and backup Samsung A12.

The A51 is my main phone and has a sim card, the A12 has no sim and I use that when I go out for my daily exercise (GPS and fitness App).
Generally I only connect via WiFi at home and rarely on the A51, when I'm out I generally don't use the phone for browsing, calls and texts only.

Both of these phones are on Android 11, the strange thing is this seems only to be on the Samsung A51 phone (not the Samsung A12). I also had it on my Nexus 6P primary phone before I replaced it with the A51.

I can't understand why there would be a difference in the A51 and A12, Samsung general settings.

I think you can understand why users would blame Avast Mobile Security as there doesn't seem to be any clear explanation on why it might happen and how to clearly resolve it. 

All this back and forth only to find it is still a big fat Red Circle, trying the options you mentioned and have even just done a system restart!
A couple of back and forth actions, so much so that I really don't know how, but it is now enabled  :(

Hi,

Each vendor decides what type of battery saving techniques to apply to its device, and they can even differ based on the model. You sometimes need to go through a few optimization apps to resolve the issue.  The battery-saving settings you apply can sometimes be overwritten after a firmware, App or OS update.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86498
  • No support PMs thanks
Re: Cannot turn Web Shield on
« Reply #9 on: September 07, 2021, 09:14:14 PM »
Yes repeatedly on two phones Samsung A51 and backup Samsung A12.

The A51 is my main phone and has a sim card, the A12 has no sim and I use that when I go out for my daily exercise (GPS and fitness App).
Generally I only connect via WiFi at home and rarely on the A51, when I'm out I generally don't use the phone for browsing, calls and texts only.

Both of these phones are on Android 11, the strange thing is this seems only to be on the Samsung A51 phone (not the Samsung A12). I also had it on my Nexus 6P primary phone before I replaced it with the A51.

I can't understand why there would be a difference in the A51 and A12, Samsung general settings.

I think you can understand why users would blame Avast Mobile Security as there doesn't seem to be any clear explanation on why it might happen and how to clearly resolve it. 

All this back and forth only to find it is still a big fat Red Circle, trying the options you mentioned and have even just done a system restart!
A couple of back and forth actions, so much so that I really don't know how, but it is now enabled  :(

Hi,

Each vendor decides what type of battery saving techniques to apply to its device, and they can even differ based on the model. You sometimes need to go through a few optimization apps to resolve the issue.  The battery-saving settings you apply can sometimes be overwritten after a firmware, App or OS update.


There doesn't seem to be any consistency (but the instructions on how to fix given in the web shield is off, isn't at all clear) between my two phones.

Samsung A51, with sim card on board always has a Red circle (with fig 1) over the avast screen icon, even though the Web Shield is supposedly on, on the checks I have done.
Samsung A12, no sim card, same settings (as far as I can tell (having taken time to try and get them that way), not that installation of Avast Mobile Security hasn't got that notification.

Before replying here I ran a couple of tests on the A12 (the Realtime Protection settings are the same as the A51), connecting to several sites via WiFi and went back to check the My Statistics, and 0 Zero web sites scanned. 

Yet the My Statistics on the A51 has 5 sites scanned, but this mobile is the one that has a virtual permanent notification on the application icon. That often tells me the Web Shield is disabled.  I didn't see anywhere to zero these stats so I could run tests.

I would hazard a guess probably incorrect (as there is nothing to indicate this) is that the WiFi connections going through my modem/router are being scanned anyway ?
Essentially both connect via WiFi (on my desktops modem/router) as I rarely use my sim card (data allowance) to connect to the internet
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.2.6003 (build 22.2.7013.717) UI 1.0.697/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline r@vast

  • Avast team
  • Super Poster
  • *
  • Posts: 2293
Re: Cannot turn Web Shield on
« Reply #10 on: September 08, 2021, 11:18:45 AM »
There doesn't seem to be any consistency (but the instructions on how to fix given in the web shield is off, isn't at all clear) between my two phones.

Samsung A51, with sim card on board always has a Red circle (with fig 1) over the avast screen icon, even though the Web Shield is supposedly on, on the checks I have done.
Samsung A12, no sim card, same settings (as far as I can tell (having taken time to try and get them that way), not that installation of Avast Mobile Security hasn't got that notification.

Before replying here I ran a couple of tests on the A12 (the Realtime Protection settings are the same as the A51), connecting to several sites via WiFi and went back to check the My Statistics, and 0 Zero web sites scanned. 

Yet the My Statistics on the A51 has 5 sites scanned, but this mobile is the one that has a virtual permanent notification on the application icon. That often tells me the Web Shield is disabled.  I didn't see anywhere to zero these stats so I could run tests.

I would hazard a guess probably incorrect (as there is nothing to indicate this) is that the WiFi connections going through my modem/router are being scanned anyway ?
Essentially both connect via WiFi (on my desktops modem/router) as I rarely use my sim card (data allowance) to connect to the internet

Hi,

There is, unfortunately, no consistency because of the difference in Android versions and the device make and models. In Avast Mobile Security, the instructions for enabling "Accessibility" are general for this very reason.  Our developers are looking into ways of improving the instructions.

Concerning the scanned websites, they are scanned and counted only if the Web Shield is on. For this, you need to:
have the feature on
have the accessibility on
use a compatible browser
If there is still zero, then the pages are not scanned/checked by Web Shield.
It may be that on your A12, the accessibility is off (because of the power saving), or you used a browser that does not work with Web Shield.
For battery saving settings, you might find this useful https://support.avast.com/en-ww/article/Prevent-stop-Android-app/
https://dontkillmyapp.com/

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86498
  • No support PMs thanks
Re: Cannot turn Web Shield on
« Reply #11 on: September 08, 2021, 12:15:14 PM »
<snip quote>
Hi,

There is, unfortunately, no consistency because of the difference in Android versions and the device make and models. In Avast Mobile Security, the instructions for enabling "Accessibility" are general for this very reason.  Our developers are looking into ways of improving the instructions.

Concerning the scanned websites, they are scanned and counted only if the Web Shield is on. For this, you need to:
have the feature on
have the accessibility on
use a compatible browser
If there is still zero, then the pages are not scanned/checked by Web Shield.
It may be that on your A12, the accessibility is off (because of the power saving), or you used a browser that does not work with Web Shield.
For battery saving settings, you might find this useful https://support.avast.com/en-ww/article/Prevent-stop-Android-app/
https://dontkillmyapp.com/

That's the problem, the Web Shield appears to be on. 

Even when there is the Red or Orange circle with the figure 1 on the Avast icon, when I open avast there are no notifications and the web shield appears to be on.

Unfortunately the support article hasn't been updated for Android 11 on the Samsung section.

EDIT: See this from the don't kill my app link about samsungs deep sleep - https://dontkillmyapp.com/samsung

EDIT2: my default browser is Firefox.
« Last Edit: September 09, 2021, 02:52:22 AM by DavidR »
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.2.6003 (build 22.2.7013.717) UI 1.0.697/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline r@vast

  • Avast team
  • Super Poster
  • *
  • Posts: 2293
Re: Cannot turn Web Shield on
« Reply #12 on: September 10, 2021, 01:43:44 PM »

That's the problem, the Web Shield appears to be on. 

Even when there is the Red or Orange circle with the figure 1 on the Avast icon, when I open avast there are no notifications and the web shield appears to be on.

Unfortunately the support article hasn't been updated for Android 11 on the Samsung section.

EDIT: See this from the don't kill my app link about samsungs deep sleep - https://dontkillmyapp.com/samsung

EDIT2: my default browser is Firefox.

Hi,

Are you referring to this (as in the attachment)?
If something else, please attach a screenshot.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86498
  • No support PMs thanks
Re: Cannot turn Web Shield on
« Reply #13 on: September 10, 2021, 05:32:52 PM »
Yes, the Avast Mobile Security on my Home screen (as I don't have any of the other products installed (so no Avast Group).
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.2.6003 (build 22.2.7013.717) UI 1.0.697/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline r@vast

  • Avast team
  • Super Poster
  • *
  • Posts: 2293
Re: Cannot turn Web Shield on
« Reply #14 on: September 13, 2021, 12:59:49 PM »
Yes, the Avast Mobile Security on my Home screen (as I don't have any of the other products installed (so no Avast Group).

This only means that there is one notification displayed, it does not imply that Web Shield is not working.
Please visit this website (in Google Chrome) to test Web Shield: https://web-shield-test.avast.com/