Author Topic: Avast! creates sav*.tmp files with Autocad 2006  (Read 10255 times)

0 Members and 1 Guest are viewing this topic.

beacharch

  • Guest
Avast! creates sav*.tmp files with Autocad 2006
« on: August 30, 2007, 05:20:01 PM »
Every time I save a drawing in Autocad, a seperate sav*.tmp file appears in the drawing directory.  The drawing (*.dwg) gets saved and a backup file (*.bak) is created; which is suppose to happen.  Avast! creates an additional sav*.tmp file.  I turned off avast! and no file was created; turned it back on and a new tmp file was created.  Is there a fix for this? ???

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11848
    • AVAST Software
Re: Avast! creates sav*.tmp files with Autocad 2006
« Reply #1 on: August 30, 2007, 05:25:17 PM »
Unfortunatelly, I have no explanation why those files are created...  but if the file is really called sav*, it's not created by avast!; there's no such filemask anywhere in the program.
It could be possible that it's actually created by Autocad when it's saving the file, and then avast! somehow prevents it from being deleted - though I've never seen anything like that.

Could you take a FileMon session of the file save operation? It might give some hints about what's going on there.
(http://www.microsoft.com/technet/sysinternals/FileAndDisk/Filemon.mspx)

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 88786
  • No support PMs thanks
Re: Avast! creates sav*.tmp files with Autocad 2006
« Reply #2 on: August 30, 2007, 05:34:46 PM »
avast doesn't create files in user folders so I have no idea where this file is coming from despite your saying it doesn't happen when avast is stopped.

avast uses the _avast4_ folder in the Temp location to unpack archive files so the contents can be scanned these take the form of unp?????.tmp where ????? is a numeric value. The only other file it sort of creats is when you choose to move/rename a file detected as infected when it creates yourfilename.exe.vir in the <avast4>\DATA\Moved folder.

I did a google search for sav*.tmp and it returns many hits, http://www.google.com/search?q=sav*.tmp

This seems relevant as it mentions the sav###.tmp file remains if the save fails, http://discussion.autodesk.com/thread.jspa?threadID=343773
Quote
I also scanned our networks for SAV###.tmp files since December 31, 2003,
approximately when we began to use AutoCAD 2004. This file should be renamed
to Filename.dwg if the save is completely successful. The number of
SAV##.tmp files is also large. One reason we have so many and have not lost
many dwg files may be that the users get an error message if they fail on a
regular save or a Qsave. When they see the message, they can save again
until they are successful.

Also http://discussion.autodesk.com/thread.jspa?messageID=5051611
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.1.6099 (build 24.1.8821.762) UI 1.0.796/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

beacharch

  • Guest
Re: Avast! creates sav*.tmp files with Autocad 2006
« Reply #3 on: August 30, 2007, 07:00:22 PM »
Thanks for your input.  Apparently, Autodesk has had this type of issue for some time and no one really know why.  I tried excluding the file location and the file types in avast! and I still get the sav###.tmp files.  I just have to delete them until Autodesk comes up with a solution.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 88786
  • No support PMs thanks
Re: Avast! creates sav*.tmp files with Autocad 2006
« Reply #4 on: August 30, 2007, 07:55:54 PM »
No problem, though it is strange that whilst avast disabled they don't occur.

The only thing I can think of (even then I can't understand why it would happen) is before an executable is run avast would scan it, perhaps this very short pause is enough for autodesk to fail to save. Though I find this very hard to believe.

I don't know what files you tried to exclude or if you excluded them in the Standard Shield which is the correct place. I don't know anything about autodesk so if you can find out the file that does the saving qsave (?) you could try excluding that to see if it works. But you may be left with no option other than what you said, periodically delete the sav###tmp files.

Welcome to the forums.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.1.6099 (build 24.1.8821.762) UI 1.0.796/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline SpeedyPC

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3398
  • Avast shall conquer the whole world
Re: Avast! creates sav*.tmp files with Autocad 2006
« Reply #5 on: August 30, 2007, 11:49:53 PM »
I'm a AutoCAD operator been using CAD for more than 12yrs, AutoCAD can get very mix up saving in Autosave *.sav in the normal default temp directory.

To try and keep the *.sav file well away for the normal MS window temp directory, please follow my instruction.

1. Create an C:\Autosave directory on your HD which every your AutoCAD is installed on what drive.

2. Go into AutoCAD and click on the tools pull menu and click on options.

3. Pick the files Tab next to display tab on your left (Files) and pick Support File Search Path.

4. Scroll down and look for Automatic Save File Location, change the Temp directory save location to C:\Autosave.

5. Scroll down and look for Temporary Drawing File Location, change the Temp directory save location to C:\Autosave.

6. Scroll down and look for Temporary External Reference File Location, change the Temp directory save location to C:\Autosave.

7. Check to make sure you have complete instruction 4, 5 and 6 before you click the apply tab button and then click.

This should keep well away from the normal MS Window default temp directory, and you shouldn't have a problem between Avast and AutoCAD.

Autodesk cannot explain this problem and why it just the way AutoCAD been setup at the default installation of AutoCAD.
Gigabyte 670 LGA1200 Full ATX MB | Intel Core i9-13900 CPU/LGA 1700 | GeForce Nvidia RTX-4070/12GB | 32GB DDR4 | 2 x 1TB Samsung SSD | W11 Home 64bit | Avast Premium v23.11.6090 | Avast SecureLine VPN | Avast Secure Browser | Avast Driver Updater | Avast BreachGuard | Firefox 64bit | MalwareBytes Premium | Adguard Premium | CCleaner Portable | Macrium Reflect | 7-Zip

paulp192

  • Guest
Re: Avast! creates sav*.tmp files with Autocad 2006
« Reply #6 on: June 29, 2009, 04:14:46 PM »
Gent's I have discovered an effective work around for this issue ;D that stops Avast trying to scan the dwg files to be written.

1) you click on the avast icon in the system tray and select the 'standard shield'.
2) Click on the 'customize' button
3) select the 'Scanner (Advanced)' tab
4) Under 'Scan Selected File' select the 'Selected Files' (this will deselect the 'All Files' check box)
5) tick the 'Default Files' check box
6) close & close

Done Avast will no longer try to scan dwg files to be written ;D

And done

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 88786
  • No support PMs thanks
Re: Avast! creates sav*.tmp files with Autocad 2006
« Reply #7 on: June 29, 2009, 04:40:22 PM »
What you are suggesting I believe is the default setting for the Standard Shield (on Normal sensitivity), see image. So it looks like you previously tweaked the avast settings setting sensitivity to High.

By changing to All files, this changes the sensitivity setting to High, see image2, not what it would have been by default 'Normal' and 'Only files with selected extension.'

So if a user wants to have a Higher level of security then excluding the files as previously mentioned is the only way to achieve this.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.1.6099 (build 24.1.8821.762) UI 1.0.796/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security