Author Topic: Web Protection doesn't work with WIN 98?  (Read 5709 times)

0 Members and 1 Guest are viewing this topic.

waw

  • Guest
Web Protection doesn't work with WIN 98?
« on: September 10, 2007, 05:25:44 PM »
Hi,

anyone here who runs avast under WIN 98?
I can download "wicked" files without getting a warning.
Do I have some wrong adjustment, or is it a well-known bug with the old WIN 98 system?

Best regs from Germany,
Wolf


Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 87433
  • No support PMs thanks
Re: Web Protection doesn't work with WIN 98?
« Reply #1 on: September 10, 2007, 06:36:15 PM »
In win9x you need to manually set your browser to use the web shield proxy.

For IE - broadband users: - Tutorial - Web Shield Proxy Set-up for IE
For IE - dialup users - Tutorial - Web Shield Proxy Set-up for IE (Dial-up)
For Firefox users - Tutorial - Web Shield Proxy Set-up for Firefox

See extract of avast help file image below.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.1.6049 (build 23.1.7883.774) UI 1.0.746/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

waw

  • Guest
THX a lot - but it still doesn't work. There are ...
« Reply #2 on: September 10, 2007, 08:24:31 PM »
... still no warnings (I'm using Firefox and the Eicar test downloads which trigger the alarm on my Win XP laptop quite well).

Any other idea? Do I have to change settings in my router as well, or what might be the reason?

Sincerely,
Wolf

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67212
Re: Web Protection doesn't work with WIN 98?
« Reply #3 on: September 10, 2007, 08:35:01 PM »
... still no warnings
But did you change the proxy settings?

Any other idea? Do I have to change settings in my router as well, or what might be the reason?
Generally, router has nothing to do with WebShield working...
The best things in life are free.

waw

  • Guest
Of course I did, I even ...
« Reply #4 on: September 10, 2007, 08:42:22 PM »
... restarted Firefox. No effect :(

What now, der Tech?

Sincerely,
Wolf

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 87433
  • No support PMs thanks
Re: Web Protection doesn't work with WIN 98?
« Reply #5 on: September 10, 2007, 08:43:08 PM »
I doubt you have to change anything in your router.

So if you click on this link nothing happens -  Web Shield Test - http://www.eicar.org/download/eicar.com.

Does your firefox setting look like this, see image ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.1.6049 (build 23.1.7883.774) UI 1.0.746/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

waw

  • Guest
Roger - everything ...
« Reply #6 on: September 10, 2007, 09:32:39 PM »
... set as shown in the "instructions movie" ;) Eicar does not trigger the alarm with Firefox. I doublechecked twice ;)

I set Internet Explorer (which I don't usually use) with the shown settings and it quite well does trigger the alarm with the Eicar test file!

But I need to use it with Firefox - pleaaaase ;)

Am I the only one in this forum having this problem with Win 98?

Sincerely,
Wolf

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67212
Re: Web Protection doesn't work with WIN 98?
« Reply #7 on: September 10, 2007, 09:50:29 PM »
... set as shown in the "instructions movie" ;) Eicar does not trigger the alarm with Firefox. I doublechecked twice ;)
Did you boot after changing proxy settings?
Do you use any firewall?
The best things in life are free.

waw

  • Guest
Yes and yes, I ...
« Reply #8 on: September 10, 2007, 10:05:54 PM »
... did a reboot and I switched Kerio Firewall off and I disabled all the addons in Firefox, such as LayerBlock and NoScript - it still doesn't ring the alarm from the Eicar File :(

It works fine with Internet Explorer on Win 98, it works fine with Win XP on the laptop - so the router surely can't be the reason.

End of ideas? ;)

Sincerly,
Wolf

waw

  • Guest
And now - without further ado - it SUDDENLY works. Seems ...
« Reply #9 on: September 10, 2007, 10:26:49 PM »
... as if it took the system some time to grip the new settings - which to me seems totally unlogical ;))

And before it hooked in, all the weblinks to images went away and reappeared after a new start of firefox! Windows IS Magic, definetely :)

ThX @ all helpers and goodbye (for now ;)

Wolf

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11657
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Web Protection doesn't work with WIN 98?
« Reply #10 on: September 10, 2007, 10:28:12 PM »
Maybe just the browser cache...? (i.e. Firefox was satisfying the requests from the cache, because you recently visited them)
If at first you don't succeed, then skydiving's not for you.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67212
Re: Web Protection doesn't work with WIN 98?
« Reply #11 on: September 10, 2007, 10:34:26 PM »
Just for asking... did you UNCHECK the option for scanning local communication?
The best things in life are free.

waw

  • Guest
@ VLK: Indeed, now that ...
« Reply #12 on: September 10, 2007, 10:46:03 PM »
... you mention it: I did do :-) one of my regular cache-emptyings! So, after all, no magic at all!?

Have a nice day (or night?)
Wolf (Germany)

waw

  • Guest
@ TECH: Now idea what you're ...
« Reply #13 on: September 10, 2007, 10:51:42 PM »
... talking about, sorry ;-)

maybe it's because I've the German version of AVAST? But i cannot figur out what "Local Communication" might be.

I've 3 modules/"providers" installed:

- Internet Mail
- Standard-Schutz/Protection
- Web-Schutz/Protection

The last two mentioned are active. Or did you mean s.th. totally different?

Best regs,
Wolf

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67212
Re: Web Protection doesn't work with WIN 98?
« Reply #14 on: September 10, 2007, 11:02:54 PM »
Web-Schutz/Protection
WebShield basic tab of settings...
The best things in life are free.