Author Topic: Ashserv.exe - application error {fixed}  (Read 14358 times)

0 Members and 1 Guest are viewing this topic.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Ashserv.exe - application error
« Reply #15 on: September 14, 2007, 11:39:38 PM »
Nothing in my log or anything. I might have to uninstall avast and install avg or something. Thanks
It's a pity... but I can't guess what's wrong...
Please, post the last 100-150 lines of avast log: C:\Program Files\Alwil Software\Avast4\DATA\log\Setup.log
The best things in life are free.

Nogard

  • Guest
Re: Ashserv.exe - application error
« Reply #16 on: September 14, 2007, 11:47:56 PM »
14:48:23 vrb/reg  Set registry: SYSTEM\CurrentControlSet\Services\avast! Mail Scanner\Description=Implements mail scanning for avast! antivirus.
14:48:23 vrb/sys  Service avast! Mail Scanner updated
14:48:23 vrb/sys  Reboot set by changed resident C:\WINDOWS\system32\drivers\aswTdi.sys
14:48:23 vrb/sys  Driver file copied: C:\WINDOWS\system32\drivers\aswTdi.sys
14:48:23 vrb/reg  Set registry: SYSTEM\CurrentControlSet\Services\aswTdi\DisplayName=avast! Network Shield Support
14:48:23 vrb/reg  Set registry: SYSTEM\CurrentControlSet\Services\aswTdi\ErrorControl=1
14:48:23 vrb/reg  Set registry: SYSTEM\CurrentControlSet\Services\aswTdi\Type=1
14:48:23 vrb/reg  Set registry: SYSTEM\CurrentControlSet\Services\aswTdi\Group=PNP_TDI
14:48:23 vrb/reg  Set registry: SYSTEM\CurrentControlSet\Services\aswTdi\Start=1
14:48:23 nrm/sys  Service 'aswTdi' load order set id=268435456 in group 'PNP_TDI'
14:48:23 vrb/reg  Set registry: SYSTEM\CurrentControlSet\Services\avast! Web Scanner\Description=Implements web (HTTP) scanning for avast! antivirus.
14:48:23 vrb/sys  Service avast! Web Scanner installed
14:48:23 vrb/sys  Service avast! Web Scanner dependency avast! Antivirus
14:48:23 vrb/reg  Set registry: SYSTEM\CurrentControlSet\Services\avast! Web Scanner\Description=Implements web (HTTP) scanning for avast! antivirus.
14:48:23 vrb/sys  Service avast! Web Scanner updated
14:48:23 vrb/reg  Set registry: SYSTEM\CurrentControlSet\Services\aswRdr\DisplayName=aswRdr
14:48:23 vrb/reg  Set registry: SYSTEM\CurrentControlSet\Services\aswRdr\ErrorControl=1
14:48:23 vrb/reg  Set registry: SYSTEM\CurrentControlSet\Services\aswRdr\Type=1
14:48:23 vrb/reg  Set registry: SYSTEM\CurrentControlSet\Services\aswRdr\Start=3
14:48:23 vrb/reg  Set registry: SYSTEM\CurrentControlSet\Services\aswRdr\Group=PNP_TDI
14:48:23 vrb/fil  Shortcut for ashAvast.exe installed in C:\Documents and Settings\All Users\Start Menu\Programs\avast! Antivirus
14:48:23 vrb/fil  Shortcut for help.chm installed in C:\Documents and Settings\All Users\Start Menu\Programs\avast! Antivirus
14:48:24 vrb/fil  Shortcut for ashAvast.exe installed in C:\Documents and Settings\All Users\Desktop
14:48:24 vrb/reg  Set registry: *\shellex\ContextMenuHandlers\avast\(null)={472083B0-C522-11CF-8763-00608CC02F24}
14:48:24 vrb/reg  Set registry: avast\ShellEx\ContextMenuHandlers\(null)={472083B0-C522-11CF-8763-00608CC02F24}
14:48:24 vrb/reg  Set registry: Folder\shellex\ContextMenuHandlers\avast\(null)={472083B0-C522-11CF-8763-00608CC02F24}
14:48:24 vrb/reg  Set registry: CLSID\{472083B0-C522-11CF-8763-00608CC02F24}\(null)=avast
14:48:24 vrb/reg  Set registry: CLSID\{472083B0-C522-11CF-8763-00608CC02F24}\InProcServer32\(null)=C:\Program Files\Alwil Software\Avast4\ashShell.dll
14:48:24 vrb/reg  Set registry: CLSID\{472083B0-C522-11CF-8763-00608CC02F24}\InProcServer32\ReleaseName=C:\Program Files\Alwil Software\Avast4\ashShell.dll
14:48:24 vrb/reg  Set registry: CLSID\{472083B0-C522-11CF-8763-00608CC02F24}\InProcServer32\ThreadingModel=Apartment
14:48:24 vrb/reg  Set registry: SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved\{472083B0-C522-11CF-8763-00608CC02F24}=avast
14:48:24 vrb/reg  Set registry: SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved\{472083B0-C522-11CF-8763-00608CC02F24}=avast
14:48:24 vrb/reg  Set registry: Software\Microsoft\Windows\CurrentVersion\Run\avast!=C:\PROGRA~1\ALWILS~1\Avast4\ashDisp.exe
14:48:24 vrb/fil  Fix security on: C:\Program Files\Alwil Software\Avast4\*.*
14:48:24 vrb/fil  Fix security on: C:\Program Files\Alwil Software\Avast4\ENGLISH\*.*
14:48:24 vrb/fil  Fix security on: C:\Program Files\Alwil Software\Avast4\ENGLISH\HELP\*.*
14:48:24 vrb/fil  Fix security on: C:\Program Files\Alwil Software\Avast4\ENGLISH\HtmlData\*.*
14:48:24 vrb/fil  Fix security on: C:\Program Files\Alwil Software\Avast4\images\*.*
14:48:24 vrb/reg  Set registry: Software\Microsoft\Windows\CurrentVersion\Uninstall\avast!\DisplayName=avast! Antivirus
14:48:24 vrb/reg  Set registry: Software\Microsoft\Windows\CurrentVersion\Uninstall\avast!\DisplayVersion=4.7
14:48:24 vrb/reg  Set registry: Software\Microsoft\Windows\CurrentVersion\Uninstall\avast!\HelpLink=http://www.avast.com
14:48:24 vrb/reg  Set registry: Software\Microsoft\Windows\CurrentVersion\Uninstall\avast!\HelpTelephone=
14:48:24 vrb/reg  Set registry: Software\Microsoft\Windows\CurrentVersion\Uninstall\avast!\UrlInfoAbout=http://www.avast.com
14:48:24 vrb/reg  Set registry: Software\Microsoft\Windows\CurrentVersion\Uninstall\avast!\UrlUpdateInfo=http://www.avast.com
14:48:24 vrb/reg  Set registry: Software\Microsoft\Windows\CurrentVersion\Uninstall\avast!\InstallLocation=C:\PROGRA~1\ALWILS~1\Avast4
14:48:24 vrb/reg  Set registry: Software\Microsoft\Windows\CurrentVersion\Uninstall\avast!\InstallSource=C:\DOWNLO~1
14:48:24 vrb/reg  Set registry: Software\Microsoft\Windows\CurrentVersion\Uninstall\avast!\Publisher=Alwil Software
14:48:24 vrb/reg  Set registry: Software\Microsoft\Windows\CurrentVersion\Uninstall\avast!\VersionMajor=4
14:48:24 vrb/reg  Set registry: Software\Microsoft\Windows\CurrentVersion\Uninstall\avast!\VersionMinor=7
14:48:24 vrb/reg  Set registry: Software\Microsoft\Windows\CurrentVersion\Uninstall\avast!\DisplayIcon=C:\Program Files\Alwil Software\Avast4\ashAvast.exe
14:48:24 vrb/reg  Set registry: Software\Microsoft\Windows\CurrentVersion\Uninstall\avast!\UninstallString=rundll32 C:\PROGRA~1\ALWILS~1\Avast4\Setup\setiface.dll,RunSetup
14:48:25 vrb/gen  License key generated Demo
14:56:48 vrb/reg  Set registry: Software\Alwil Software\Avast\4.0\Label=Sep2007
14:56:48 vrb/reg  Set registry: Software\Alwil Software\Avast\4.0\Avast4DataFolder=C:\Program Files\Alwil Software\Avast4\DATA
14:56:48 vrb/reg  Set registry: Software\Alwil Software\Avast\4.0\Avast4SkinFolder=C:\Program Files\Alwil Software\Avast4\DATA\Skin
14:56:48 vrb/reg  Set registry: Software\Alwil Software\Avast\4.0\Version=4.7
14:56:48 vrb/reg  Set registry: Software\Alwil Software\Avast\4.0\VersionShort=4.7
14:56:48 vrb/reg  Set registry: Software\Alwil Software\Avast\4.0\SetupVersion=1043
14:56:49 nrm/pkg  Transferred files: 11
14:56:49 nrm/pkg  Transferred bytes: 16070319
14:56:49 nrm/pkg  Transfer time: 140 ms
14:56:49 vrb/fil  NeedReboot=true
14:56:49 vrb/sys  Reboot set by filRenameOnReboot(C:\Program Files\Alwil Software\Avast4\Setup\reboot.txt,)
14:56:49 vrb/fil  MoveFileEx(C:\PROGRA~1\ALWILS~1\Avast4\Setup\reboot.txt, NULL)
14:56:49 min/gen  Return code: 0x20000000 [Something done]
14:56:49 min/gen  Stopped: 14.09.2007, 14:56:49



Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Ashserv.exe - application error
« Reply #17 on: September 15, 2007, 12:50:25 AM »
14:48:25 vrb/gen  License key generated Demo
How many times did you install the Trial version?
How long are you using it?
The best things in life are free.

Nogard

  • Guest
Re: Ashserv.exe - application error
« Reply #18 on: September 15, 2007, 01:11:56 AM »
I uninstalled Avast a few times and reinstalled it. I never put in my Registration yet.

I never used the demo version that long. Before I update to the latest version, I didn't even use the demo when I installed it a 4 weeks ago. I registered it and had no problem. I get message through Avast update that there was a new version out. I tried to update through the updating tool but it wouldn't let me for some reason. So I down loaded a new version, uninstalled the old version, reboot, cleaned up what was left, reboot and re-installed the new version I started to get the error message.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Ashserv.exe - application error
« Reply #19 on: September 15, 2007, 03:56:24 PM »
I didn't even use the demo when I installed it a 4 weeks ago.
It does not matter if you use (on-demand scanning) but the installation itself is considered as an use (on-access). If you install / uninstall / install again, you will have only 6 days of trial period.
Can you add your Home registration key and see if you can update?
The best things in life are free.

Nogard

  • Guest
Re: Ashserv.exe - application error
« Reply #20 on: September 15, 2007, 04:03:55 PM »
I didn't even use the demo when I installed it a 4 weeks ago.
It does not matter if you use (on-demand scanning) but the installation itself is considered as an use (on-access). If you install / uninstall / install again, you will have only 6 days of trial period.
Can you add your Home registration key and see if you can update?
Yeah I can update with the key in, it's asking me to reboot after the update though. I'm going to reboot and see what happens.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Ashserv.exe - application error
« Reply #21 on: September 15, 2007, 04:06:25 PM »
Yeah I can update with the key in, it's asking me to reboot after the update though. I'm going to reboot and see what happens.
Indeed, this should happen after first update...
The best things in life are free.

Nogard

  • Guest
Re: Ashserv.exe - application error
« Reply #22 on: September 15, 2007, 04:17:43 PM »
OK, I rebooted and I still get the error message.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Ashserv.exe - application error
« Reply #23 on: September 15, 2007, 04:40:03 PM »
Strange... Is there any other security program that could be interfering?
Firewall? HIPS protection?
It could sound stupid, but can't you try an installation from the scratch:

1. Uninstall avast from Control Panel first.
2. Boot.
3. Use Avast Uninstall for complete uninstallation.
4. Boot.
5. Install again the last version.
6. Boot.
7. Check and post the results.
The best things in life are free.

Nogard

  • Guest
Re: Ashserv.exe - application error
« Reply #24 on: September 15, 2007, 04:46:22 PM »
I have Outpost firewall installed. Should I try shutting that down while I do an install? I got xpsmoker installed along with Spybot s&d, but they don't run in the background.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Ashserv.exe - application error
« Reply #25 on: September 15, 2007, 05:36:00 PM »
I have Outpost firewall installed. Should I try shutting that down while I do an install? I got xpsmoker installed along with Spybot s&d, but they don't run in the background.
XPSmoker is a tweaker tool, isn't it?
It won't be bad if you disable Outpost firewall and test... but, for sure, something is blocking low level activity of avast and you're receiving an error. The difficult for us is to guess what is doing that...
The best things in life are free.

Nogard

  • Guest
Re: Ashserv.exe - application error
« Reply #26 on: September 15, 2007, 05:51:48 PM »
I did all that was said to do in the other post you posted. I even went as far as disabling outpost on startup and I still get the error.

Yes XP Smoker is a tweaking tool. But I have nothing else that is running that could mess with it. I don't know what it could be.

Nogard

  • Guest
Re: Ashserv.exe - application error
« Reply #27 on: September 15, 2007, 11:09:41 PM »
Anyone know if it's a registry thing? If so what kind? I scanned through what I have running in the background and all I have is Outpost firewall running.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 87304
  • No support PMs thanks
Re: Ashserv.exe - application error
« Reply #28 on: September 15, 2007, 11:21:11 PM »
Did you try the troubleshooting option I suggested way back when.

<snip>
Edit: Something I just thought of, that light bulb moment. If you can get in and open the Program Settings, Troubleshooting, check the 'Delay loading of avast services after other system services' and see if that has any effect.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.12.6044 (build 22.12.7758.768) UI 1.0.741/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Nogard

  • Guest
Re: Ashserv.exe - application error
« Reply #29 on: September 16, 2007, 01:24:22 AM »
Did you try the troubleshooting option I suggested way back when.

<snip>
Edit: Something I just thought of, that light bulb moment. If you can get in and open the Program Settings, Troubleshooting, check the 'Delay loading of avast services after other system services' and see if that has any effect.

I did that, I still get the error message at the log in screen. But after check marking that, I get to keep avast opened but still not resident though. It has a little red circle with a line through it at the bottom left corner.