Author Topic: I am unable to connect to run avast update, please help  (Read 2913 times)

0 Members and 1 Guest are viewing this topic.

Offline rkhou

  • Newbie
  • *
  • Posts: 1
I am unable to connect to run avast update, please help
« on: December 02, 2007, 08:21:45 PM »
Here is the log, any input will be appreciated.

02.12.2007 13:15:33 general: Started: 02.12.2007, 13:15:33
02.12.2007 13:15:33 general: Running setup_av_pro-413 (1043)
02.12.2007 13:15:33 system: Operating system: WindowsXP ver 5.1, build 2600, sp 2.0 [Service Pack 2]
02.12.2007 13:15:33 system: Computer WinName: GREG
02.12.2007 13:15:33 system: Windows Net User: GREG\Owner
02.12.2007 13:15:33 general: Cmdline: /downloadpkgs /noreboot /updatevps /silent /progress 
02.12.2007 13:15:33 general: DldSrc set to inet
02.12.2007 13:15:33 general: Operation set to INST_OP_UPDATE_GET_PACKAGES
02.12.2007 13:15:33 general: Old version: 413 (1043)
02.12.2007 13:15:33 general: SGW32P::CheckIfInstalled set m_bAlreadyInstalled to 1
02.12.2007 13:15:33 system: Computer DnsName: Greg
02.12.2007 13:15:33 system: Computer Ip Addr: 192.168.79.7
02.12.2007 13:15:33 internet: SYNCER: Type: use IE settings
02.12.2007 13:15:33 internet: SYNCER: Auth: another authentication, use WinInet
02.12.2007 13:15:33 package: Part prg_av_pro-413 is installed
02.12.2007 13:15:34 package: Part vps-77301 is installed
02.12.2007 13:15:34 package: Part news-4b is installed
02.12.2007 13:15:34 package: Part setup_av_pro-413 is installed
02.12.2007 13:15:34 package: Part jrog-15 is installed
02.12.2007 13:15:34 general: Old version: 413 (1043)
02.12.2007 13:15:35 file: SetExistingFilesBitmap: 1045->145->145
02.12.2007 13:15:35 general: GUID: e5f32cc3-5ab4-4685-973d-56b8618b487e
02.12.2007 13:15:35 general: Server definition(s) loaded for 'main': 3 (maintenance:0)
02.12.2007 13:15:35 general: SelectCurrent: selected server 'Test (external beta 2)' from 'main'
02.12.2007 13:15:35 package: GetPackages - set proxy for inet
02.12.2007 13:15:35 internet: SYNCER: Type: use IE settings
02.12.2007 13:15:35 internet: SYNCER: Auth: another authentication, use WinInet
02.12.2007 13:15:35 general: Entered SetupProcessPro::Do( INST_OP_UPDATE_GET_PACKAGES )
02.12.2007 13:15:35 general: Entered SetupProcessWin32Avast::Do( INST_OP_UPDATE_GET_PACKAGES )
02.12.2007 13:15:35 general: Entered SetupProcessWin32::Do( INST_OP_UPDATE_GET_PACKAGES )
02.12.2007 13:15:35 general: Entered SetupProcess::Do( INST_OP_UPDATE_GET_PACKAGES )
02.12.2007 13:15:35 general: progress thread start
02.12.2007 13:15:36 general: progress start - 1
02.12.2007 13:15:36 general: progress start - 2
02.12.2007 13:15:59 package: ERROR:HttpGetWininet, catch returned 0x00002EE7
02.12.2007 13:16:17 package: ERROR:HttpGetWininet, catch returned 0x00002EE7
02.12.2007 13:16:17 general: InvalidateCurrent: invalidated server 'Test (external beta 2)' from 'main'
02.12.2007 13:16:17 general: SelectCurrent: selected server 'Test (external beta)' from 'main'
02.12.2007 13:16:17 package: GetPackages - set proxy for inet
02.12.2007 13:16:17 internet: SYNCER: Type: use IE settings
02.12.2007 13:16:17 internet: SYNCER: Auth: another authentication, use WinInet
02.12.2007 13:16:17 internet: while trying to get file 'servers.def.vpu', error 0x20000004 has occured, try 1
02.12.2007 13:16:35 package: ERROR:HttpGetWininet, catch returned 0x00002EE7
02.12.2007 13:16:35 general: InvalidateCurrent: invalidated server 'Test (external beta)' from 'main'
02.12.2007 13:16:35 general: SelectCurrent: unable to find any suitable server in 'main'
02.12.2007 13:16:35 internet: while trying to get file 'servers.def.vpu', error 0x20000004 has occured, try 2
02.12.2007 13:16:35 internet: tried 2 servers to get file 'servers.def.vpu', but failed (0x20000004)
02.12.2007 13:16:35 file: GetNewerStampedFile:GetFileWithRetry failed: C:\DOCUME~1\Owner\LOCALS~1\Temp\_av_proI.tm~a02548\onefile, servers.def.vpu, error: 0x20000004
02.12.2007 13:16:35 package: Download servers.def, servers.def.vpu failed with error 0x20000011.
02.12.2007 13:16:53 package: ERROR:HttpGetWininet, catch returned 0x00002EE7
02.12.2007 13:17:10 package: ERROR:HttpGetWininet, catch returned 0x00002EE7
02.12.2007 13:17:10 general: InvalidateCurrent: invalidated server 'Test (external beta)' from 'main'
02.12.2007 13:17:10 general: SelectCurrent: unable to find any suitable server in 'main'
02.12.2007 13:17:10 internet: while trying to get file 'servers.def', error 0x20000004 has occured, try 1
02.12.2007 13:17:10 internet: tried 1 servers to get file 'servers.def', but failed (0x20000004)
02.12.2007 13:17:10 file: GetNewerStampedFile:GetFileWithRetry failed: C:\DOCUME~1\Owner\LOCALS~1\Temp\_av_proI.tm~a02548\onefile, servers.def, error: 0x20000004
02.12.2007 13:17:10 package: Tried to download servers.def but failed with error 0x20000004.
02.12.2007 13:17:10 general: progress end - 1
02.12.2007 13:17:10 general: progress end - 0
02.12.2007 13:17:10 general: progress thread end

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67255
Re: I am unable to connect to run avast update, please help
« Reply #1 on: December 02, 2007, 09:53:34 PM »
0x20000004 is difficult to debug.

1) If your subscription allows the update right now (i.e., if it is not expired). Home (free) version need registering each 14 months.

2) If your firewall settings and allow avast.setup to connect.
    If you're not sure, just turn off your firewall (to be sure the update failure is not due to it).
    Maybe you should 'remove' avast.setup entry, try to update, receiving a new alert from the firewall, allowing it and checking it to remember.

3)  Check your proxy settings into avast!:
     Left click the avast icon > Settings
     Update (Basic) > Details > Proxy
     Make sure your browser is not set to "Work Offline" (this option is generally in the File menu).
     If it doesn't help, try switching from "Auto-detect" to "No proxy" (I'm assuming you're not connecting to the Internet via proxy).

4) Also you can try changing update service's login account, follow this:
    Open services control panel (e.g. Start->Run, and type: services.msc
    Double-click on avast! iAVS4 Control Service to show properties. Switch to LogOn page.
    Enter administrator account name and password.
    Do the same for avast! Antivirus service.
    Then start update again.

5) The last option, check if the servers.def file is corrupt or 0KB (C:\Program Files\Alwil Software\Avast4\Setup\servers.def).
    You can try and download the servers.def file, http://files.avast.com/iavs4x/servers.def and replace the one in the avast setup folder.
The best things in life are free.