Author Topic: AAVM Subsystem detected a RPC error  (Read 15051 times)

0 Members and 1 Guest are viewing this topic.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67236
Re: AAVM Subsystem detected a RPC error
« Reply #30 on: December 05, 2007, 08:42:06 PM »
You can, probably, still have an infection, probably a rootkit on your system that is killing avast.

See http://forum.avast.com/index.php?topic=26554.0
http://forum.avast.com/index.php?topic=25941.0

http://research.pandasoftware.com/blogs/research/archive/2006/12/14/Rootkit-cleaner.aspx
http://www.f-secure.com/blacklight/try_blacklight.html

After running the above rootkit tools if nothing is found try these.
If you haven't already got this software (freeware), download, install, update and run it, preferably in safe mode.
AVG anti-spyware or SUPERantispyware or Spyware Terminator.
The best things in life are free.

hotmog

  • Guest
Re: AAVM Subsystem detected a RPC error
« Reply #31 on: December 06, 2007, 03:42:33 PM »
You can, probably, still have an infection, probably a rootkit on your system that is killing avast.

See http://forum.avast.com/index.php?topic=26554.0
http://forum.avast.com/index.php?topic=25941.0

http://research.pandasoftware.com/blogs/research/archive/2006/12/14/Rootkit-cleaner.aspx
http://www.f-secure.com/blacklight/try_blacklight.html

After running the above rootkit tools if nothing is found try these.
If you haven't already got this software (freeware), download, install, update and run it, preferably in safe mode.
AVG anti-spyware or SUPERantispyware or Spyware Terminator.

I already have AVG anti-spyware, which I run daily, also Ad-Aware, Spywareblaster and Spybot. I also downloaded and ran AVG anti-rootkit, which found nothing. I have just finished running Trend Micro HouseCall, which again found no viruses or malware, just 9 items of gray/spyware which it deleted, and 3 so-called security vulnerabilities relating to Microsoft patches dating back to 2001 which have long since been subsumed within SP2.

Still no sign of the red circle, so I am inclined to think that whatever was responsible on my pc has now been shuffled off.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67236
Re: AAVM Subsystem detected a RPC error
« Reply #32 on: December 06, 2007, 09:00:51 PM »
Still no sign of the red circle
If you have ashserv.exe running in background (process), probably everything is all right...
The best things in life are free.