Author Topic: Avast killing internet speed  (Read 12069 times)

0 Members and 1 Guest are viewing this topic.

Offline avastnoob

  • Newbie
  • *
  • Posts: 14
Avast killing internet speed
« on: December 07, 2007, 08:58:49 PM »
Hi everyone

I have only just started using Avast having converted from Norton and am generally quite impressed. However, I am finding that the Webshield is reducing my internet speed by 5 to 6 Mb/s. If I turn the webshield off it goes back up to full speed (20Mb). Does anyone know why this is the case and if there are any settings I can alter to reduce the impact on download speeds.

Cheers

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Avast killing internet speed
« Reply #1 on: December 07, 2007, 09:38:43 PM »
It shouldn't have that much impact...
Do you have any other security program?
Did you fully uninstall Norton using Norton Removal Tool for Windows 2000/XP/Vista?
I'm an ex-NAV too...
Welcome to avast forums.
The best things in life are free.

Offline avastnoob

  • Newbie
  • *
  • Posts: 14
Re: Avast killing internet speed
« Reply #2 on: December 07, 2007, 10:52:16 PM »
I Installed a new HDD and a fresh reinstall of windows last weekend. NAV was on the old disk but decided with the new install to try Avast after reading good reviews of it. I am using Comodo Firewall but the problem is definitely webshield as if I disable comodo I still suffer the 5 to 6 Mb swing turning webshield on or off

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Avast killing internet speed
« Reply #3 on: December 08, 2007, 12:57:39 AM »
Maybe you can activate logging in WebShield:
1. Edit <avast>\data\avast4.ini file
2. Find the section [WebScanner]
3. Add the line:
    EnableLogging=1
4. Restart Web Shield in XP (terminate and start again) or whole PC in case of Win98
5. Browse (trying to access some webpages)

The log file are <avast>\data\log\ashwebsv.log and ashwebsv.ws.
They would be accessible when WebShield is terminated again.
Post them here or send by mail to rypacek (at) asw.cz
After that, disable the logging to avoid a big log file.
The best things in life are free.

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: Avast killing internet speed
« Reply #4 on: December 08, 2007, 02:15:29 AM »
We have not had this report in a while so I have not tested my experience with the latest release of avast.

I just did.  Admittedly my stated download speed is slower than yours (my ISP boosts the early part of downloads and at that point I regularly measure >20Mbps download speeds).

I just downloaded the same 20Mb file from the same website twice (using http).

1) on a connection not scanned by avast average speed 1459.7 Kilobytes/sec
2) on a connection scanned by avast average speed 1487.76 Kilobyte/sec

I won't blame avast for the speed increase while it is scanning. 

This is running the Webshield at normal sensistivity.  What sensistivity have you selected?     

Offline avastnoob

  • Newbie
  • *
  • Posts: 14
Re: Avast killing internet speed
« Reply #5 on: December 09, 2007, 08:26:25 PM »
Maybe you can activate logging in WebShield:
1. Edit <avast>\data\avast4.ini file
2. Find the section [WebScanner]
3. Add the line:
    EnableLogging=1
4. Restart Web Shield in XP (terminate and start again) or whole PC in case of Win98
5. Browse (trying to access some webpages)

The log file are <avast>\data\log\ashwebsv.log and ashwebsv.ws.
They would be accessible when WebShield is terminated again.
Post them here or send by mail to rypacek (at) asw.cz
After that, disable the logging to avoid a big log file.

Hi

Thanks. I have done that but no ashwebsv.log file was produced. There is a file there called ashwebsv.ws but it is 0kb and empty

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Avast killing internet speed
« Reply #6 on: December 10, 2007, 01:53:57 AM »
Thanks. I have done that but no ashwebsv.log file was produced. There is a file there called ashwebsv.ws but it is 0kb and empty
If you done it right, most probably WebShield is not scanning because it's not working. Are you sure you're Norton clean? I mean, no remains of Norton were left in your computer?
The best things in life are free.

Offline avastnoob

  • Newbie
  • *
  • Posts: 14
Re: Avast killing internet speed
« Reply #7 on: December 10, 2007, 08:24:03 PM »
Finally got it to save a log (.log file only - the .ws file is still empty) and have e-mailed it to the address above

This is a fresh install of windows on a new HDD so there are no left over traces of Norton. The scanner is set to normal sensitivity.

Cheers

Offline lukor

  • Avast team
  • Super Poster
  • *
  • Posts: 1877
    • AVAST Software
Re: Avast killing internet speed
« Reply #8 on: December 10, 2007, 08:48:31 PM »
Hello avastnoob,

surely, avast! WebShield is an extra step in your downloads, so it is possible you will notice some delays. Especially if you create a large number of connections (hundreds) as some speed test do, you may observe some slowdowns - but transfer rates during continuous downloads should be limited only by the avast! engine power (and as the scanning during downloads is performed only in the memory, it is much faster than 20Mbps on today's systems). Judging from your log, your connections are reused successfully and several requests are handled on one HTTP connection - so I don't think there is anything strange happening that may indicate you have a problem.

How did you observe the slowdown? Is there a special file you are downloading where the slowdown is visible? Can you perform a similar test as Alanrf and post here the times and URL of the file your are testing?

Lukas

Offline lukor

  • Avast team
  • Super Poster
  • *
  • Posts: 1877
    • AVAST Software
Re: Avast killing internet speed
« Reply #9 on: December 10, 2007, 09:27:03 PM »
Hi,

I've just made some test on our local network. Dowloading 200MB file with and without WebShield.

using wget:

With webshield: 48.12 MB/s or 46.42 MB/s
Without webshield: 56.64 MB/s but also 42 MB/s

well, there seems to be a slight slowdown, however, in these speeds the current load on the server HD and disk cache contents is relevant.

(we are talking about 384 Mbps with WebShield enabled)

The same file in Firefox downloads (according to the download manager) first at about 8000KB/sec and ends at the speed 3950KB/sec -- with or without WebShield - don't ask we why.

Offline avastnoob

  • Newbie
  • *
  • Posts: 14
Re: Avast killing internet speed
« Reply #10 on: December 12, 2007, 07:46:49 PM »
Here are the results for the download of a 200Mb file with webshield on and then off. As you can see it is one helluva difference

With webshield On

226 Transfer complete.
197163008 bytes received in 140.06Seconds 1407.68Kbytes/sec.
quit
221 Goodbye.
18:38
12/12/2007


With webshield off

226 Transfer complete.
97163008 bytes received in 83.55Seconds 2359.93Kbytes/sec.
quit
221 Goodbye.
18:40
12/12/2007



Offline lukor

  • Avast team
  • Super Poster
  • *
  • Posts: 1877
    • AVAST Software
Re: Avast killing internet speed
« Reply #11 on: December 12, 2007, 08:15:19 PM »
Hmmm, interesting though is the fact that "226 Transfer complete" and "221 Goodbye" seems exactly like FTP status messages? Or am I mistaken?

If not, well, how do you force FTP client to use WebShield as it's proxy? WebShield does not support FTP command interface, only FTP-over-HTTP but that certainly does not support commands like GET or QUIT....

Offline avastnoob

  • Newbie
  • *
  • Posts: 14
Re: Avast killing internet speed
« Reply #12 on: December 13, 2007, 02:44:04 PM »
Doh! Yes you are right. It was a small file passed to me by my ISP some time ago when I was having problems with download speeds following upgrades to 20Mb. Thinking about it it is an FTP download.

Why then is webshield affecting it as further tests I did last night all showed similar results i.e. a severe drop in download speed with webshield on.

I will try and download HTTP next time I am at my home PC and post the results

Thanks for your help so far

Offline avvidro

  • Jr. Member
  • **
  • Posts: 75
  • I'm not a llama!
Re: Avast killing internet speed
« Reply #13 on: December 13, 2007, 02:52:15 PM »
I'm experiencing that webshield slowing down internet speed, but I didn't any measure as I notice it in just web navigation. When I stop Webshield provider the whole thing noticably accelerates again.

The slow down got more power since the last "microsoft patch tuesday", so it may be a clue.

Offline avastnoob

  • Newbie
  • *
  • Posts: 14
Re: Avast killing internet speed
« Reply #14 on: December 13, 2007, 08:08:55 PM »
Ok, just downloaded the Microsoft Office 2003 Service Pack 3 at 117.7MB from MS website

With webshield ON it took 66 secs

With webshield OFF it took 52 secs
« Last Edit: December 13, 2007, 08:10:29 PM by avastnoob »