Author Topic: [SOLVED] Avast One CPU Usage spike causing games to stutter  (Read 1372 times)

0 Members and 1 Guest are viewing this topic.

Offline redinel.amestir

  • Newbie
  • *
  • Posts: 1
Hi there, I have an issue with Avast One chugging CPU during gameplay and causing stutter every 5-10min for about 3-5sec :(
Here are requested details for my PC and Avast

- Windows 10 x64 21H1
- Intel(R) Core(TM) i7-8700K CPU 3.70GHz  @ 4.90 GHz // RTX 2080Ti 12GB // 32GB RAM DDR4
- Avast One ver. 22.6.6022 - build 22.6.7355.731
- Avast settings you changed from default - None as far as I am aware.
- Exact error messages - N/A
- When the problem first happened, and when it repeats, what triggers it

The problem started ages ago and I can't really specify the exact time and date but it's lasted for nearly a year now so quite some time. Apologies as I can't be more specific but I can say that it did occur even when I was using Avast Premium but dismissed it and put up with it until now when I finally got fed up with the performance.

- Any steps you already took to try fixing the problem

I've attempted a number of things. Having Avast completely removed fixes the issue but that is kind of besides the point.
I've thought of enabling shields one by one to see which one causes the issue but funny enough even with all shields disabled the issue still occurs.
I've contacted Avast support and allowed my PC to be remote controlled but the issue wasn't fixed. The agent suggested repairing Avast installation which we did but it did not fix the issue as it keeps on reoccurring. Had to stop the session as I ran out of time.
I've established that no matter how modern a game is the stutter persists. Games I've tested it with recently were: Trails in the Sky, Trails of Cold Steel, Battlefield 2042 and Elden Ring. Whilst testing I have established CPU spikes for all Avast related processes. Each time the spike occurred all aforementioned games stuttered for 3-5 seconds before returning to normal.

I have also tested the games on both HDD and SSD the problem occurs no matter the drive the game is on and I'm at my wits end.

- Any recent changes to your system, its configuration, or your network
None that I can think of aside from standard Windows 10 updates.
I'd greatly appreciate any kind of advice on the matter.

Here is the spike caught on Task Manager

EDIT: Matter has now been sorted. The issue for me were previous Avast installation left over files. To fix this completely blitz your PC by using software like Revo Uninstaller to remove it all (including registry entries).

This and a fresh new install fixed it for me.
« Last Edit: July 14, 2022, 09:12:41 AM by redinel.amestir »