Author Topic: AVLaunch.exe - Bad Image Errors following 22.7 update  (Read 2117 times)

0 Members and 1 Guest are viewing this topic.

Offline jsessions

  • Newbie
  • *
  • Posts: 2
AVLaunch.exe - Bad Image Errors following 22.7 update
« on: July 27, 2022, 02:55:37 PM »
Since updating to 22.7 I'm getting 'AvLaunch.exe - Bad Image' error messages on startup relating to the file C:\Windows\system32\cssguard64.dll with error code 0xc000022.  Alert states the dll file is either not designed to run on Windows or it contains an error.  Tried uninstalling/reinstalling with same result.  Also tried AVG Free instead of Avast Free but get same error with AVG.  Rolled back to 22.6 which works fine.  (This is on latest version of Windows 10).

Offline Spec8472

  • Avast team
  • Sr. Member
  • *
  • Posts: 277
Re: AVLaunch.exe - Bad Image Errors following 22.7 update
« Reply #1 on: July 27, 2022, 06:50:50 PM »
Hi jsessions,

Avast self-defense is preventing 3rd party (non MS) module injection (Comodo in this case) into Avast processes since version 22.7. The 0xc000022 is STATUS_ACCESS_DENIED, which is expected. But this blockage should be silent (no message box). We are investigating this.

Thank you for reporting this

Offline jsessions

  • Newbie
  • *
  • Posts: 2
Re: AVLaunch.exe - Bad Image Errors following 22.7 update
« Reply #2 on: July 27, 2022, 07:39:40 PM »
Thanks for your reply.  I haven't used any Comodo software for a few years so this Comodo Secure Shopping related file must be a remnant leftover from a previous uninstall which I'll deal with!  I'm glad that report was helpful.

Offline wir1313

  • Newbie
  • *
  • Posts: 4
Re: AVLaunch.exe - Bad Image Errors following 22.7 update
« Reply #3 on: July 27, 2022, 09:32:38 PM »
I also have this error and many others.

When starting Windows 10 while loading Avast, I get an error and until I click OK, Avast will not start. Further errors occur when, for example, saving / recovering Avast configurations. Reinstalling Avast does not improve the situation.

VisthAux.exe
AvLaunch.exe
C:\Windows\system32\guard64.dll
0xc0000022

Windows 10 and Avast free 22.7.6025 (build 22.7.7403.736)

Yes I use Comodo Firewall 12.2.2.8012
« Last Edit: July 27, 2022, 09:35:04 PM by wir1313 »

Offline Spec8472

  • Avast team
  • Sr. Member
  • *
  • Posts: 277
Re: AVLaunch.exe - Bad Image Errors following 22.7 update
« Reply #4 on: July 28, 2022, 12:27:04 AM »
Hello,
the problem was identified. A fix will be released ASAP.

Offline wir1313

  • Newbie
  • *
  • Posts: 4
Re: AVLaunch.exe - Bad Image Errors following 22.7 update
« Reply #5 on: July 29, 2022, 08:46:53 AM »
Hello,
the problem was identified. A fix will be released ASAP.

Eta?

Offline markinson

  • Jr. Member
  • **
  • Posts: 37
Re: AVLaunch.exe - Bad Image Errors following 22.7 update
« Reply #6 on: July 29, 2022, 07:42:12 PM »
Same issue here, unfortunately.  :(
Both with AVAST and with AVG, too.

Hope fixing this problem ...

Offline Spec8472

  • Avast team
  • Sr. Member
  • *
  • Posts: 277
Re: AVLaunch.exe - Bad Image Errors following 22.7 update
« Reply #7 on: July 29, 2022, 09:13:14 PM »
Hello wir1313, probable release of fix is Monday, 1 August

Offline Spec8472

  • Avast team
  • Sr. Member
  • *
  • Posts: 277
Re: AVLaunch.exe - Bad Image Errors following 22.7 update
« Reply #8 on: August 01, 2022, 07:36:14 PM »
Hello,
the fix is released. A reboot is needed to reload afflicted driver.

Offline wir1313

  • Newbie
  • *
  • Posts: 4
Re: AVLaunch.exe - Bad Image Errors following 22.7 update
« Reply #9 on: August 02, 2022, 02:48:55 PM »
Hello,
the fix is released. A reboot is needed to reload afflicted driver.

Thank you, the fix is working fine. ;)

Offline markinson

  • Jr. Member
  • **
  • Posts: 37
Re: AVLaunch.exe - Bad Image Errors following 22.7 update
« Reply #10 on: August 03, 2022, 06:56:45 PM »
Well done and thank you so much! The issue was fixed!
Cheers!

Offline Tavi

  • Newbie
  • *
  • Posts: 1
Re: AVLaunch.exe - Bad Image Errors following 22.7 update
« Reply #11 on: August 04, 2022, 03:36:22 PM »
Hello,
the fix is released. A reboot is needed to reload afflicted driver.

Indeed, it's fine now! Thank you!
For the record I had to download and (re)install the new (fixed) version. It didn't want to be fixed through the Update on the ("old" version) app interface.
« Last Edit: August 04, 2022, 07:20:43 PM by Tavi »