Author Topic: New browser version 105.0  (Read 1194 times)

0 Members and 1 Guest are viewing this topic.

Offline SanduP

  • Avast team
  • Jr. Member
  • *
  • Posts: 24
New browser version 105.0
« on: September 15, 2022, 01:17:33 PM »
Hello ASB community,

We’re pleased to announce that we have released a new version of Avast Secure Browser (ASB) for macOS - version 105.0.

This version includes a major Chromium update (including a security patch) and other minor improvements and fixes, which increase browser performance and stability.

-----------------------------------------------------------------------------------------
How to get this latest version
If you have ASB already installed, it should be updated automatically (feel free to visit 'secure://settings/help' to trigger an update faster)
Alternatively, you can download and install ASB from our official site:
https://download.avastbrowser.com/external/avast_secure_browser_setup.exe


We hope you enjoy the changes we have made, and as always we would love to hear your feedback. Please try our Browser also on your other devices. Besides the macOS version, ASB is also available on iOS, Android and Windows platforms and with the Avast sync, you can synchronise the settings on all of them. You can download the MacOS version here, more information for iOS see here (English locales only), and for Android here or go straight to the App Store or Google Play Store.
« Last Edit: November 21, 2022, 09:49:16 PM by SanduP »

Offline Dwight2

  • Newbie
  • *
  • Posts: 1
Re: New browser version 105.0
« Reply #1 on: October 11, 2022, 08:49:22 PM »
Hello,  I think my computer must have updated to this new version. This has actually happened with two of our computers that have MAC OS 10.12.6.   I cannot use the new version and get this error message each time I try to open it:

You can’t use this version of the application “Avast Secure Browser” with this version of macOS. You have macOS 10.12.6. The application requires macOS 10.13 or later.

However, the Avast website still states the following:

Minimum system requirements:
    Apple macOS 12.x (Monterey), Apple macOS 11.x (Big Sur), Apple macOS 10.15.x (Catalina), Apple macOS 10.14.x (Mojave), Apple macOS 10.13.x (High Sierra), Apple macOS 10.12.x (Sierra), Apple Mac OS X 10.11.x (El Capitan), Apple Mac OS X 10.10.x (Yosemite)
    Intel-based Mac with 64-bit processor
    Internet connection to download the browser and receive updates
    Optimal standard screen resolution no less than 1024 x 768 pixels is recommended

Question:  If it is the new version of Avast Secure Browser that is my problem, is there a way of going back to the previous version? 

Offline SanduP

  • Avast team
  • Jr. Member
  • *
  • Posts: 24
Re: New browser version 105.0
« Reply #2 on: October 18, 2022, 11:53:29 AM »
Hello,  I think my computer must have updated to this new version. This has actually happened with two of our computers that have MAC OS 10.12.6.   I cannot use the new version and get this error message each time I try to open it:

You can’t use this version of the application “Avast Secure Browser” with this version of macOS. You have macOS 10.12.6. The application requires macOS 10.13 or later.

However, the Avast website still states the following:

Minimum system requirements:
    Apple macOS 12.x (Monterey), Apple macOS 11.x (Big Sur), Apple macOS 10.15.x (Catalina), Apple macOS 10.14.x (Mojave), Apple macOS 10.13.x (High Sierra), Apple macOS 10.12.x (Sierra), Apple Mac OS X 10.11.x (El Capitan), Apple Mac OS X 10.10.x (Yosemite)
    Intel-based Mac with 64-bit processor
    Internet connection to download the browser and receive updates
    Optimal standard screen resolution no less than 1024 x 768 pixels is recommended

Question:  If it is the new version of Avast Secure Browser that is my problem, is there a way of going back to the previous version?

Hello,

thank you for your message. Unfortunately, there is no other solution than updating your macOS to a newer version. Even if you install again Avast Secure Browser 104.0, it will update automatically to 105.0.

The issue is that the latest browser versions require a more recent OS version than macOS 10.12.X (Sierra) and older. Regarding minimum system requirements on our web, those are no longer actual and I requested my colleagues to update them as soon as possible.

Have a nice day.

Sandu