Author Topic: NET:ERR_CERT_INVALID issue with Chrome  (Read 2357 times)

0 Members and 1 Guest are viewing this topic.

Offline AlexL

  • Newbie
  • *
  • Posts: 2
NET:ERR_CERT_INVALID issue with Chrome
« on: December 04, 2022, 06:53:17 PM »
I started having the ERR_CERT_INVALID problem anytime I click on a secure site that had always worked before. I found some Chrome forums where the issue has been reported but not in the Avast knowledge base. One Chrome user simply uninstalled the Avast free product and the error went away. I tried turning off different settings within Avast to see which one was the culprit. It turned out to be Web Shield setting in Protection. My version is below since this only started a few weeks ago.

22.10.6038 (build 22.10.7633.0)

I hope someone can figure out what is really the issue so we can have a real fix. I will not keep using Avast with the Web Shield off for very long. I will have to find a different product in that case.

Thanks

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 89015
  • No support PMs thanks
Re: NET:ERR_CERT_INVALID issue with Chrome
« Reply #1 on: December 04, 2022, 10:05:13 PM »
1.  Uninstalling Avast doesn't make it go away, it is being ignored or not covered by the next AV.

2.  I would suggest that you post a screenshot of the avast notification/warning as without the domain name/url it is impossible to check.

If posting the URL ensure that it isn't active e.g. no http, www, etc. - invalid-domain-name.com

There is nothing stopping you also reporting it to Avast (but it may be better to do the above first):
Reporting a Possible False Positive File or Website - https://www.avast.com/false-positive-file-form.php.
You should get a response in a day or two.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.3.6108 (build 24.3.8975.762) UI 1.0.801/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline AlexL

  • Newbie
  • *
  • Posts: 2
Re: NET:ERR_CERT_INVALID issue with Chrome
« Reply #2 on: December 05, 2022, 07:18:47 PM »
DavidR thanks for the suggestions. I am attaching the screenshot here.

« Last Edit: December 05, 2022, 09:28:50 PM by AlexL »

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 89015
  • No support PMs thanks
Re: NET:ERR_CERT_INVALID issue with Chrome
« Reply #3 on: December 05, 2022, 08:16:37 PM »
OK first I'm going to ask you to remove your screenshots and blank out the client key element for security reasons (so it can't be harvested).

I can reach Login element, so I can only assume that the redirection from this link isn't fully https secure.  To the same degree I'm not sure how Avast would investigate this given they don't have a login name, etc.

Now I don't know if adding your the myschoolbucks.com URL to the avast Web Shield Exclusions would prevent this.
Avast UI > Menu > Settings > General > Exceptions > Add Advanced Exception - Website/Domain.

If this does work it means you have protection for your other sites, etc.

I will try to draw some Avast Team attention to this topic.
« Last Edit: December 05, 2022, 08:20:34 PM by DavidR »
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.3.6108 (build 24.3.8975.762) UI 1.0.801/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Sjors

  • Newbie
  • *
  • Posts: 1
Re: NET:ERR_CERT_INVALID issue with Chrome
« Reply #4 on: December 11, 2022, 10:36:45 AM »
I have the same issue and putting websites on exception does not help either. It now also seems to spread to my Brave Browser as it started in 1, but not all Chrome browser windows I use.

I have also tried to update SSL certificates, but the issue seems to be at Avast.
« Last Edit: December 11, 2022, 10:40:19 AM by Sjors »

Offline Luukjr

  • Sr. Member
  • ****
  • Posts: 276
Re: NET:ERR_CERT_INVALID issue with Chrome
« Reply #5 on: December 11, 2022, 12:03:23 PM »
I have the same issue and putting websites on exception does not help either. It now also seems to spread to my Brave Browser as it started in 1, but not all Chrome browser windows I use.

I have also tried to update SSL certificates, but the issue seems to be at Avast.

https://windowsreport.com/fix-neterr_cert_invalid-error-steal-information/
OS: Windows 10 Home
Soft: Avast Premium Security  / Avast Cleanup / Malwarebytes Premium

Offline tomek_pl_7

  • Newbie
  • *
  • Posts: 2
Re: NET:ERR_CERT_INVALID issue with Chrome
« Reply #6 on: December 23, 2022, 09:45:27 AM »
Have the same issue.
Looks like original certificate is replaced by "avast! Web/Mail Shield Root"
See on attached screenshots. When Avast is ON, certificate is invalid. When Avast is OFF than all works fine.
Issue is reproduced for many web pages.

Tested on Windows7 with Avast 22.10.6038 (compilation 22.10.7633.760), Google Chrome 107.0.5304.107
« Last Edit: December 23, 2022, 09:51:58 AM by tomek_pl_7 »

Offline chris..

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2926
Re: NET:ERR_CERT_INVALID issue with Chrome
« Reply #7 on: December 23, 2022, 01:15:59 PM »
When Avast is ON, certificate is invalid. When Avast is OFF than all works fine.
Can you do an intermediate test, i.e. unchecking only the scan of the latest http version: "QUIC/HTTP3"

Menu->settings-> Protection-> Core shields -> web shield -> uncheck "Enable QUIC/HTTP3 scanning"

Offline tomek_pl_7

  • Newbie
  • *
  • Posts: 2
Re: NET:ERR_CERT_INVALID issue with Chrome
« Reply #8 on: December 23, 2022, 01:56:40 PM »
Tested in two cases:
1. "Enable QUIC/HTTP3 scanning" unchecked -> issue is present,
2. "Enable HTTPS scanning" unchecked -> issue dissapeared.

Looks like QUIC/HTTP3 setting is not relevant.