Author Topic: unable to start  (Read 3746 times)

0 Members and 1 Guest are viewing this topic.

Offline D++

  • Newbie
  • *
  • Posts: 1
unable to start
« on: February 20, 2023, 03:34:18 PM »
Hello, have the following error now:

in 3.0.3:
Code: [Select]
Feb 20 15:28:05 XXX systemd: Starting LSB: Avast antivirus service...
Feb 20 15:28:05 XXX avast: main: Starting daemon.
Feb 20 15:28:05 XXX avast: submit: execv(): /var/lib/avast/Setup/submit: Permission denied
Feb 20 15:28:05 XXX avast: submit: /var/lib/avast/Setup/submit: 255
Feb 20 15:28:05 XXX avast: engine: avldrLoadModule(): Cannot exec a shared library directly
Feb 20 15:28:05 XXX avast: main: Fatal error. Exiting.
Feb 20 15:28:06 XXX avast: Starting avast:[FAILED]
Feb 20 15:28:06 XXX systemd: avast.service: control process exited, code=exited status=1
Feb 20 15:28:06 XXX systemd: Failed to start LSB: Avast antivirus service.
Feb 20 15:28:06 XXX systemd: Unit avast.service entered failed state.
Feb 20 15:28:06 XXX systemd: avast.service failed

4.3.0:
Code: [Select]
Feb 20 15:32:47 XXX avast[6946]: main: Starting 4.3.0 (1 LNX 4.3.0)
Feb 20 15:32:47 XXX avast[6946]: engine: avldrLoadModule(): Cannot exec a shared library directly
Feb 20 15:32:47 XXX avast[6946]: main: Failed to load VPS.
Feb 20 15:32:47 XXX avast[6946]: main: Fatal error. Exiting

Centos 7.9 lastest Updates. Any Ideas?

Offline Radek Brich

  • Developer (Linux AV, Mac AV)
  • Avast team
  • Jr. Member
  • *
  • Posts: 56
Re: unable to start
« Reply #1 on: February 23, 2023, 04:56:22 PM »
Hi, can you still reproduce this, or was it only temporary error?
I've run a test on CentOS 7 now and VPS loaded fine, scan worked.