Author Topic: Error Messages in the log  (Read 4918 times)

0 Members and 1 Guest are viewing this topic.

aquilo

  • Guest
Error Messages in the log
« on: December 28, 2007, 04:23:20 PM »
Hi!

I´m experiencing the following error messages:

25.11.2007   03:41:24   1195958484   ADMINNAME   1548   An error has occured while attempting to update. Please check the logs. 
25.11.2007   06:44:23   1195969463   ADMINNAME   1548   Function setifaceUpdatePackages() has failed. Return code is 0x20000004, dwRes is 20000004. 
25.11.2007   06:44:32   1195969472   ADMINNAME   1548   An error has occured while attempting to update. Please check the logs. 
27.11.2007   11:43:48   1196160228   ADMINNAME   1548   Function setifaceUpdatePackages() has failed. Return code is 0x20000011, dwRes is 20000011.

What can i do to avoid these messages?

Martin

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Error Messages in the log
« Reply #1 on: December 28, 2007, 05:21:00 PM »
1) If your subscription allows the update right now (i.e., if it is not expired). Home (free) version need registering each 14 months.

2) If your firewall settings and allow avast.setup to connect.
    If you're not sure, just turn off your firewall (to be sure the update failure is not due to it).
    Maybe you should 'remove' avast.setup entry, try to update, receiving a new alert from the firewall, allowing it and checking it to remember.

3)  Check your proxy settings into avast!:
     Left click the avast icon > Settings
     Update (Basic) > Details > Proxy
     Make sure your browser is not set to "Work Offline" (this option is generally in the File menu).
     If it doesn't help, try switching from "Auto-detect" to "No proxy" (I'm assuming you're not connecting to the Internet via proxy).

When does the problem occur? Just after booting or at any time?
The best things in life are free.

aquilo

  • Guest
Re: Error Messages in the log
« Reply #2 on: December 28, 2007, 05:37:11 PM »
Hi!

the Problem occurs obviously at the automatic update! A manual update leads not to any error messages!

I´m not sure, but it happens periodically!

Martin

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Error Messages in the log
« Reply #3 on: December 28, 2007, 06:34:56 PM »
the Problem occurs obviously at the automatic update! A manual update leads not to any error messages!
If manual update works, the automatic should do it so.
Check both tab of Update settings of avast to see if you have everything right. Also you can change (or add) AlwaysConnectedWaitSeconds value into the [InetWD] section of avast4.ini file. You could set the number of seconds to wait before attempting to update. The default is 30 but it may not be enough in some DSL systems. In this case, you can try increasing this e.g. to 60 (1 minute). That should be enough.
More details here: http://forum.avast.com/index.php?board=2;action=display;threadid=1647
The best things in life are free.