Author Topic: Scan says Webshield off but Accessibility toggle for Avast is on  (Read 7230 times)

0 Members and 1 Guest are viewing this topic.

Offline rocksteady

  • Super Poster
  • ***
  • Posts: 1538
Re: Scan says Webshield off but Accessibility toggle for Avast is on
« Reply #15 on: July 16, 2023, 10:45:12 AM »
@DavidR Yes. I got that.
The UI is quite different with this AMS update version.
Also see Avast have also changed what components are or not provided in free edition.
I can't see any release notes about it fixing webshield.
I just hope this version fixed webshield issue for all supported Andriod devices without intervention.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 89021
  • No support PMs thanks
Re: Scan says Webshield off but Accessibility toggle for Avast is on
« Reply #16 on: July 16, 2023, 01:10:56 PM »
I'm still not 100% certain just who/what is responsible for the accessibility issue, I'm still leaning to overly aggressive actions of battery saving disabling stuff. 

I know that Samsung comes chock-a-block with junk that I have no intention of using and zero ability to remove. Samsung can kiss my ass goodbye for mobile phones.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.3.6108 (build 24.3.8975.762) UI 1.0.801/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline rocksteady

  • Super Poster
  • ***
  • Posts: 1538
Re: Scan says Webshield off but Accessibility toggle for Avast is on
« Reply #17 on: July 17, 2023, 09:54:37 AM »
I just hope this version fixed webshield issue for all supported Andriod devices without intervention.
The answer is NO.
I had another instance of unexpected WEBSHIELD = OFF with the new version yesterday and had to toggle the services setting from ON to OFF then ON again to resume. :(

Offline cska133

  • Sr. Member
  • ****
  • Posts: 313
Re: Scan says Webshield off but Accessibility toggle for Avast is on
« Reply #18 on: January 31, 2024, 03:04:41 PM »
Hi there,

I am also on Samsung device, but alwayson Android 12
I am also struggling with the issue that webshield is getting disabled permanently i think every 5 days or so without any notification. And exacly as you wrote, even visiting the webshield sectio in Avast doesn show that it is off, i just notice that by looking on the statistics of how many websides are beein scanned, and it show 0 for this day. But NO notification.
I use AMS very long time and can remember that i have this issue for a long time
As i said am already on Android 12, but i had the issue on 11 on the same Samsung device too. I also spend a lot of time to fight eith the settings on Samsung, some of which often are doubled. Here i can say:
@DavidR Thanks. I had a look at that, specific for my Phone and Android version.
Problem I have is "Avast" is not listed when I select to add to my list of Non-sleeping apps.
I even uninstalled and re-installed Avast, but same result.  :(
Well, you dont have Avast listed there because you probably have set Avast to "no limits" (dont know how is it called in English). Check Apps-> Avast->battery-> there you have 3 options "limit/optimal/no limits". Wo for every app you have set it to "no limits" will not appear in the device's global setting for the standby apps. For me  if you set it up on the one end (by visiting the settings of every app) or on other end (through the global settings for standby apps) it doesnt make any difference, it should lead to the same result. But who knows how it does get from Samsung. Maybe you could look at the settings of Avast how you have it set for the battery?

@rocksteady
And which Android version are you using?
And which AMS version do you have now?
« Last Edit: January 31, 2024, 03:07:30 PM by cska133 »

Offline rocksteady

  • Super Poster
  • ***
  • Posts: 1538
Re: Scan says Webshield off but Accessibility toggle for Avast is on
« Reply #19 on: January 31, 2024, 03:18:07 PM »
Currently have Android 11, AMS 24.2.1...


Offline cska133

  • Sr. Member
  • ****
  • Posts: 313
Re: Scan says Webshield off but Accessibility toggle for Avast is on
« Reply #20 on: January 31, 2024, 04:23:08 PM »
Well Android 11 or 12 doesnt make difference. I am on AMS 23. Do you still have the issue ? What are the battery settings for AMS (look above limited/optimal/no limits?

Offline rocksteady

  • Super Poster
  • ***
  • Posts: 1538
Re: Scan says Webshield off but Accessibility toggle for Avast is on
« Reply #21 on: February 01, 2024, 06:00:59 PM »
I have given up wasting time trying to analyse and fix the issue. The notification that webshield has turned itself off does not occur that often, so I just go to settings and toggle the permission OFF then ON again. Just annoying that the setting does not stick.

Offline cska133

  • Sr. Member
  • ****
  • Posts: 313
Re: Scan says Webshield off but Accessibility toggle for Avast is on
« Reply #22 on: February 27, 2024, 10:49:15 AM »
Well, as the only thing to have Webshield working remains to manually toggle the accessibility service of Avast i was thinking about solution to automate this. So thatsway i was trying to manage this by using the app Macrodroid, which is an automate tool .
By using Macrodroid i found some workaround of how to automatically toggle the Avast accessibility service in Android. My idea and previous observations were that something in the Android devices kills/stopps the webshield in the background but the settings in the accessibility settings in Android system remains on, thats why no notofications are even displayed to activate the webshield. So if you dont know about this issue you will never notice it.
In Macrodroid there is a possibility to create own macro to disable and then enable the accessibility service of Avast for example every day on certain day/night time (or often). By doing this even if the webshield gets off, it will be automaticlly reset to on when the accessibility service toggles off and then on. I am still using this Macrodroid macro since 7 days and can see the webshied active every day. Probably it was set to off in the meantime (i can not notice this) but after re-toggle the acessibility service every morning (it is how i set it up) the webshield is on every day as i can see this.
The Macrodroid app has also a separate feature to keep accessibility services permanent on, in turns of when the acessibility service goes off the Macrodroid app toggles it automatically on again. But i have not tested this yet. Maybe someone can do this test, so we can know which of these workaround is working properly.

All of what i have wrote here can be found on the Macrodroid forum https://www.macrodroidforum.com/index.php?threads/automate-accessibility-services.6459/ where i have disscuss it and where i got help. Of course you have to know how Macrodoid app works, but this is not complicated. After installing the app, you need to create your own macro. Every macro must have trigger (in my case i choose the time trigger - every day at 3:00h) and action (in my case disable Avast accessibility service, then new action Wait 3 seconds, and last action Enable accessibility service of Avast). Save and done. The only thing is that Macrodroid needs extra permissons for doing that, which can easily be done with ADB debugging.
But as i said, please try the macrodroid feature to keep acessibility services running. Just go in the settings of Microdroid and choose "keep accessibility services runnung", choose the Avast service and done. But again here is the ADB Hack needed to grant extra permissions (if not already done).

Please post here your results and questions. I can help with settings up Macrodroid :-)

I hope we will find workaround.