Author Topic: AswEngSrv.exe isn't launching  (Read 905 times)

0 Members and 1 Guest are viewing this topic.

Offline Pierogi

  • Jr. Member
  • **
  • Posts: 41
AswEngSrv.exe isn't launching
« on: September 27, 2023, 02:43:12 PM »
Hello. Since today morning I've noticed in task manager that Avast process that is aswEngSrv.exe doesn't seem to be launching as it used to. Till yesterday it was working fine, and as far as i know this process is important for AV to be working, so my question is, has anyone noticed that as well? Is that some sort of "quiet" update from Avast that disabled it? My auto updates are disabled, i haven't touched any of settings in AV too, nor i haven't changed anything in my OS, means updates etc, yet since this morning this process isn't launching.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11865
    • AVAST Software
Re: AswEngSrv.exe isn't launching
« Reply #1 on: September 27, 2023, 03:23:27 PM »
What's your version of the Avast program?

Offline Pierogi

  • Jr. Member
  • **
  • Posts: 41
Re: AswEngSrv.exe isn't launching
« Reply #2 on: September 27, 2023, 03:33:51 PM »
What's your version of the Avast program?

21.2.2455
running on Windows 7

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11865
    • AVAST Software
Re: AswEngSrv.exe isn't launching
« Reply #3 on: September 27, 2023, 04:02:36 PM »
Yes, that's correct - the "sandboxed scanning" has been disabled for old versions of the program (and 21.2 is very old, you're missing over two years of updates and security improvements/fixes). It's not really a silent update (in the sense that your program files are untouched)... but there are some online configuration checks that can change specific behavior.

The reason for this is that some updates will be released soon (in virus definitions) that are incompatible with this feature - unless you have a reasonably new version of the program. So to prevent your computer from losing Web Shield altogether, we've disabled the sandbox.

Offline Pierogi

  • Jr. Member
  • **
  • Posts: 41
Re: AswEngSrv.exe isn't launching
« Reply #4 on: September 27, 2023, 04:10:02 PM »
Yes, that's correct - the "sandboxed scanning" has been disabled for old versions of the program (and 21.2 is very old, you're missing over two years of updates and security improvements/fixes). It's not really a silent update (in the sense that your program files are untouched)... but there are some online configuration checks that can change specific behavior.

The reason for this is that some updates will be released soon (in virus definitions) that are incompatible with this feature - unless you have a reasonably new version of the program. So to prevent your computer from losing Web Shield altogether, we've disabled the sandbox.

So i shouldn't be afraid that this is some kind of a bug/crash and my AV is, and still will without this feature, work properly?

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11865
    • AVAST Software
Re: AswEngSrv.exe isn't launching
« Reply #5 on: September 27, 2023, 04:13:35 PM »
Yes, it will work... it will be a bit less secure (the sandbox is a security feature - if someone happened to find an exploitable bug in the AV scanning engine, the sandbox would be there to prevent the malicious code to get "out of the scanner" and infect the system).