Author Topic: Webshield not working?  (Read 713 times)

0 Members and 1 Guest are viewing this topic.

Offline Kees1958

  • Jr. Member
  • **
  • Posts: 25
Webshield not working?
« on: March 04, 2024, 07:07:43 AM »
Hi,

I am using 24.1.6099 (version 24.1.8821.762) and when I add a domain to the blocklist in the webshield (e.g. malwaretips.com), my browser Google Chrome opens that website (malwaretips.com) without any problem.

Does Avast has a website to check whether webshield is working?

I know that Chrome changed the default from allowing third-party software injecting DLL's into the browser to blocking. Could this be the problem (does the webshield needs to allow its DLL injected to Chrome browser)?

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5604
  • Spartan Warrior
Re: Webshield not working?
« Reply #1 on: March 04, 2024, 07:05:38 PM »
Windows 10 Home 64-bit 22H2 Avast Premier Security version 24.1.6099 (build 24.1.88821.762)  UI version 1.0.797
 UI version 1.0.788.  Windows 11 Home 23H2 - Windows 11 Pro 23H2 Avast Premier Security version 24.2.6105 (build 24.1.8918.827) UI version 1.0.801

Offline New_Style_xd

  • Sr. Member
  • ****
  • Posts: 397
Re: Webshield not working?
« Reply #2 on: March 05, 2024, 04:47:47 PM »
Here:  http://www.avast.com/eng/test-url-blocker.html

I tried to access the link you provided, it says that the impressive AVAST service itself is infected.
Image is being attached.
OS: Windows 10 PRO / Intel(R) Core(TM) i7-6500U CPU 2.60 GHz.
Real Time: Avast Premium Security: 24.2.6104 (compilação 24.2.8904.819) IU: 1.0.799
Moble: Avast Security: 24.3.0-1004091
VPN: Avast SecureLine VPN: 5.29.9498
On Demand: Malwarebytes: 4.6.9.314

Offline Dinobot2

  • Sr. Member
  • ****
  • Posts: 393
Re: Webshield not working?
« Reply #3 on: March 05, 2024, 04:53:50 PM »
Here:  http://www.avast.com/eng/test-url-blocker.html

I tried to access the link you provided, it says that the impressive AVAST service itself is infected.
Image is being attached.

Same result.

Offline New_Style_xd

  • Sr. Member
  • ****
  • Posts: 397
Re: Webshield not working?
« Reply #4 on: March 05, 2024, 05:05:53 PM »
Is it strange that the Avast service itself is blocked?
Avast what is happening with your products?
OS: Windows 10 PRO / Intel(R) Core(TM) i7-6500U CPU 2.60 GHz.
Real Time: Avast Premium Security: 24.2.6104 (compilação 24.2.8904.819) IU: 1.0.799
Moble: Avast Security: 24.3.0-1004091
VPN: Avast SecureLine VPN: 5.29.9498
On Demand: Malwarebytes: 4.6.9.314

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89033
  • No support PMs thanks
Re: Webshield not working?
« Reply #5 on: March 05, 2024, 05:14:17 PM »
Here:  http://www.avast.com/eng/test-url-blocker.html

I tried to access the link you provided, it says that the impressive AVAST service itself is infected.
Image is being attached.

What else would you expect it is pretty much the same as using the EICAR virus test function to check your AV is alerting as it should. Hence test-url-blocker name.
« Last Edit: March 05, 2024, 05:17:14 PM by DavidR »
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.3.6108 (build 24.3.8975.762) UI 1.0.801/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Dinobot2

  • Sr. Member
  • ****
  • Posts: 393
Re: Webshield not working?
« Reply #6 on: March 05, 2024, 05:15:25 PM »
Is it strange that the Avast service itself is blocked?
Avast what is happening with your products?

I'm pretty sure that specific link is meant to be blocked, with the purpose of testing the web shield.

Offline New_Style_xd

  • Sr. Member
  • ****
  • Posts: 397
Re: Webshield not working?
« Reply #7 on: March 05, 2024, 05:17:23 PM »
Is it strange that the Avast service itself is blocked?
Avast what is happening with your products?

I'm pretty sure that specific link is meant to be blocked, with the purpose of testing the web shield.
Now I understand. and a link to test as our friend explained above. I understand now.
OS: Windows 10 PRO / Intel(R) Core(TM) i7-6500U CPU 2.60 GHz.
Real Time: Avast Premium Security: 24.2.6104 (compilação 24.2.8904.819) IU: 1.0.799
Moble: Avast Security: 24.3.0-1004091
VPN: Avast SecureLine VPN: 5.29.9498
On Demand: Malwarebytes: 4.6.9.314

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89033
  • No support PMs thanks
Re: Webshield not working?
« Reply #8 on: March 05, 2024, 05:18:02 PM »
Is it strange that the Avast service itself is blocked?
Avast what is happening with your products?

I'm pretty sure that specific link is meant to be blocked, with the purpose of testing the web shield.

That is its purpose.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.3.6108 (build 24.3.8975.762) UI 1.0.801/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security