Author Topic: avast does not find mail viruses  (Read 10437 times)

0 Members and 1 Guest are viewing this topic.

Offline aveitan

  • Newbie
  • *
  • Posts: 14
avast does not find mail viruses
« on: March 17, 2004, 02:49:14 PM »
 :'(  I've recently defined my avast preferences to check for viruses in my incoming mail (via Outlook Express). It worked fine for 1 week and revealed all the huge amount of junk which unfortunately were trying to intrude my pc with the NETSKY worm. But yesterday avast stoped to recognize anymore these kind of incoming junk. I have not change anything in my pc longtime and I do not know how to redefine  and correct this avast failure.
Please help me asap

Offline shgoh

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 977
Re:avast does not find mail viruses
« Reply #1 on: March 17, 2004, 03:02:07 PM »
maybe you can try to re-run the mail wizard again???
lIfE iS sAd...yOu NeVeR kNoW wHaT yOu GoNnA gEt... :'(

Offline aveitan

  • Newbie
  • *
  • Posts: 14
Re:avast does not find mail viruses
« Reply #2 on: March 17, 2004, 03:14:26 PM »
maybe you can try to re-run the mail wizard again???
I've done it twice (as required, while OE was closed) but it didn't help. I also o tried to use the XP Restore option but it didn't help either. Please please try to help me!  :'( :'(

Offline shgoh

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 977
Re:avast does not find mail viruses
« Reply #3 on: March 17, 2004, 03:18:16 PM »
try the manual config?

how do you know avast is not scanning anymore?

double-click your avast icon in your system tray and see whether the mail provider is running? scanning any files?
lIfE iS sAd...yOu NeVeR kNoW wHaT yOu GoNnA gEt... :'(

Offline aveitan

  • Newbie
  • *
  • Posts: 14
Re:avast does not find mail viruses
« Reply #4 on: March 17, 2004, 03:28:02 PM »
mail provider is operative as well as all other providers!
i've checked avast simply by resending to myself some of the junkmail with their Netsky attachment. In addition, I continue to receieve again and again these junk mail from other unknown to me senders!

Offline shgoh

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 977
Re:avast does not find mail viruses
« Reply #5 on: March 17, 2004, 03:42:54 PM »
try checking your default smtp & pop server in avast.ini?
lIfE iS sAd...yOu NeVeR kNoW wHaT yOu GoNnA gEt... :'(

Offline aveitan

  • Newbie
  • *
  • Posts: 14
Re:avast does not find mail viruses
« Reply #6 on: March 17, 2004, 04:51:21 PM »
try checking your default smtp & pop server in avast.ini?
DefaultSmtpServer and DefaultPopServer were checked and are correct. the next value: UseDefaultSmtp=0
Should this value realy be 0?
Thanks for your assistance!!!!!!!!!

Offline shgoh

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 977
Re:avast does not find mail viruses
« Reply #7 on: March 17, 2004, 04:54:48 PM »
If your e-mail program supports SMTP authentication, and also makes it possible to set a different login name for SMTP than for POP, insert the line: UseDefaultSmtp=0.
If your e-mail program does not support SMTP authentication, insert the line: UseDefaultSmtp=1.
lIfE iS sAd...yOu NeVeR kNoW wHaT yOu GoNnA gEt... :'(

Offline aveitan

  • Newbie
  • *
  • Posts: 14
Re:avast does not find mail viruses
« Reply #8 on: March 17, 2004, 05:08:43 PM »
Since it does support autentication the 0 value is OK, but still avast does not support the email scanning. Now I start to suspect that it also stopped to scan my internet communications and my downloaded files. What should I do more????

Offline shgoh

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 977
Re:avast does not find mail viruses
« Reply #9 on: March 17, 2004, 05:39:21 PM »
sorry....i ran out of ideas... :-\

maybe someone else can help???...plss...
lIfE iS sAd...yOu NeVeR kNoW wHaT yOu GoNnA gEt... :'(

Offline whocares

  • Super Poster
  • ***
  • Posts: 1698
  • I'm not a llama! :-)
Re:avast does not find mail viruses
« Reply #10 on: March 17, 2004, 05:41:03 PM »
Hi,

1) test if it really doesn't scan the mails by sending the harmless testfile eicar.com from www.eicar.com to yourself (just to be sure)
You'll probably have to pause avast's resident shield and mailscan providers for this; reenable them when the mail is sent

P.S.: if afterwards you doubleclick on the eicar.com file on your disk avast shield should alert you and block it... This works ? just delete it then

2) have you read the FAQ: http://www.avast.com/i_kat_81.html

3) maybe post the relevant settings in avast and your mailclient here; replace your real username/domain maybe with "username" & "domain" or xxxx

4) have you tried repairing avast (via software -> uninstall avast)

5) what version do you have for avast's programm and VPS ? and for Outlook ?
are all WindowsUpdates applied ?

Offline aveitan

  • Newbie
  • *
  • Posts: 14
Re:avast does not find mail viruses
« Reply #11 on: March 17, 2004, 07:14:51 PM »
Hi whocares
Reur remarks:
5) I have avast 4 automatically and regularly updated,
   (build 4.1.342 with VPS file 0403-11)
4) I have tried the repairing process as the first action, but as all other actions ut didn't help.
2) & 3) I'm going to read the FAQ and to test eicar.com file. Then I'll send the results. As for the relevant settings, do you mean  to post the complete avas4.ini file?
I have XP Home updated regularly/automaticly on my Pentium 4, 2.6GHz which works OK.
Thanks for your efforts,

By the way, going through START>PROGRAMS>AVAST>
I don't find the option "Mail Protection Wizard". I am having only three options:
-Avast! Antivirus
-Avast! Website
-Help
Should I reinstall Avast? if positive should I uninstall first or just try to reinstall?
« Last Edit: March 17, 2004, 08:21:27 PM by aveitan »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re:avast does not find mail viruses
« Reply #12 on: March 18, 2004, 12:16:55 AM »
I suggest:

First of all: try the option Repair into the Control Panel > Add/Remove Programs > avast! antivirus > 'Change'. A window will popup and you will be able to choose the option Repair. You must be connected to the Internet.

Then, check if scanning Inbound and Outbound mail is set into the Internet Mail provider options (if it's not checked you won't have your emails scanned).

Run a full scanning with avast! (better at boot-time). Send files to Chest if you are not sure of deleting them.

Let's try to get rid from that infection...
The best things in life are free.

Offline Datagg

  • Sr. Member
  • ****
  • Posts: 219
  • Perceive things that you cant see
    • Girlfriends Lingerie
Re:avast does not find mail viruses
« Reply #13 on: March 18, 2004, 02:06:01 AM »
mail provider is operative as well as all other providers!
i've checked avast simply by resending to myself some of the junkmail with their Netsky attachment. In addition, I continue to receieve again and again these junk mail from other unknown to me senders!


If I am reading the above right and you are resending the email that had these attachments in them back to you, they allready had the virus removed, therefore there will be no virus to warn you of.
X64
GA-K8N-SLI
AMD 64 3500+
Nvidia Nforce4
e-Geforce 6800GT - PCI-E 256M
Gig of PC3200 DDR2

Offline aveitan

  • Newbie
  • *
  • Posts: 14
Re:avast does not find mail viruses
« Reply #14 on: March 18, 2004, 02:37:17 PM »
Here are the last and final tests that I have commited, but still with negative results:
1) I disabled avast standard shield provider and downloaded eicar test file. than i enabled all the providers and sent to myself a letter (thru Outlook Express) with the eicar file attached to it. Avast mail provider didn't activate any alarm.
2) While all providers are on, I downloaded again the eicar test file and this time avast alarm started to scream on the spot!
Before those tests, I have done twice the repair procedure using the Add/Remove. It should also be noted that I don't see the Mail Provider Wizard which is supposed to appear while going thru START>PROGRAMS>AVAST!>...
It seems that the only thing left to do is to reinstall avast.
I want an expert from the avast team to advise me wether it is possible to reinstall avast on itself (without uninstalling the existing one). If the process will not solve the mail scan problems, perhaps I'll have to look for a different antivirus software.  :'( :'( :'(