Author Topic: Citrix sessions hang, when 'Virus Detected' pop-up appears on server  (Read 5715 times)

0 Members and 1 Guest are viewing this topic.

kcr

  • Guest
Windows 2K SP4
Avast Server Edition 4
Citrix 1.2

Installed the demo version of Avast Server Edition.  When a virus is detected on the server, all of the Citrix sessions hang and are unusable until I attend to the pop-up on the server.

I've attempted to disable the WinPop-Up message in the Alerts, but it is unresponsive.  I've tried to delete the winpop-up, but nothing happens.  I've tried to edit the winpop-up, but nothing happens.

This Citrix server is at a remote location, so it is impossible to attend to the pop-ups, unless I call to have someone go an press "move to chest" or "delete" the virus.  The remote desktop sessions hang when the pop-up appears.

When I installed the Avast Server Edition, I told the install that the computer was a terminal/Citrix server.  Is there any other configuration that needs to occur on a Citrix server beside the normal install?

We are evaluating the software for about 12 servers, but if this is a constant problem then, we will look for a different product.

Thanks for your help,

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Citrix sessions hang, when 'Virus Detected' pop-up appears on server
« Reply #1 on: March 21, 2008, 12:17:47 AM »
Hi kcr,

thanks for your post, and your interest in avast.

By default, avast Server Edition is preconfigured to run in so called "Silent mode". This means no popups at all - any time a virus is detected, it is moved to the Virus Chest automatically, period.

However, if you select that it is a terminal server, this default setting is actually overriden so that the terminal user is given a chance to do something.

If you'd prefer to switch back to the Silent mode, please follow these steps:

1. double-click the avast tray icon
2. click "Details" (you should see a larger dialog with an icon list on the left)
3. In the icon list, scroll to Standard Shield, and double-click its icon
4. Go to the last page ("Advanced") and check the "Silent mode" box.


Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.