Author Topic: Error with avast! 4.8 [antirootkit-related]  (Read 47088 times)

0 Members and 1 Guest are viewing this topic.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84749
  • No support PMs thanks
Re: Error with avast! 4.8 [antirootkit-related]
« Reply #45 on: April 04, 2008, 06:31:21 PM »
Yes the anti-rootkit module is now working on my system (FAT32 formatted drives), tested using the ashquick rootkit command.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.2.2455 (build 21.2.6096.648) UI 1.0.608/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline comRace

  • Newbie
  • *
  • Posts: 17
Re: Error with avast! 4.8 [antirootkit-related]
« Reply #46 on: April 04, 2008, 06:54:37 PM »
The problem seems to be solved here too.
After the update to 080404-0 I didn't restart the pc and so I got the error in the log viewer.
Now I restarted the pc and there's no error regarding the 'aswar scan function'.

Offline MauriceW

  • Jr. Member
  • **
  • Posts: 44
Re: Error with avast! 4.8 [antirootkit-related]
« Reply #47 on: April 05, 2008, 04:33:03 AM »
Happy to report that since my last post, as promised by Vlk,
a VPS update (080404) has cured the rootkit scan at startup problem.
My troubleshooting options are now all cleared
and Avast! 4.8, Online Armor 2.1.0.119 and WinPatrol 12 are all collaborating at startup.
IE7 and OE6 are both operating correctly Sandboxed
and Avast Rootkit Scan on demand is also working.

All systems are "GO".

Congratulations to the Alwil Staff

Maurice
Win7 Home 4GB RAM on HPdv7 dual HD
Office2007; Regular ERUNT
Security:-  Avast! 5 , All browsing in Sandboxie 3.46 Occasional SAS, MBAM
OS fairly stable - no malware.

Offline -Doug-

  • Newbie
  • *
  • Posts: 12
Re: Error with avast! 4.8 [antirootkit-related]
« Reply #48 on: April 06, 2008, 01:29:21 PM »
Hello again!

The problem occured again and now with new error function.
6.4.2008 11:47:38   SYSTEM   1532   Internal error has occurred in module aswar scan function failed!, function C0000005. 
6.4.2008 14:25:08   SYSTEM   1532   Internal error has occurred in module aswar scan function failed!, function C0000005. 

I think this started after yesterday VPS-updates.

Offline skipperl

  • Jr. Member
  • **
  • Posts: 21
Re: Error with avast! 4.8 [antirootkit-related]
« Reply #49 on: April 06, 2008, 04:45:18 PM »
Me too:
At least the error changed:

Internal error has occurred in module aswar scan function failed!, function C0000005. 

IF there is a fix, please provide steps.  Delay, no delay, disable, whatever.  I just want this thing to go away.

Offline sanctuaryforever

  • Sr. Member
  • ****
  • Posts: 252
Re: Error with avast! 4.8 [antirootkit-related]
« Reply #50 on: April 06, 2008, 04:46:34 PM »
a few topics have been made referring to this, hopefully someone in the know can give us some info on a fix
Celeron 1.30Ghz, 1Gb ram, Windows XP SP3 32-bit

running Avast 6.0.1289

Offline comRace

  • Newbie
  • *
  • Posts: 17
Re: Error with avast! 4.8 [antirootkit-related]
« Reply #51 on: April 06, 2008, 05:15:58 PM »
Same error here. But if I try the "C:\Program Files\Alwil Software\Avast4\ashQuick.exe" "<RTK>SUPERQUICK" command in Run, the scan works and finishes succesfully.
« Last Edit: April 06, 2008, 05:17:50 PM by comRace »

Offline acapulco08

  • Newbie
  • *
  • Posts: 9
Re: Error with avast! 4.8 [antirootkit-related]
« Reply #52 on: April 06, 2008, 09:50:30 PM »
Discussion on the matter continues on Subject: Internal error has occurred in module aswar scan function failed!, http://forum.avast.com/index.php?topic=34213.

Offline MauriceW

  • Jr. Member
  • **
  • Posts: 44
Re: Error with avast! 4.8 [antirootkit-related]
« Reply #53 on: April 07, 2008, 02:07:29 AM »
Hello All,
I got this new variety of rootkit scan error yesterday.
"Internal error has occurred in module aswar scan function failed!, function C0000005"
After updating to VPS 080406 this morning, all fixed again.
This is getting to be tedious.
Maurice
Win7 Home 4GB RAM on HPdv7 dual HD
Office2007; Regular ERUNT
Security:-  Avast! 5 , All browsing in Sandboxie 3.46 Occasional SAS, MBAM
OS fairly stable - no malware.

Offline MiguelAngelXP

  • Jr. Member
  • **
  • Posts: 58
Re: Error with avast! 4.8 [antirootkit-related]
« Reply #54 on: April 07, 2008, 07:01:13 AM »
Hi, everyone :

So long time I wasn't here.

First of all congrats for the version 4.8 Release, it's working fine in my computer however I'm experiences some problems. The antivirus log error  viewer is filling with errors related with my firewall (Online Armor 2.1.0.119 Free), here I send you the lines for today April 7th 2008

07-04-2008   0:19:53   1207541993   SYSTEM   1684   AAVM - scanning error: x_AavmCheckFileDirectEx: avfilesScanReal of C:\Archivos de programa\Tall Emu\Online Armor\server.dat failed, 00000005. 
07-04-2008   0:19:59   1207541999   SYSTEM   1684   AAVM - scanning error: x_AavmCheckFileDirectEx: avfilesScanReal of C:\Archivos de programa\Tall Emu\Online Armor\server.dat failed, 00000005. 
07-04-2008   0:19:59   1207541999   SYSTEM   1684   AAVM - scanning error: x_AavmCheckFileDirectEx: avfilesScanReal of C:\Archivos de programa\Tall Emu\Online Armor\server.dat failed, 00000005. 
07-04-2008   0:20:32   1207542032   SYSTEM   1684   Internal error has occurred in module aswar scan function failed!, function C0000005. 
07-04-2008   0:33:59   1207542839   SYSTEM   1684   AAVM - scanning error: x_AavmCheckFileDirectEx: avfilesScanReal of C:\Archivos de programa\Tall Emu\Online Armor\SentList.dat failed, 00000005. 
07-04-2008   0:34:00   1207542840   SYSTEM   1684   AAVM - scanning error: x_AavmCheckFileDirectEx: avfilesScanReal of C:\Archivos de programa\Tall Emu\Online Armor\server.dat failed, 00000005. 
07-04-2008   0:35:35   1207542935   SYSTEM   1684   AAVM - scanning error: x_AavmCheckFileDirectEx: avfilesScanReal of C:\Archivos de programa\Tall Emu\Online Armor\server.dat failed, 00000005. 
07-04-2008   0:37:10   1207543030   SYSTEM   1684   AAVM - scanning error: x_AavmCheckFileDirectEx: avfilesScanReal of C:\Archivos de programa\Tall Emu\Online Armor\SentList.dat failed, 00000005. 
07-04-2008   0:37:10   1207543030   SYSTEM   1684   AAVM - scanning error: x_AavmCheckFileDirectEx: avfilesScanReal of C:\Archivos de programa\Tall Emu\Online Armor\server.dat failed, 00000005. 
07-04-2008   0:38:47   1207543127   SYSTEM   1684   AAVM - scanning error: x_AavmCheckFileDirectEx: avfilesScanReal of C:\Archivos de programa\Tall Emu\Online Armor\server.dat failed, 00000005. 

Also I have Superspyware Terminator but On-Demand Mode only, and I've checked the rootkit checker at startup

Also the Windows Log Viewer (Avast Antivirus section) is reporting the same errors, and the worst is when I perform a HDD check (both files check and surface check (Windows in-built HDD CHKDSK) because after the CHKDSK the startup freezes, so I had the following workaround  :):

1. Pressing Alt+Ctrl+Del keys (Task Manager)
2. Stopping the explorer.exe process
3. Reboot
4. The start up works normally

So these are my glitches, but I hope that the developement team will find a solution to this problem, as far I can see I'm not the only who's experience this issue  ;). My HDD is a NTFS file system

I'll post the following image

Kindly regards
MiguelAngelXP





« Last Edit: April 07, 2008, 07:14:58 AM by MiguelAngelXP »
avast 5.0.x Free Edition
SONY VAIO VGN-CS270T
Centrino 2,4 Ghz Core Duo 2, 4GB RAM
Windows 7 Ultimate 64bit
COMODO Internet Security 5.x

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84749
  • No support PMs thanks
Re: Error with avast! 4.8 [antirootkit-related]
« Reply #55 on: April 07, 2008, 02:59:41 PM »
These errors are unrelated to the anti-rootkit scan errors. The windows error 5 = Access is denied, which doesn't surprise me in the slightest given that it is related to your Firewall which is probably protecting its files. You have nothing to worry about.

The windows event viewer, anti-virus gets its information form the same source so there will be matching entries in both.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.2.2455 (build 21.2.6096.648) UI 1.0.608/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline MiguelAngelXP

  • Jr. Member
  • **
  • Posts: 58
Re: Error with avast! 4.8 [antirootkit-related]
« Reply #56 on: April 07, 2008, 10:22:15 PM »
Thanks pal  ;)

MiguelAngelXP
avast 5.0.x Free Edition
SONY VAIO VGN-CS270T
Centrino 2,4 Ghz Core Duo 2, 4GB RAM
Windows 7 Ultimate 64bit
COMODO Internet Security 5.x

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84749
  • No support PMs thanks
Re: Error with avast! 4.8 [antirootkit-related]
« Reply #57 on: April 07, 2008, 11:12:49 PM »
Your welcome.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.2.2455 (build 21.2.6096.648) UI 1.0.608/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security