Author Topic: Avast 4.8 and World of Warcraft  (Read 132899 times)

0 Members and 1 Guest are viewing this topic.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67247
Re: Avast 4.8 and World of Warcraft
« Reply #30 on: April 05, 2008, 03:52:01 AM »
Is there a link to download the old 4.7 version?
It's not a good idea to downgrade...

You can try 4.7.1098 from the scratch.

1. Uninstall avast from Control Panel first.
2. Boot.
3. Use Avast Uninstall for complete uninstallation.
4. Boot.
5. Install again the old version: http://filehippo.com/download_avast_antivirus/
6. Boot. Uncheck the programs updates (set to manual).
7. Check and post the results.
The best things in life are free.

Offline adikos

  • Newbie
  • *
  • Posts: 3
Re: Avast 4.8 and World of Warcraft
« Reply #31 on: April 05, 2008, 05:17:51 AM »
Turning off avast! antivirus in services didnt fix the problem for me either :(

Offline Tinara

  • Jr. Member
  • **
  • Posts: 23
Re: Avast 4.8 and World of Warcraft
« Reply #32 on: April 05, 2008, 08:57:00 AM »
Same here, turning it off did not help (work got me, hence slow answers - did not have time to check earlier). Uninstalling 4.8 and installing 4.7 from scratch helps instantly - 0 lags. Upgrading to 4.8 and restarting computer = lags are visible the instant I start WoW.

Offline FulValBot

  • Jr. Member
  • **
  • Posts: 20
Re: Avast 4.8 and World of Warcraft
« Reply #33 on: April 05, 2008, 09:35:04 AM »
so for fix all lags i need to unistall avast 4.8?

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast 4.8 and World of Warcraft
« Reply #34 on: April 05, 2008, 09:51:59 AM »
So, stopping the service doesn't help wither... hmm... very odd, I have to say.

I'm just wondering what is left running on the system once you turn the service off.
It's basically just the avast kernel drivers, but these should be more or less switched to "pass-through" mode as well.

What we could try is prevent the new drivers from loading, and see if it makes any difference.

Could you guys please try one more thing?

1. with avast 4.8 installed, boot into Windows Safe Mode
2. from there, run regedit and navigate to HKLM\System\CurrentControlSet\Services
3. in the aswSP and aswFsBlk subkeys, change the value called "Start" to 3 (manual start).
4. reboot the system

This will suppress the avast self defense drivers. I'll like to here if that solves the problem (with the service either on or off - but it shouldn't be too relevant).


Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline blakeman

  • Newbie
  • *
  • Posts: 5
Re: Avast 4.8 and World of Warcraft
« Reply #35 on: April 05, 2008, 10:58:59 AM »
On my side, PES 2008 is hanging the same way as WoW. Works fine windowed. Hangs when full screen.
Also, with Max Media Manager Pro (convert avi to PSP format), it hangs.
Seems like when a process takes almost 100% CPU, Avast 4.8 is using the small amont available and XP hangs.

I'll try to do your test (windows safe mode and regedit) in a few hours...


Offline apexadam

  • Newbie
  • *
  • Posts: 3
Re: Avast 4.8 and World of Warcraft
« Reply #36 on: April 05, 2008, 11:16:08 AM »
 :-\  It's True!  I have tested the Avast 4.7 vs 4.8 against the WoW software on three machines.  All of them exhibited the Keyboard Lag in World of Warcraft (I am using Ati drives too).  Remove 4.8 and all the lag is gone!  Goodbye Avast 4.80.  Let us know when you fix this problem, and I will upgrade.  I love Avast but I love Warcraft more!  It's too bad that blizzard didn't post this solution days ago...  :'(  It was driving me insane.

apexadam
WoW-Name:  Whitehail

Offline apexadam

  • Newbie
  • *
  • Posts: 3
Re: Avast 4.8 and World of Warcraft
« Reply #37 on: April 05, 2008, 11:31:50 AM »
Anyone sport me an Avast Home Free v4.7 until this gets resolved?

Uninstalling 4.7 worked perfectly.  It doesn't appear Avast has discovered a solution yet...does anyone have 4.7 to send...or can you give me a link?  I like using Avast but need v4.7 and could not find it on the main page...

Please give me an option for the Home Free v4.7 if you can.

Thanks,
apexadam

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3866
  • Just an avast user

Offline Nefilim

  • Newbie
  • *
  • Posts: 2
Re: Avast 4.8 and World of Warcraft
« Reply #39 on: April 05, 2008, 03:05:45 PM »
So, stopping the service doesn't help wither... hmm... very odd, I have to say.

I'm just wondering what is left running on the system once you turn the service off.
It's basically just the avast kernel drivers, but these should be more or less switched to "pass-through" mode as well.

What we could try is prevent the new drivers from loading, and see if it makes any difference.

Could you guys please try one more thing?

1. with avast 4.8 installed, boot into Windows Safe Mode
2. from there, run regedit and navigate to HKLM\System\CurrentControlSet\Services
3. in the aswSP and aswFsBlk subkeys, change the value called "Start" to 3 (manual start).
4. reboot the system

This will suppress the avast self defense drivers. I'll like to here if that solves the problem (with the service either on or off - but it shouldn't be too relevant).


Thanks
Vlk


Hello

I tried this and it seems to work now, thanks  :)

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67247
Re: Avast 4.8 and World of Warcraft
« Reply #40 on: April 05, 2008, 03:31:47 PM »
I tried this and it seems to work now, thanks  :)
Thanks for testing and welcome to forums.
The best things in life are free.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 85959
  • No support PMs thanks
Re: Avast 4.8 and World of Warcraft
« Reply #41 on: April 05, 2008, 04:17:16 PM »
<snip>
Could you guys please try one more thing?

1. with avast 4.8 installed, boot into Windows Safe Mode
2. from there, run regedit and navigate to HKLM\System\CurrentControlSet\Services
3. in the aswSP and aswFsBlk subkeys, change the value called "Start" to 3 (manual start).
4. reboot the system

This will suppress the avast self defense drivers. I'll like to here if that solves the problem (with the service either on or off - but it shouldn't be too relevant).


Thanks
Vlk

Hello

I tried this and it seems to work now, thanks  :)

Thanks for testing and contributing hopefully to a resolution of the problem, rather than turning away from the problem.

Welcome to the forums.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.9.2494 (build 21.9.6698.703) UI 1.0.672/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline blakeman

  • Newbie
  • *
  • Posts: 5
Re: Avast 4.8 and World of Warcraft
« Reply #42 on: April 05, 2008, 04:43:22 PM »
Ok, kids are sleeping, I had time to test : it works for me too.
Thanks for the advice, that's great !

Offline Tinara

  • Jr. Member
  • **
  • Posts: 23
Re: Avast 4.8 and World of Warcraft
« Reply #43 on: April 05, 2008, 06:02:54 PM »
What we could try is prevent the new drivers from loading, and see if it makes any difference.
(...)
This will suppress the avast self defense drivers. I'll like to here if that solves the problem (with the service either on or off - but it shouldn't be too relevant).

I just tried it - no lags visible anymore, everything works good. :) I suppose now we'll just have to wait for the new update fixing it (if it's even possible of course) and use v4.8 for now without self defense drivers?

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast 4.8 and World of Warcraft
« Reply #44 on: April 05, 2008, 06:55:33 PM »
OK, guys, one more thing to try (if possible):
try disabling aswFsBlk.sys only (i.e. keep aswSp.sys enabled).

Does that resolve the problem as well?

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.