Author Topic: Avast 4.8 and World of Warcraft  (Read 133692 times)

0 Members and 1 Guest are viewing this topic.

Arnie-san

  • Guest
Re: Avast 4.8 and World of Warcraft
« Reply #60 on: April 07, 2008, 08:51:48 PM »
I'll do it at the morning (should have some free time then) and report back my findings. And just to be sure/remember - we have to change in registry Start value back to 2 on both keys mentioned earlier in a "fix", yes?

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast 4.8 and World of Warcraft
« Reply #61 on: April 07, 2008, 09:00:34 PM »
And just to be sure/remember - we have to change in registry Start value back to 2 on both keys mentioned earlier in a "fix", yes?

Yes, of course. Having it on 3 would block the driver from loading altogether.

BTW the procedure may sound long, but in fact it shouldn't take you more than 15-30 minutes (depending on your system)


Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

blakeman

  • Guest
Re: Avast 4.8 and World of Warcraft
« Reply #62 on: April 07, 2008, 09:40:44 PM »
Ok, I've put "2" in regedit for both services.
I've test the first version of aswSP.sys (http://public.avast.com/~vlk/wow-fix/1/aswSP.sys )  and it works for me  (I've an ATI Radeon 9600XT).

Since I'm the only one on PES 2008 and I havent WoW, lets wait for other feedback.

Thanks anyway !

yacoob

  • Guest
Re: Avast 4.8 and World of Warcraft
« Reply #63 on: April 07, 2008, 10:49:21 PM »
I had this problem with both WoW and Guildwars. First tested turning aswSP.sys off - that certainly did the trick. Tried the fixes you've provided - fix3 did the trick for me (or it looks like it, so far). And yes, I also have ATI gfx card (radeon9800). During my tests I've replaced it with nvidia card - lag was not there.

Once you're done with a permanent fix - care to shed some light on this one? I've spent some time on the weekend trying to find a cause for this erratic behavior, blaming both hardware (keyboard? gfx card? north bridge overheating?) and software (fyi, turning spybot sd OFF also helped, as in reduced the frequency of lag playing up).

dorada

  • Guest
Re: Avast 4.8 and World of Warcraft
« Reply #64 on: April 07, 2008, 10:50:00 PM »
I have the same problem with Need For Speed.
I fixed with  (...)

1. with avast 4.8 installed, boot into Windows Safe Mode
2. from there, run regedit and navigate to HKLM\System\CurrentControlSet\Services
3. in the aswSP and aswFsBlk subkeys, change the value called "Start" to 3 (manual start).
4. reboot the system

Please tell me what does it mean for my system?Why avast does not fix this problem?
I also have ATI X1600Pro

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast 4.8 and World of Warcraft
« Reply #65 on: April 07, 2008, 10:53:10 PM »
yacoob,

I had this problem with both WoW and Guildwars. First tested turning aswSP.sys off - that certainly did the trick. Tried the fixes you've provided - fix3 did the trick for me (or it looks like it, so far).

Thanks for testing. So driver #1 and #2 did NOT do the trick, right?
Only #3 did...


dorada, OK, this indeed works, but this disables the avast self protection altogether. We're now trying to analyze the problem a bit deeper - by finding out which part of the self protection module is causing the issue.

Thanks
Vlk

If at first you don't succeed, then skydiving's not for you.

Offline jimmy88

  • Newbie
  • *
  • Posts: 2
Re: Avast 4.8 and World of Warcraft
« Reply #66 on: April 07, 2008, 11:20:04 PM »
Just signed up to report Rubies of Eventide having the same lag (freeze) Problem... Downloaded all 4 test patches and re-installing 4.8 to test.

Pateric

  • Guest
Re: Avast 4.8 and World of Warcraft
« Reply #67 on: April 07, 2008, 11:42:45 PM »
Just registered to report in from a user with NVIDIA.

NVIDIA  GeForce 7800 GT.

I too am having this problem,  but not as severe as some listed above.

The problem is so intermittent for me that Testing the fixes one by one will be difficult.  But I will give it a shot tonight.

Also want to thank Avast and everyone else for the quick responses to this problem.  Not often you find such good customer support these days.  Hats off to you guys!!

gallusik

  • Guest
Re: Avast 4.8 and World of Warcraft
« Reply #68 on: April 07, 2008, 11:57:43 PM »
Pro Evolution Soccer 2008 have the same problem. But Sometimes when I try play this game is 100% usage CPU, and I can't do anything. Only Reset helps. Dissable Avast don't help, only Uninstall

Arnie-san

  • Guest
Re: Avast 4.8 and World of Warcraft
« Reply #69 on: April 08, 2008, 12:07:14 AM »
Right, tested it and:

1. File nr 1 - no lag on login screen, entered game... no lag... no lag... noooo llllaaa... darn! Lag is back. ;)
2. File nr 2 - no lag on login screen, entered game, played for ~30 minutes - no lag so far.

So, seems file nr 2 works good (for now). Will test it even more tomorrow.

EDIT: Is it normal that it allowed me to delete and/or overwrite that file even under normal Windows mode (not safe mode)? As if it's self-protect driver and any other program can just put different file in it's place... Just wondering. :)
« Last Edit: April 08, 2008, 12:10:08 AM by Tinara »

Online DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 86140
  • No support PMs thanks
Re: Avast 4.8 and World of Warcraft
« Reply #70 on: April 08, 2008, 12:10:48 AM »
Pro Evolution Soccer 2008 have the same problem. But Sometimes when I try play this game is 100% usage CPU, and I can't do anything. Only Reset helps. Dissable Avast don't help, only Uninstall

What is the process responsible for the bulk of the CPU usage and how much, etc. ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.11.2500 (build 21.11.6809.528) UI 1.0.683/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

gallusik

  • Guest
Re: Avast 4.8 and World of Warcraft
« Reply #71 on: April 08, 2008, 12:19:26 AM »
100% CPU usage pes2008.exe file
sometimes in aqq.exe (this is something like jabber)
and sometimes in FM.exe  (football manager)
I try reinstall Java, aqq, PES, fm and many more.
It's funny thet the programs have 100% cpu usage. some kind of scan?
But it's ok when I unistall avast!
;)
I sometimes I wait about 1 minute, sometimes 5 minute and it's ok, and sometimes i wait 1 hour and press reset. ctrl+alt+del console dosnt work. Power button (default shutdown system) don't work, logout the same. only reset workt :]
« Last Edit: April 08, 2008, 12:22:13 AM by gallusik »

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast 4.8 and World of Warcraft
« Reply #72 on: April 08, 2008, 12:25:04 AM »
Right, tested it and:

1. File nr 1 - no lag on login screen, entered game... no lag... no lag... noooo llllaaa... darn! Lag is back. ;)
2. File nr 2 - no lag on login screen, entered game, played for ~30 minutes - no lag so far.

So, seems file nr 2 works good (for now). Will test it even more tomorrow.

Huh, these resuts are inconsistent with a previous poster (who reported that only #3 solved the problem for him).
Interesting, I'm looking forward to feedback from some other people. I hope that the majority will agree on something. ;)

EDIT: Is it normal that it allowed me to delete and/or overwrite that file even under normal Windows mode (not safe mode)? As if it's self-protect driver and any other program can just put different file in it's place... Just wondering. :)

Do you still have Start=3 set for aswFsBlk.sys? As that's the driver that's responsible for the protection of the avast files.

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Online DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 86140
  • No support PMs thanks
Re: Avast 4.8 and World of Warcraft
« Reply #73 on: April 08, 2008, 12:27:35 AM »
100% CPU usage pes2008.exe file
sometimes in aqq.exe (this is something like jabber)
and sometimes in FM.exe  (football manager)
I try reinstall Java, aqq, PES, fm and many more.
It's funny thet the programs have 100% cpu usage. some kind of scan?
But it's ok when I unistall avast!
<snip>

Well I don't know how that can possibly be attributed to avast as they aren't avast processes.

If avast were scanning then it would be an avast process that showed the CPU activity, but that scan wouldn't be represented in the CPU of the scanned program.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.11.2500 (build 21.11.6809.528) UI 1.0.683/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

dreamusic

  • Guest
Re: Avast 4.8 and World of Warcraft
« Reply #74 on: April 08, 2008, 12:28:20 AM »
I wish i was computer literate enough to test this stuff... but as I'm not... I've just uninstalled Avast :( :(

Please let us know when Avast is working with Rubies of Eventide or WoW