Author Topic: SMTP port not connecting after updating to Avast Home 4.8  (Read 6891 times)

0 Members and 1 Guest are viewing this topic.

mingteikg

  • Guest
SMTP port not connecting after updating to Avast Home 4.8
« on: April 03, 2008, 03:36:16 PM »
Running on a  Vista x64, OUtlook is perfect all the while running Avast Home 4.7.

However after updating to Home 4.8, suddenly port 25 can't connect anymore (to any server).

Telnetting to port 25 doesn't connect either.

ANybody seeing the same issue?

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11831
    • AVAST Software
Re: SMTP port not connecting after updating to Avast Home 4.8
« Reply #1 on: April 04, 2008, 10:08:39 AM »
Do you use any firewall? (that might be blocking avast! executables from network since its executables changed during the update)

mingteikg

  • Guest
Re: SMTP port not connecting after updating to Avast Home 4.8
« Reply #2 on: April 05, 2008, 06:26:17 AM »
I only have windows firewall on my Vista.

But I can receive emails (which will also get scanned through Avast).

I turned off Windows Firewall and still can't telnet into port 25...


Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3869
  • Just an avast user
Re: SMTP port not connecting after updating to Avast Home 4.8
« Reply #3 on: April 05, 2008, 11:32:14 AM »
If the SMTP server you are connecting to is a public one can you tell us the name of it so that we can check too.

I cannot see any change in avast 4.8 that could be blocking port 25. 

Are you using avast's Outlook plugin or the Internet Mail provider? 

Erroneus

  • Guest
Re: SMTP port not connecting after updating to Avast Home 4.8
« Reply #4 on: April 21, 2008, 11:41:57 AM »
I'm having the same problem, but only sometime :(

I CAN send email thrugh GMAIL, because it's not using port 25, but smtp servers on port25 will not be connected and i cant telnet them either :(

A reboot of the machine helps.

Running latest Avast on Vista Buisness with SP1.
« Last Edit: April 21, 2008, 09:26:46 PM by Erroneus »

Bascule

  • Guest
Re: SMTP port not connecting after updating to Avast Home 4.8
« Reply #5 on: April 21, 2008, 03:44:20 PM »
Same problem here.

I used to use beeb.net but they are stopping their email service in June so I am moving to Gmail and I have tried setting up their smtp server in Avast but no joy yet.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67199
Re: SMTP port not connecting after updating to Avast Home 4.8
« Reply #6 on: April 21, 2008, 04:04:18 PM »
Take a look here: http://forum.avast.com/index.php?topic=10428.0 to see how to set up secure email (like GMail) with avast!

The solution is to pass e-mail in and out un-encrypted from your client (Outlook Express, Thunderbird, ...) to a proxy program (Stunnel) that does the actual ssl or tls encryption/decryption of the pop3/smtp e-mail and communicates directly with the ISP server on the appropriate ports. Download here: http://www.stunnel.org/download/binaries.html

If you were using MS Outlook it would be able to do that as there is a plug-in, which effectively has the avast email scanner inside Outlook. I believe the same is true for 'The Bat' email client.
The best things in life are free.

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1883
    • AVAST Software
Re: SMTP port not connecting after updating to Avast Home 4.8
« Reply #7 on: April 21, 2008, 07:40:49 PM »
Hi, have you recently installed Sp1 on your Vista 64 system?

Thanks.

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3869
  • Just an avast user
Re: SMTP port not connecting after updating to Avast Home 4.8
« Reply #8 on: April 21, 2008, 08:12:21 PM »
Quote
I am moving to Gmail and I have tried setting up their smtp server in Avast but no joy yet.

If you do this it will not work and it will definitely prevent the connection.

avast cannot scan any secure connections (and GMail insists on secure connections).  Secure connections are secure to prevent them being scanned (just like your online banking transactions).

It you want GMail scanned then, at present, you have to use STunnel as Tech has advided.  This manages the secure connections to the mail server and then passes the email to/from your mail client (entirely and safely inside your own system) in a way that avast can scan it.

Erroneus

  • Guest
Re: SMTP port not connecting after updating to Avast Home 4.8
« Reply #9 on: April 21, 2008, 09:28:03 PM »
Hi, have you recently installed Sp1 on your Vista 64 system?

Thanks.

The problem were also there before SP1.

Note GMAIl SSL email sending is working fine for me, normal SMTP sending simply stop working sometimes.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67199
Re: SMTP port not connecting after updating to Avast Home 4.8
« Reply #10 on: April 21, 2008, 09:34:46 PM »
Note GMAIl SSL email sending is working fine for me
But avast is not scanning it...

normal SMTP sending simply stop working sometimes.
Which firewall do you use? Any other security program?
The best things in life are free.

Erroneus

  • Guest
Re: SMTP port not connecting after updating to Avast Home 4.8
« Reply #11 on: April 21, 2008, 11:35:03 PM »
Builtin Vista firewall and Windows Defender.

Also today Avast decided that I wasn't allowed to surf any pages in neither Firefox or IE, I had to kill Avast completely...

4.8 has been a disaster and form the look of it on the forums, I'm not the only one with problems, back to betatest ALWIL.

btw. not sure, but my Avast update shortly before i lost my ability to browse.

21-04-2008   23:10:18   1208812218   SYSTEM   1648   The virus database (VPS 080421-1) was automatically updated.
« Last Edit: April 21, 2008, 11:37:57 PM by Erroneus »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67199
Re: SMTP port not connecting after updating to Avast Home 4.8
« Reply #12 on: April 21, 2008, 11:38:41 PM »
4.8 has been a disaster
Not really... I'm using since the first beta and the errors that I've found were correctly immediatly.

Seems your problem could be solved installing the latest beta version.
Download the updater (http://files.avast.com/files/beta/aswbeta.exe) and run it or go here for more information.
The best things in life are free.

DaneBrooke

  • Guest
Re: SMTP port not connecting after updating to Avast Home 4.8
« Reply #13 on: April 22, 2008, 01:42:26 AM »
YES. Identical problem.  My fix was to turn off scan of outgoing mail.  However I did not have any telnet problem....

Online DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 88180
  • No support PMs thanks
Re: SMTP port not connecting after updating to Avast Home 4.8
« Reply #14 on: April 22, 2008, 01:47:38 AM »
You shouldn't have any telnet problem as that uses a different port and protocol and isn't monitored by avast's email scanner.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.9.6082 (build 23.9.8494.792) UI 1.0.781/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security