Author Topic: Avast 4.* update / avast.setup issues  (Read 10476 times)

0 Members and 1 Guest are viewing this topic.

YLNG

  • Guest
Re: Avast 4.* update / avast.setup issues
« Reply #15 on: April 13, 2008, 06:37:53 PM »
I hope this can help

I once have the same problem as they said (system stop responding with just desktop without any icons and task manager).  So I un-install 4.8 in safe mode and go back to 4.7 and I skip several upgrade message for a while.

Yesterday, I finally go back to give it a try and upgrade once again.  But I have it done a little bit difference this time.

1) I don't upgrade from 4.7 pop-up screen.  I un-install 4.7, reboot, use aswclear, reboot and install 4.8
2) Last time, I skip the file scan before windows load up (I can't remember what process it called).  I do it this time although it is really time consuming.  By the way, I just leave the computer on to scan overnight.
3) What I have found in the morning is a trojan in a file name kdbg32.dll.
4) Once I move it and keep scanning.  Windows load up and everything running.  I mean I haven't change any setting or disable module, it just work fine now.

I don't know whether the trojan in kdbg32.dll cause 4.8 to stop working but not 4.7 or aswclear clear things up, I only know I am really happy I can have 4.8 working now. 

Marlon

  • Guest
Re: Avast 4.* update / avast.setup issues
« Reply #16 on: April 13, 2008, 09:53:11 PM »
ok will give this a shot tonight, thank you for your help

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: Avast 4.* update / avast.setup issues
« Reply #17 on: April 13, 2008, 10:44:35 PM »
I don't know whether the trojan in kdbg32.dll cause 4.8 to stop working but not 4.7
I will think the opposite: version 4.8 has a self-defense module and 4.7 is more vulnerable than 4.8. Maybe a new virus database - updated between 4.7 to 4.8 version - is due to this detection.
The best things in life are free.

YLNG

  • Guest
Re: Avast 4.* update / avast.setup issues
« Reply #18 on: April 14, 2008, 07:28:23 AM »
Tech,

   Yes, I believe 4.8 is better and less vulnerable as 4.7 don't catch that trojan when I re-install it.
 
   However, my concern is if it is really some trojan can really lock up my computer, and maybe someday I really be infected similar trojan before virus updates come, then it may be problem as I may have no clue what is wrong when system is just not responding during boot up.  That's why I post this finding and hope if this is really the case, avast team can have something to deal with that, so the system wouldn't just lock up.

   Of course, I can't verify and maybe just a isolated case I have.   

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3866
  • Just an avast user
Re: Avast 4.* update / avast.setup issues
« Reply #19 on: April 14, 2008, 08:21:25 AM »
YLNG,

one of the important changes in avast 4.8 is the new self defense module that will prevent malware from stopping avast from functioning before a VPS update comes along to detect it.

qbuster

  • Guest
Re: Avast 4.* update / avast.setup issues
« Reply #20 on: April 14, 2008, 08:58:16 AM »
There are a lot of newbies here... for each one, please, post the last 200-250 lines of avast log: C:\Program Files\Alwil Software\Avast4\DATA\log\Setup.log

OK, here is a description of what I am experiencing.

1. Each time I bootup, I get a message that my Avast for Home has expired and
offereing me a way to re-register. I do so, following the instructions.
2. When the meail arrives with the new licence key (it is always the same) I
follow the instructions and try to past it into the filed provided - password
is rejected.

3. NOTE: If the invitation to re-register occurs after my Firefox web-browser
has been closed down without closing a tab, the re-register process won't work
because th dialog window sits over the request from Firefox to 'restore or start
a new tab'.

The only way out of this is to destroy the Avast invitation via CTR-ALT-DEL
close all tabs in the Firefox window and re-boot.

I am attaching the setup.log


Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: Avast 4.* update / avast.setup issues
« Reply #21 on: April 15, 2008, 12:13:53 AM »
Can you try if the latest beta version solves this?
Download the updater (http://files.avast.com/files/beta/aswbeta.exe) and run it or go here for more information.
The best things in life are free.