Author Topic: Avast won't scan.  (Read 2940 times)

0 Members and 1 Guest are viewing this topic.

Dark Heart

  • Guest
Avast won't scan.
« on: April 20, 2008, 09:33:05 PM »
I do a scan about twice a week, with avast! home edition 4.8. I just tried to do my scan a few minutes ago and here is what happens:
1. The splash screen freezes when it is testing operating memory and startup items.
2. When I click stop memory scan (or something like that) it is still frozen.
3. I have to go under task manager and click "end task" and then avast! will start.

4. I try to start a scan, like always, but now it just sits there at 0%. It didn't start for 30min, so I tried to close Avast!, and it didn't close.
It eventually did, but very slow.

Last thing I did was manually remove AVG from registry and services, as I was told it was not wise to run it with avast!.

Now, before I resort to reinstall, I need to know what I am dealing with...If this is corruption, I can easily fix that; if it is a virus, then I am screwed.

OS: Vista Home Premium
RAM: 1gb
Manufacturer: Hewlett Packard/COMPAQ
PC age: about 14 months.
Type: Laptop


recent virus removals: WIN32Parite (PE.Parite.AO) - (October, 2007=date last seen)

Any Ideas, or should I reinstall. :-\
« Last Edit: April 20, 2008, 09:35:11 PM by Dark Heart »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67198
Re: Avast won't scan.
« Reply #1 on: April 20, 2008, 11:02:02 PM »
Last thing I did was manually remove AVG from registry and services, as I was told it was not wise to run it with avast!
But did you uninstall AVG before removing manually that items?
The best things in life are free.

Dark Heart

  • Guest
Re: Avast won't scan.
« Reply #2 on: April 21, 2008, 01:34:34 AM »
But did you uninstall AVG before removing manually that items?
When I tried to uninstall AVG from "Programs and features" it said AVG was already uninstalled. I didn't see any program files other than the AVG folder in the Program Files directory. But I still saw AVG in the services list in "Services", so I got rid of them through CMD. They were stopped btw.

I hardly believe that this is the cause, as it was done not-so-recently. I will re-boot first and then come back with the results.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67198
Re: Avast won't scan.
« Reply #3 on: April 22, 2008, 12:19:46 AM »
I hardly believe that this is the cause
Maybe drivers... You can run Autoruns from Microsoft with elevated privileges and remove the AVG drivers entries...

I will re-boot first and then come back with the results.
Hope we could help further then...
The best things in life are free.

Dark Heart

  • Guest
Re: Avast won't scan.
« Reply #4 on: April 22, 2008, 04:58:54 AM »
It was a registry issue, I tried to recover my registry with an incomplete backup .reg that I made and it messed it up, used System Restore to fix it. Thank you.