Author Topic: Network Shield Not Working  (Read 12609 times)

0 Members and 1 Guest are viewing this topic.

Offline ioyuioynx

  • Jr. Member
  • **
  • Posts: 48
Re: Network Shield Not Working
« Reply #15 on: April 18, 2008, 03:53:49 AM »
You need to worry when the counts are not zero and something has been scanned.  avast cannot scan anything that does not get through your firewall (and/or router). 


Well, is there any way to test whether the Network Shield is working?

Unless you can test it, or it gives status updates like what was last checked, etc, to people, its as good as not working.

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: Network Shield Not Working
« Reply #16 on: April 18, 2008, 04:00:49 AM »
If you have a good firewall and/or a router it is pretty much as good as useless.

I never have it on.

If you want to really test it then try running connected directly to the internet without a firewall.   I do not recommend this.
« Last Edit: April 18, 2008, 04:02:36 AM by alanrf »

Offline ioyuioynx

  • Jr. Member
  • **
  • Posts: 48
Re: Network Shield Not Working
« Reply #17 on: April 18, 2008, 04:10:41 AM »
If you have a good firewall and/or a router it is pretty much as good as useless.

I never have it on.

If you want to really test it then try running connected directly to the internet without a firewall.   I do not recommend this.

I'll test it on my wifes Vista Home Premium laptop. Currently, she has the Windows Firewall on, so I'll turn that off and see if Network Shield picks anything up. How long do you think it will take without a firewall for it to start getting attacked?

PS: I have a Netcomm NB6Plus4 ADSL Modem/Router. Would I have to do anything to its settings also? I hope not. I don't really wanna mess with it.

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: Network Shield Not Working
« Reply #18 on: April 18, 2008, 04:41:16 AM »
The router you have will almost certainly prevent anything getting through to be detected by avast.  Your router will probably allow you to turn off the hardware firewall functionality. But ...

Were you one of the users I support I would advise you not to mess with it.  Leave your router alone, your firewall on and forget about the Network Shield.  Yours and your wife's systems will be much safer that way.   
« Last Edit: April 18, 2008, 04:48:11 AM by alanrf »

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: Network Shield Not Working
« Reply #19 on: April 18, 2008, 04:47:36 AM »
By the way ... what is the version of Ad Muncher you are using? 

Given it's description it has to work as avast does too so it is a proxy.  I would like to take a look at it's interaction with avast.

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: Network Shield Not Working
« Reply #20 on: April 18, 2008, 04:53:06 AM »
You may want to take a look at this thread. It looks like a way of getting AdMuncher to work without the need to set up a proxy for avast.


Offline hines232

  • Avast Evangelist
  • Poster
  • ***
  • Posts: 432
  • Love you Kiwi,Wolf and Patches
Re: Network Shield Not Working
« Reply #21 on: April 18, 2008, 05:39:41 AM »
What are we talking about, "Network shield" or "Web shield".------I don't have "Network shield", and I am using the same version he is using. ???
WINDOWS ME, IE6,Opera 10.62 Avast/Home,4.8.1368,WiseRegestry Cleaner,WiseDisk Cleaner,Regseeker,CCleaner, SpywareBlaster 4.2, Tiny Fire Wall, WinPatrol 17.0.2010 0:17.0.2010.0,Hitware Popup Killer Light
Java 1.5.0_22-b01 (All latest updates OS ME can Fathom)

Regards

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: Network Shield Not Working
« Reply #22 on: April 18, 2008, 06:10:17 AM »
We are talking about Network Shield.

It is not available to users of Windows 9x systems (including your Windows Me).

Just by the way ... the box at the top the forum called "Search" is pretty good for finding out the answer to questions like this for yourself.
« Last Edit: April 18, 2008, 06:16:28 AM by alanrf »

Offline ioyuioynx

  • Jr. Member
  • **
  • Posts: 48
Re: Network Shield Not Working
« Reply #23 on: April 18, 2008, 07:45:14 AM »
By the way ... what is the version of Ad Muncher you are using? 

Given it's description it has to work as avast does too so it is a proxy.  I would like to take a look at it's interaction with avast.

The latest version of Ad Muncher, which is Ad Muncher 4.72.30321 Beta.

Offline ioyuioynx

  • Jr. Member
  • **
  • Posts: 48
Re: Network Shield Not Working
« Reply #24 on: April 18, 2008, 07:55:25 AM »
You may want to take a look at this thread. It looks like a way of getting AdMuncher to work without the need to set up a proxy for avast.



Thanks a lot man. I appreciate it.

Offline ioyuioynx

  • Jr. Member
  • **
  • Posts: 48
Re: Network Shield Not Working
« Reply #25 on: April 18, 2008, 08:13:27 AM »
I need a way to test the Web Shield.

Can someone please suggest some sites that does something Web Shield would notice and scream about?

I don't like an idea of relying on something without testing it to see that its working. I'm the tinkering curious type.

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: Network Shield Not Working
« Reply #26 on: April 18, 2008, 08:18:09 AM »
See this site for the perfectly harmless eicar test virus.

http://www.eicar.org/anti_virus_test_file.htm

Offline ioyuioynx

  • Jr. Member
  • **
  • Posts: 48
Re: Network Shield Not Working
« Reply #27 on: April 18, 2008, 08:22:03 AM »
See this site for the perfectly harmless eicar test virus.

http://www.eicar.org/anti_virus_test_file.htm

Thanks, but I was hoping for something a bit stronger...

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: Network Shield Not Working
« Reply #28 on: April 18, 2008, 08:26:08 AM »
Just an aftertought. 

If you did make the change to the avast4.ini file for AdMuncher please remember it.  Just in case .....

When you make your next update to the avast program if you run into any problems with the Webshield then remove that change and see if it solves them.   

I am certainly not saying a problem will occur - I just have some concerns about the way Ad Muncher and avast can tread on each other's toes.

We will still be here to help.   

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11745
    • AVAST Software
Re: Network Shield Not Working
« Reply #29 on: April 18, 2008, 08:26:55 AM »
See this site for the perfectly harmless eicar test virus.

http://www.eicar.org/anti_virus_test_file.htm

Thanks, but I was hoping for something a bit stronger...

Why? (and what is "stronger" anyway?)
avast! will behave the same, no matter if towards Eicar or a real malicious file.