Author Topic: update na  (Read 10816 times)

0 Members and 1 Guest are viewing this topic.

Offline wyrmrider

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1298
update na
« on: May 13, 2008, 11:55:28 PM »
I
I just removed AVG- it was interfering with Earthlink email once again
ran the Antivir regcleaner- 118 items removed including some very old Norten entries
Installed Avast and updated to latest
however I have not been able to get avast update to work today program or virus db
virus database shows yesterday 080512-0

I have zone alarm with permissions checked
DSL
I tried with "always connected" checked and unchecked
any ideas?
thanks
I'd like to update and run a scan

email outgoing is na so I'll try and hand enter smtpauth.earthlink.net sometime later
incoming seems to be working fine

thanks

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83751
  • No support PMs thanks
Re: update na
« Reply #1 on: May 14, 2008, 12:40:02 AM »
What errors were being displayed when unable to update ?
I assume you got a red pop-up at the bottom right of the screen ?
Check the avast! Log Viewer (right click the avast 'a' icon), Error/Warning section, this contains information on all Errors/Warnings you are looking for anything relating to inability to connect to downloadXX.avast.com the XX are numeric values.

Delete the entries for avast.setup in ZA program control sometimes even with permissions the firewall seems to get amnesia and blocks. Now do a manual update, this will force the firewall to ask permission again.

Always connected would be correct for DSL.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline wyrmrider

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1298
Re: update na
« Reply #2 on: May 14, 2008, 01:46:31 AM »
ni
thanks
no red flash no popup  nothing-- tilt
nothing in error /warnings (except a FP for Sysclean.exe which is now in vault)
If I remember Avast usually gives a message that you're current when you're current
I'll dig into za tomorrow
perhaps with the update I missed something
funny because worked as expected during installation
I'll check the box for always connected but I do not think that's it
I did the search for correct proxy settings thingie and it said all ok

hack hack

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83751
  • No support PMs thanks
Re: update na
« Reply #3 on: May 14, 2008, 01:27:22 PM »
OK I'll wait for your feedback and proceed from there.

However, one pre-emptive question, does a manual update work or was this limited to the auto updates ?
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline wyrmrider

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1298
Re: update na
« Reply #4 on: May 14, 2008, 05:43:07 PM »
auto update has not updated since 5-12 installation updates
manual update (from any location) no nothing, no red flash, no pop up
I suppose I can download the whole file
will check za

I removed duplicates from ZA and all update related entries there were four
still no response
I would have expected to be prompted again
access ---both trusted and internet were checked
server ----neither were checked

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83751
  • No support PMs thanks
Re: update na
« Reply #5 on: May 14, 2008, 07:16:31 PM »
I would have expected you to have been asked again if having deleted all avast related entries from the ZA program control.

You could try manually setting the following files, in the avast4 folder, ashWebSv.exe and ashMaiSv.exe and in the avast4\setup folder avast.setup.

You could try a reinstall of avast, but I feel the issue is at ZAs door, so it may be worth reinstalling that ?
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline wyrmrider

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1298
Re: update na
« Reply #6 on: May 14, 2008, 11:14:23 PM »
no ashwebsv.exe so I added manually
I have now
ashserv.exe
setup/avast.setup   which is entitled avast antivirus update 4.8.0.0  no exe
ashmaisv.exe
ashwebsv.exe

still no flash no popup no blink nada
hack at it more later

found this from a previous install which I removed
Product name        avast! Antivirus
File name           C:\Program Files\Alwil Software\Avast4\ashMaiSv.exe
Last policy update  Not applicable
Version             4, 6, 763, 0
Last modified date  1/27/06 15:35:32
File size           236 KB
« Last Edit: May 14, 2008, 11:27:33 PM by wyrmrider »

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83751
  • No support PMs thanks
Re: update na
« Reply #7 on: May 15, 2008, 12:27:02 AM »
The ashServ.exe shouldn't need internet permission, so I don't know why ZA has that in program control.

That is an ancient version of ashwebsv.exe and you found that on your current avast installation ?
Is your current avast installed in the same location C:\Program Files\Alwil Software\Avast4\ ?

If these are correct you have a screwed installation, sorry for getting technical. You need to do a clean reinstall.

Download the latest version of avast http://www.avast.com/eng/download-avast-home.html and save it to your HDD, somewhere you can find it again. Use that when you reinstall.

Download the avast! Uninstall Utility, find it here and save it to your HDD.

Now uninstall (using windows add remove programs), reboot, run the avast! Uninstall Utility, reboot, install the latest version, reboot.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline wyrmrider

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1298
Re: update na
« Reply #8 on: May 15, 2008, 02:04:38 AM »
Im on the same track you are
Product name        avast! Antivirus
File name           C:\Program Files\Alwil Software\Avast4\Setup\avast.setup
Last policy update  Not applicable
Version             4, 6, 0, 0
Last modified date  4/19/06 6:49:04
File size           1864 KB
loaded itself again
must be from the registry as there is NO C:program Files\ Alwill Software

current installation is
Product name        avast! Antivirus
File name           D:\program files\Alwil Software\Avast4\Setup\avast.setup
Last policy update  Not applicable
Version             4, 8, 0, 0
Last modified date  5/12/08 16:30:02
File size           2456 KB


I still have the 20 mb download so I'll run the uninstaller and reinstall

I notice that AVG update and something else reappeared on their own so I'll seek out an Avg uninstaller also
Hmmm
Norton

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83751
  • No support PMs thanks
Re: update na
« Reply #9 on: May 15, 2008, 02:26:50 AM »
Yes you really need to resolve the avast installation in two locations that will really screw things up not jut get ZA in a fit, but the registry keys, device drivers might also be an issue.

So look for two entries for avast in windows add remove programs, whilst there might not be two. When you come to running the uninstall utility you might need to run that twice also as I believe it asks for the location of avast and you have it in two locations. I don't know if it would be best to run it against the old version on C:\Program Files\Alwil Software\Avast4\ before running it against the current installation on D:\Program Files\Alwil Software\Avast4\.

Good luck, that's me for the night my bed is calling, just after 1:30 a.m. here.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline wyrmrider

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1298
Re: update na
« Reply #10 on: May 15, 2008, 02:59:42 AM »
thanks a bunch  hope you had a nice night
however
there is NO
C:\Program Files\Alwil Software\Avast4\

so I guess I'll remove from D:
and reinstall on C:

evidently the old installation was not completly removed with add remove programs
I looked around the registry and did not see any references to the old C: version
gotta be there somewhere


Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re: update na
« Reply #11 on: May 15, 2008, 03:06:03 AM »
If it helps, I suggest an installation from the scratch:

1. Uninstall avast from Control Panel first.
2. Boot.
3. Download the latest version of Avast Uninstall and use it for complete uninstallation.
4. Boot.
5. Install again the latest avast! version.
6. Boot.
7. Check and post the results.
The best things in life are free.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83751
  • No support PMs thanks
Re: update na
« Reply #12 on: May 15, 2008, 02:41:02 PM »
Which is what I suggested in reply #7 ;D
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline wyrmrider

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1298
Re: update na
« Reply #13 on: May 15, 2008, 04:36:30 PM »
Correct DavidR
The question is where to reinstal and which drive to try and run the removal program on
another possibility is to manually Create a
C:\Program Files\Alwil Software\Avast4\
run the removal program with that as the target and see if it finds the old registry entries
last thing I need is remnants of two avast installations
as of now I'll probably run removal tool on both C and D
will not be till 10 hrs from now when I can take the machine down for an extended period of time
Thanks

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83751
  • No support PMs thanks
Re: update na
« Reply #14 on: May 15, 2008, 05:19:46 PM »
It is best to install to the default location which is C:\Program Files\Alwil Software\Avast4\ no need to create the folder that is done by the installation file setupeng.exe, etc.

Whilst there is nothing to stop you from installing to another location (mine is also in the D:\ partition), but given your previous problem with multiple locations I would stick with the default location.

Re Uninstall Utility, I would say it is wise to run it against both locations as the registry keys although relating to different installation they would be in the same registry area and this isn't good if you (read we) are trying to track any issues in the future.

When you have run the uninstall utility and rebooted just check that the physical hard disk locations are gone C:\Program Files\Alwil Software\Avast4\ and D:\Program Files\Alwil Software\Avast4\ they should be.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro