Author Topic: type avastgui brings up warning error  (Read 11162 times)

0 Members and 1 Guest are viewing this topic.

diablo1

  • Guest
type avastgui brings up warning error
« on: May 14, 2008, 05:00:21 AM »
i have opensuse 10.3
when i type avastgui in a terminal i get this warning error in the terminal.
(process 6912):  gdk warning **: local not supported by xlib
(process 6912):  gdk warning **:  can not set locale modifiers
gtk-message: failed to load module "gnomebreakpad"*: libgnomebreakpad.so: can not
open shared object file: no such file or directory.

print screen of warning attached
how can i correct the problem ???

thanks ;)

diablo1

  • Guest
Re: type avastgui brings up warning error
« Reply #1 on: May 14, 2008, 02:50:59 PM »
now im getting another warning pop up

deleted stale lock file '/root/avast/lockfile-root'

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67185
Re: type avastgui brings up warning error
« Reply #2 on: May 14, 2008, 02:55:47 PM »
deleted stale lock file '/root/avast/lockfile-root'
This popup appears when avast process/service was not correctly shutdown.
It should appear only once, on next avast opening and not all the time.
The best things in life are free.

Offline zilog

  • Avast team
  • Advanced Poster
  • *
  • Posts: 957
  • or #f0; daa; add a,#a0; adc a,#40
Re: type avastgui brings up warning error
« Reply #3 on: May 14, 2008, 03:02:55 PM »
now im getting another warning pop up

deleted stale lock file '/root/avast/lockfile-root'

these warning have only informational nature - the first complains about unsupported locales in xlib (check you locale settings - locales -a).
The second one warns about lock that survived from previous run - is this warning deterministic, even when you exit the application from its menu the normal way (= not killing it explicitly)?

regards,
pc
May's Law: Software efficiency halves every 18 months, compensating Moore's Law. (David May, INMOS)

diablo1

  • Guest
Re: type avastgui brings up warning error
« Reply #4 on: May 14, 2008, 03:10:59 PM »
new to linux , have opensuse 10.3
how do i check my locale settings?

and how do i fix it?

thanks

Offline zilog

  • Avast team
  • Advanced Poster
  • *
  • Posts: 957
  • or #f0; daa; add a,#a0; adc a,#40
Re: type avastgui brings up warning error
« Reply #5 on: May 14, 2008, 03:14:10 PM »
new to linux , have opensuse 10.3
how do i check my locale settings?

and how do i fix it?

thanks

type locale -a from your terminal

pc
May's Law: Software efficiency halves every 18 months, compensating Moore's Law. (David May, INMOS)

Offline FreewheelinFrank

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 4871
  • I'm a GNU
    • Don't Surf in the Nude!
Re: type avastgui brings up warning error
« Reply #6 on: May 14, 2008, 03:17:24 PM »
i have opensuse 10.3
when i type avastgui in a terminal i get this warning error in the terminal.
(process 6912):  gdk warning **: local not supported by xlib
(process 6912):  gdk warning **:  can not set locale modifiers
gtk-message: failed to load module "gnomebreakpad"*: libgnomebreakpad.so: can not
open shared object file: no such file or directory.

print screen of warning attached
how can i correct the problem ???

thanks ;)

The same warning appears when launching avastgui in Ubuntu. When launching from the Application>Accessories menu, there is no such problem. In Ubuntu I can launch avast! as root using gksudo avastgui, but the program then prompts for a key, which it doesn't from the menu.

Unfortunately, I couldn't find a good installation guide for Suse. Some comments by a Suse user here may help:

http://forum.avast.com/index.php?topic=30907.msg256907#msg256907
     Bambleweeny 57 sub-meson brain     Don't Surf in the Nude Blog

diablo1

  • Guest
Re: type avastgui brings up warning error
« Reply #7 on: May 14, 2008, 03:25:35 PM »
i typed locale -a and get:

vi_VN
vi_VN.tcvn
wa_BE
wa_BE@euro
wa_BE.utf8
xh_ZA
xh_ZA.utf8
yi_US
yi_US.utf8
zh_CN
zh_CN.gb18030
zh_CN.gbk
zh_CN.utf8
zh_HK
zh_HK.utf8
zh_SG
zh_SG.gbk
zh_SG.utf8
zh_TW
zh_TW.euctw
zh_TW.utf8
zu_ZA
zu_ZA.utf8

what do i do now and whats it mean??

thanks
« Last Edit: May 14, 2008, 03:27:13 PM by diablo1 »

Offline zilog

  • Avast team
  • Advanced Poster
  • *
  • Posts: 957
  • or #f0; daa; add a,#a0; adc a,#40
Re: type avastgui brings up warning error
« Reply #8 on: May 14, 2008, 03:32:20 PM »
i typed locale -a and get:

vi_VN
vi_VN.tcvn
wa_BE
wa_BE@euro
wa_BE.utf8
xh_ZA
xh_ZA.utf8
yi_US
yi_US.utf8
zh_CN
zh_CN.gb18030
zh_CN.gbk
zh_CN.utf8
zh_HK
zh_HK.utf8
zh_SG
zh_SG.gbk
zh_SG.utf8
zh_TW
zh_TW.euctw
zh_TW.utf8
zu_ZA
zu_ZA.utf8

what do i do now and whats it mean??

thanks

type also locale (without -a) - quite safe should be setting it to "POSIX", for english-speaking installations:

zilog@zilog:~$ locale -a
C
POSIX
cs_CZ
cs_CZ.iso88592
czech
zilog@zilog:~$ locale
LANG=POSIX
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=
May's Law: Software efficiency halves every 18 months, compensating Moore's Law. (David May, INMOS)

diablo1

  • Guest
Re: type avastgui brings up warning error
« Reply #9 on: May 14, 2008, 03:37:26 PM »
i got this typing locale
So set it to POSTIX ,how do i set it to POSTIX
YEA for english us

os@os:~> locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Offline zilog

  • Avast team
  • Advanced Poster
  • *
  • Posts: 957
  • or #f0; daa; add a,#a0; adc a,#40
Re: type avastgui brings up warning error
« Reply #10 on: May 14, 2008, 04:40:40 PM »
i got this typing locale
So set it to POSTIX ,how do i set it to POSTIX
YEA for english us

os@os:~> locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=


export LC_ALL=POSIX
or
LC_ALL=POSIX avastgui

... should be enough :). change the locales globally, or use this on-demand change when running avastgui only.

regards,
pc
May's Law: Software efficiency halves every 18 months, compensating Moore's Law. (David May, INMOS)