Author Topic: BOOT TIME SCAN: Error:42003  (Read 30312 times)

0 Members and 1 Guest are viewing this topic.

Offline Steele

  • Full Member
  • ***
  • Posts: 199
  • I won't bite too hard!
    • A World Beyond Imagination!
BOOT TIME SCAN: Error:42003
« on: April 03, 2004, 11:17:03 AM »
Hello:

I'm using the lastest version of avast with the lastest VPS on WinXp Pro SP1a.

This morning, I've been trying to preform a boot-time scan. But when I restart my computer...I get a QUICK BLUE SCREEN FLASH *the point where avast is supposed to load BEFORE XP starts* with Avast beginning to start... and then before it BEGINS to scan, it bypasses the screen, fails the scan... and I'm at the login point for WinXP Pro.

I'm sitting here thinking: WHAT?!  ::)

This has never happened before, and I have performed many boot-time scans in the past.

I ran CHKDSK /F *ran this about 5 times as once never seems to be enough to get rid of errors* and then tried the boot-time scan: Same result... a quick reference to the scan engine starting...and then before it can start... it bypasses and goes directly to the login screen of XP PRO.

I would really like to get this working again... and I'm wondering if anybody else is having this problem?

*sigh*... I thought I could get this going myself.... guess not.  :-\

Kindest regards,
~Steele Wolf~
« Last Edit: April 03, 2004, 08:48:15 PM by Steele »
"A man can tell a thousand lies, I’ve learned my lesson well, Hope I live to tell the secrets I have learned, till then, It will burn inside of me..."

Offline Steele

  • Full Member
  • ***
  • Posts: 199
  • I won't bite too hard!
    • A World Beyond Imagination!
Re:BOOT TIME SCAN: Failure
« Reply #1 on: April 03, 2004, 11:27:42 AM »
08/03/2004 21:49
Scan of all local drives


Number of searched folders: 3038
Number of tested files: 100939
Number of infected files: 0

----------------------------------------
11/03/2004 15:06
Scan of all local drives


Number of searched folders: 3044
Number of tested files: 102027
Number of infected files: 0

----------------------------------------
03/04/2004 01:25

----------------------------------------
03/04/2004 02:01

----------------------------------------
03/04/2004 03:18

----------------------------------------
03/04/2004 04:03

-THESE ARE THE SCANS I TRIED TODAY-> Nothing does get scanned.
"A man can tell a thousand lies, I’ve learned my lesson well, Hope I live to tell the secrets I have learned, till then, It will burn inside of me..."

Offline Steele

  • Full Member
  • ***
  • Posts: 199
  • I won't bite too hard!
    • A World Beyond Imagination!
Re:BOOT TIME SCAN: Failure
« Reply #2 on: April 03, 2004, 11:54:52 AM »
There is some error during the initialization....I can't catch it.  :-\
"A man can tell a thousand lies, I’ve learned my lesson well, Hope I live to tell the secrets I have learned, till then, It will burn inside of me..."

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67247
Re:BOOT TIME SCAN: Failure
« Reply #3 on: April 03, 2004, 04:37:07 PM »
There is some error during the initialization....I can't catch it.  :-\

Steele, remember me some of your configurations...
Did you install NAV before in this system?
Did you try to 'Repair' your avast! installation?
I'm not sure but maybe you have a report or log of the boot time scanning operation... If so, what does it tell us about?
The best things in life are free.

Offline Steele

  • Full Member
  • ***
  • Posts: 199
  • I won't bite too hard!
    • A World Beyond Imagination!
Re:BOOT TIME SCAN: Failure
« Reply #4 on: April 03, 2004, 07:48:49 PM »
Hi Technical  ;D

No.... I have never installed any Norton or McAfee product. I always use Avast4Home.

Where would I find a report or log of the boot time scanning operation? What's the file called?
You mean the log-viewer?

I have not tried repairing the installation.
You do this through Add/Remove Programs in XP Pro right?

~Steele Wolf~
"A man can tell a thousand lies, I’ve learned my lesson well, Hope I live to tell the secrets I have learned, till then, It will burn inside of me..."

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67247
Re:BOOT TIME SCAN: Failure
« Reply #5 on: April 03, 2004, 08:30:25 PM »
Where would I find a report or log of the boot time scanning operation? What's the file called?

Maybe at the 'report' folder of avast installation. I do not know the name of the file, if any, but will be an *.txt file I suppose.

You mean the log-viewer?

No. Report files are different from log. Logs are for errors and Report about activities of the antivirus.

I have not tried repairing the installation.
You do this through Add/Remove Programs in XP Pro right?

Yeah...
The best things in life are free.

Offline Steele

  • Full Member
  • ***
  • Posts: 199
  • I won't bite too hard!
    • A World Beyond Imagination!
Re:BOOT TIME SCAN: Failure
« Reply #6 on: April 03, 2004, 08:38:02 PM »
Technical:

I found this error in a log...there is an error CODE further below...this is what I saw briefly appear before a boot time scan could take.

I have not tried repairing the Avast4Home program...because I want you guys FIRST to be aware of the problem before I sweep it under the rug....that is...if a repair works.  :-\

Woah...  :o Is this what VLK is wanting?? I just saw that thread about 42003 errors.
============
CreateKbThread
new CKbBuffer
CKbBuffer::Init
CKbBuffer::Init end
ZwCreateEvent(g_hStopEvent)
ZwAllocateVirtualMemory - stack
ZwGetContextThread - NtCurrentThread
ZwCreateThread - KbThread
CreateKbThread end
ZwInitializeRegistry
KbThread start
Unschedule
Unschedule end
ZwSetEvent(g_hInitEvent)
ReadRegistry
ReadRegistry end
CreateTemp
CreateTemp end
cmnbInit
SetFolders
SetFolders end
aswEnginDllMain(DLL_PROCESS_ATTACH)
InitLog
InitKeyboard
s_dwKbdClassCnt: 2
InitKeyboard end
GetKey
InitLog end
InitReport
InitReport end
CmdLine
C:\PROGRA~1\ALWILS~1\Avast4\aswBoot.exe /A:"*" /L:"English"  
CmdLine end
ZwCreateDirectoryObject - ASWObjects
LoadResources
LoadFile
LoadFile end
LoadResources end
CKbBuffer::Wait
CKbBuffer::Get
CKbBuffer::Get end
CKbBuffer::Wait end
FreeMemory: 471433216
aswintegInitialize
avworkInitialize
0, 29, 4, 0, 0
GetKey end
CKbBuffer::Put
CKbBuffer::Put end
GetKey
0, 69, 0, 0, 0
GetKey end
CKbBuffer::Put
CKbBuffer::Put end
GetKey
0, 29, 5, 0, 0
0, 69, 1, 0, 0
avworkInitialize Error:42003 <---- there it is   :-\
aswintegClose
TerminateKbThread
GetKey end
CloseKeyboard
CloseKeyboard end
KbThread stop
CKbBuffer::~CKbBuffer
CKbBuffer::~CKbBuffer end
aswEnginDllMain(DLL_PROCESS_DETACH)
FreeResources
CloseReport
CloseLog
« Last Edit: April 03, 2004, 08:44:24 PM by Steele »
"A man can tell a thousand lies, I’ve learned my lesson well, Hope I live to tell the secrets I have learned, till then, It will burn inside of me..."

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67247
Re:BOOT TIME SCAN: Failure
« Reply #7 on: April 03, 2004, 08:48:30 PM »
Sorry, you need an advice from a programmer... It's out of my domain. I cannot help you anymore in this trouble because I do not know how to interpret the error 42003. I have numberer errors  :(
The best things in life are free.

Offline Steele

  • Full Member
  • ***
  • Posts: 199
  • I won't bite too hard!
    • A World Beyond Imagination!
Re:BOOT TIME SCAN: Error:42003
« Reply #8 on: April 03, 2004, 08:50:40 PM »
Okay... thanks anyways.  :)

I don't get this code when performing a FULL+ARCHIVE scan from within XP Pro.... only at boot time.

~Steele Wolf~
"A man can tell a thousand lies, I’ve learned my lesson well, Hope I live to tell the secrets I have learned, till then, It will burn inside of me..."

Offline vinbob

  • Newbie
  • *
  • Posts: 8
  • www.nethomehelp.co.uk
    • Nethomehelp
Re:BOOT TIME SCAN: Error:42003
« Reply #9 on: April 03, 2004, 09:37:26 PM »
Hi peeps...

I've started to get the same error on a scheduled boot-scan.
The only recent software changes to my system that might have affected Avast is that I've removed Mozilla Thunderbird.. Although it may be unrelated as I havent scheduled a boot-scan for a while.

OS : Windows XP SP1 - no updates since the last successful boot-scan.
Email : MS Outlook 2002
File System : NTFS

I've uninstalled Avast & then cleaned out any remaining avast related folders and regkeys, then after a reboot, reinstalled Avast entered my reg-code and updated the defs.
No change!

All other Avast features works a treat...

This is doing my head in, I too only ever use Avast anti-virus, I would never have Norton's bloatware on my PC....

Ideas anyone?

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:BOOT TIME SCAN: Error:42003
« Reply #10 on: April 03, 2004, 10:28:17 PM »
Hmm,

Quote
....
....
[bunch of some really weird stuff]
....
....
avworkInitialize Error:42003


That's not very good I gotta say... 42003 means something like 'general failure' or in other words: 'something went really wrong' (to put politely). First, let me check if it happens in our labs... Unfortunately, no sooner than on Monday - as boot-time scanning is one of very few things I can't try via remote access...  :-\

Anyway thanks a lot for your report!

Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Steele

  • Full Member
  • ***
  • Posts: 199
  • I won't bite too hard!
    • A World Beyond Imagination!
Re:BOOT TIME SCAN: Error:42003
« Reply #11 on: April 03, 2004, 10:37:36 PM »
Hi VLK... thank you so much for appearing on a Saturday!  ;D

I can't send you any file because...the error does not appear to be generated by a bad file....rather the engine.

It still happens if I un-check archives.
Oh well... everything still works.

I'm going to CHKDSK /F /V then defrag using Diskeeper 8 Pro.
"A man can tell a thousand lies, I’ve learned my lesson well, Hope I live to tell the secrets I have learned, till then, It will burn inside of me..."

Offline Bagmaster50

  • Newbie
  • *
  • Posts: 17
  • A stupid question is the 1 that's never asked!
    • Michael's PC CPR
Re:BOOT TIME SCAN: Error:42003
« Reply #12 on: April 04, 2004, 03:16:10 AM »
Yea, I'm getting  aboot time scan error too.
08.02.2004 17:03:47   NT AUTHORITY\SYSTEM   1656   AAVM - scanning error: x_AavmCheckBootDirectEx: avscanScanReal of *BOOTA failed, 00000005.  This is on Windows XP Pro SP1 and all updates current. I've been able to schedule boot time scans before sucessfully until today.

Offline Bagmaster50

  • Newbie
  • *
  • Posts: 17
  • A stupid question is the 1 that's never asked!
    • Michael's PC CPR
Re:BOOT TIME SCAN: Error:42003
« Reply #13 on: April 04, 2004, 04:24:47 AM »
Well, I may ahve fixed my problem. I uninstalled Avast and reinstalled it. It did a preboot scan just fine. I did have to reregister though after running the updates for the dat files and the program, Waiting for new key in email now.

Offline chameleon

  • Full Member
  • ***
  • Posts: 164
Re:BOOT TIME SCAN: Error:42003
« Reply #14 on: April 04, 2004, 04:26:53 AM »
I've got the same problem too. The only change I have made recently is to install Spybot from download.com and also to stop and restart system restore to clear out a potential virus.

I hope we figure it out soon. Keep us posted on your end. cheers!   :-\