Author Topic: server edition and ADNM on same server having issues  (Read 8179 times)

0 Members and 1 Guest are viewing this topic.

ronhume

  • Guest
server edition and ADNM on same server having issues
« on: June 20, 2008, 08:12:53 AM »
Hi,

Using ADNM to manage corporate-wide avast install.  Started with deploying server edition to 2 servers (both Windows Server 2003).

Used the 'deploy installation package to remote machines' option and selected a) the server ADNM is installed on and b) another server.

Weird thing is - the other server install seemed to work fine - server edition installed fine and is talking to ADNM, etc.

Server install on same server ADNM is installed on is having issues.  Seems to be running, but not talking to ADNM.

Tried uninstalling server edition on this server and using 'create msi' method, and running that manually - same result.

Have ADNM 4.7.657 and avast server edition 4.7.820.

When I start the GUI for the managed avast I get this error message (dont know if its related to the failure to talk to ADNM or not but its the only error message/log I can find).

Initialization of chest files.  Action was completed with errors.
On next tab it says:
Program cannot use Chest client: (null)
--->Description: Virus chest server is not running. RPC communication failed.

Please help. 

Would like to know:
a) how to clear up this RPC communication error.  The server has no firewall running.
b) how to get server edition talking to ADNM when they are on the same server.
c) if there are additional logs/traces that I could/should post to get better chance of getting this resolved.

Thanks,
Ron.

Offline Infratech Solutions

  • Avast Reseller
  • Massive Poster
  • *
  • Posts: 2425
  • Mayorista e integrador de Avast en España
    • Ciberseguridad Avast para empresas y MSPs en España.
Re: server edition and ADNM on same server having issues
« Reply #1 on: June 20, 2008, 01:34:52 PM »
Hi,

I have the same scenario as you working in several customers. The AMS server has avast! NetServer install on it an working.

I only can suggest you to reboot the server after install the avast! NetServer on your system.

 ;)

ronhume

  • Guest
Re: server edition and ADNM on same server having issues
« Reply #2 on: June 20, 2008, 05:35:13 PM »
Thanks for the info - I figured it worked for most people just not sure why its not working for me.

Rebooting was the first thing I tried - it did not change the symptoms.

I did find more logs though.

Here's a snippet.  I hope someone sees a pattern and can help.

6/20/2008   3:31:00 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
6/20/2008   3:28:28 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
6/20/2008   3:26:16 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
6/20/2008   3:25:10 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
6/20/2008   3:23:28 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
<snip>
6/20/2008   3:23:09 AM   avast!   Information   Client    90   N/A   SERVER   VRDB (Virus Recovery Database) generation was successfully completed. 
6/20/2008   3:13:34 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
<snip>
6/20/2008   2:23:23 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
6/20/2008   2:22:42 AM   avast!   Information   Client    90   N/A   SERVER   avast! engine started. 
6/20/2008   2:22:42 AM   avast!   Information   Client    90   N/A   SERVER   PVS: Starting server. 
6/20/2008   2:22:34 AM   avast!   Information   Client    90   N/A   SERVER   "Installer information: *: Going to check version of database of avast! on MS SQL Server ""SERVER"", using user ""sa""...   "
6/20/2008   2:22:22 AM   avast!   Information   Client    90   N/A   SERVER   "Installer information: *: Going to check connection to MS SQL Server ""SERVER"", using user ""sa""...   "
6/20/2008   2:18:00 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
6/20/2008   2:16:48 AM   avast!   Error   (8)   90   N/A   SERVER   aswChestInterface - Program error description: CChestListView::OnCreate() !m_strErrorWnd.IsEmpty(). 
6/20/2008   2:16:42 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
<snip>
6/20/2008   2:09:59 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
6/20/2008   2:08:04 AM   avast!   Error   (8)   90   N/A   SERVER   aswChestInterface - Program error description: CChestListView::LoadFiles() chestOpenList() failed: 2147422219. 
6/20/2008   2:08:04 AM   avast!   Error   (8)   90   N/A   SERVER   Error in aswChestC: chestOpenList Error 1753. 
6/20/2008   2:08:04 AM   avast!   Information   (8)   90   N/A   SERVER   User executed avast component Enhanced UI. 
6/20/2008   2:07:59 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
6/20/2008   2:06:34 AM   avast!   Error   (8)   90   N/A   SERVER   aswChestInterface - Program error description: CChestListView::OnCreate() !m_strErrorWnd.IsEmpty(). 
6/20/2008   2:05:35 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
<snip>
6/20/2008   1:50:03 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
6/20/2008   1:48:43 AM   avast!   Error   (8)   90   N/A   SERVER   aswChestInterface - Program error description: CChestListView::LoadFiles() chestOpenList() failed: 2147422219. 
6/20/2008   1:48:43 AM   avast!   Error   (8)   90   N/A   SERVER   Error in aswChestC: chestOpenList Error 1753. 
6/20/2008   1:48:43 AM   avast!   Information   (8)   90   N/A   SERVER   User executed avast component Enhanced UI. 
6/20/2008   1:47:53 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
6/20/2008   1:45:17 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
6/20/2008   1:44:07 AM   avast!   Error   (8)   90   N/A   SERVER   aswChestInterface - Program error description: CChestListView::OnCreate() !m_strErrorWnd.IsEmpty(). 
6/20/2008   1:43:54 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
6/20/2008   1:43:38 AM   avast!   Error   (8)   90   N/A   SERVER   aswChestInterface - Program error description: CChestListView::LoadFiles() chestOpenList() failed: 2147422219. 
6/20/2008   1:43:38 AM   avast!   Error   (8)   90   N/A   SERVER   Error in aswChestC: chestOpenList Error 1753. 
6/20/2008   1:41:48 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
6/20/2008   1:41:18 AM   avast!   Error   Client    90   N/A   SERVER   Unable to start avast! Antivirus service, error 00000433 has occured 
6/20/2008   1:41:18 AM   avast!   Error   Client    90   N/A   SERVER   avast! Antivirus service is not running, computer is not protected. The agent is now starting the service. 
6/20/2008   1:40:50 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
6/20/2008   12:33:22 AM   avast!   Information   Client    90   N/A   SERVER   avast! engine started. 
6/20/2008   12:33:22 AM   avast!   Information   Client    90   N/A   SERVER   PVS: Starting server. 
6/20/2008   12:33:14 AM   avast!   Information   Client    90   N/A   SERVER   "Installer information: *: Going to check version of database of avast! on MS SQL Server ""SERVER"", using user ""sa""...   "
6/20/2008   12:33:07 AM   avast!   Information   Client    90   N/A   SERVER   "Installer information: *: Going to check connection to MS SQL Server ""SERVER"", using user ""sa""...   "
6/20/2008   12:29:14 AM   avast!   Error   Client    90   N/A   SERVER   "Storage query ""INSERT INTO LocalEvents (Event, ObjectName, ObjectId, Param1, Param2, GenTime) VALUES (-2113919085, '', 0, '0x7FFF0021', '0', 1213936154);"" failed. Error description: ""unable to open database file [14]"".  "
6/20/2008   12:29:14 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
6/20/2008   12:29:14 AM   avast!   Error   Client    90   N/A   SERVER   "Storage query ""INSERT INTO LocalEvents (Event, ObjectName, ObjectId, Param1, Param2, GenTime) VALUES (1107296346, '', 0, 'Looked up an AMS: 192.168.42.10:16111.', '', 1213936154);"" failed. Error description: ""unable to open database file [14]"".  "
6/20/2008   12:29:14 AM   avast!   Information   Client    90   N/A   SERVER   Looked up an AMS: 192.168.42.10:16111. 
6/20/2008   12:27:08 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
6/20/2008   12:25:14 AM   avast!   Warning   Client    90   N/A   SERVER   POP from server failed [0x7FFF0021, res timestamp: 0]. 
<etc...>


ronhume

  • Guest
Re: server edition and ADNM on same server having issues
« Reply #3 on: June 21, 2008, 06:00:43 PM »
I have researched the error messages and found that 0xffff0021 means 'not enough licenses'? 

I have enough server and client licenses for the entire company and I have only installed 2 server licenses as a test.  Seems the test is failing...

Does anyone have a suggestion that might help?  I'm sure this is something silly that I did wrong.

Thanks,
Ron.


ronhume

  • Guest
Re: server edition and ADNM on same server having issues
« Reply #4 on: June 21, 2008, 06:01:59 PM »
oops.  meant 0x7FFF0021...not 0xFFFF0021.

Ron.

ronhume

  • Guest
Re: server edition and ADNM on same server having issues
« Reply #5 on: July 12, 2008, 08:49:46 PM »
After 3 weeks of no useful answers from support, I figured it out.

Licenses are handed out to DISCOVERED devices not INSTALLED devices. 

I was doing a test install with a small number of licenses.  I ran a discover on my network, found all my computers (which currently run another vendor's software - but I was going to switch slowly to Avast) but only deployed to 2 machines.  One of those machines couldn't get a license because this crap hands out licenses to discovered machines - even if they don't have Avast installed.

There's a quality design decision.

anyway - others struggling with this issue - that was my answer.  Don't bother asking tech support - I got 2 emails over the course of 3 weeks.  Both useless.

Ron.