Author Topic: Proxy Server Settings?  (Read 3514 times)

0 Members and 1 Guest are viewing this topic.

Offline lakrsrool

  • Advanced Poster
  • **
  • Posts: 712
  • Get the Picture !
Proxy Server Settings?
« on: July 09, 2008, 08:24:41 PM »
I have one Internet Service provider (ISP) that works with the connection "Proxy Settings" for WIN98SE to get the Web Shield to work but I have another ISP that does not work with either IE6 or FF2 browsers with the same connection "Proxy Settings" set the same exact way.  The alternate ISP is free and thus offers no support.

Neither browser will get any web pages with the alternate ISP set to "proxy settings" for address: "localhost" port: "12080".


"unable to connect to server" error (white page)

The connection was reset
The connection to the server was reset while the page was loading.
    *   The site could be temporarily unavailable or too busy. Try again in a few
    *   If you are unable to load any pages, check your computer's network
    *   If your computer or network is protected by a firewall or proxy, make   
          sure that Firefox is permitted to access the Web.

It is interesting that FF2 gives this "odd" error saying "connection was reset".

As it turns out:

For Interenet Explorer (IE6) I can set the connection settings seperately for each individual ISP so I can leave my primary ISP set to the "proxy settings" for the Web Shield to work and I can set the alternate ISP without the "proxy settings" so that at least the IE6 browser will work but WITHOUT WEB SHIELD PROTECTION.

But for Firefox (FF2) I cannot set each connection seperately because the browser does not allow for this.  FF2 only has a setting for ALL connections.

The lead to my question is this:

In the FF2 broswer there is a setting for "No proxy for" and the user can enter addresses.

What I find odd is that I already have (it was already set this way) "localhost," in that box (field) for "No proxy for".... yet this is what I have the "proxy settings" for as well and the Web Shield works.  ???

I would have presumed that this setting would be if the user wanted to "ignore" the proxy setting.  But the Web Shield still works with this setting for "No proxy for" that I have in my FF2 browser with one of the two ISP's (but not both).... so I have to assume that this is NOT what it appears to be since the "proxy setting" is WORKING since the Web Shield works for FF2 with one of the two (not both) ISP's with the "Proxy setting" set to "localhost" and port "12080".

I am very confused about all of this and FF2 has no help on this?

Anyway I tried adding the DNS addresses that the alternate ISP uses (that doesn't work) in the "No proxy for" box thinking maybe the "No proxy for" was ignoring the settings for "localhost" since it was "checked" above in the connections settings and anything else would be ignored.  But it didn't help with the DNS addresses for the alternate ISP put in this box for "No proxy for" since I still got the same odd error "connection was reset" anyway for FF2.

So bottom line
: it would seem that I can only use the IE6 with my alternate ISP (since IE6 can set each ISP seperately) and I cannot use FF2 at all with my alternate ISP.  And of course IE6 will NOT have Web Shield protection with my alternate ISP since it has to be set without the Proxy setting to work.

Now my question is:
What in the world is this "No proxy for" setting (FF2) supposed to do anyway?

It (No proxy setting) has "localhost" in it now yet the "Proxy setting" with "localhost" set still does cause the Web Shield to work if it is "checked" and to not work if it is "unchecked" regardless of the fact these same values are in the "No proxy for" setting.  The IE also has a "do not use proxy server with addresses that begin with:" setting but I have nothing in this box.

In the case of the ISP that DOES WORK: It certainly looks like FF2 is "ignoring" the "No proxy for" setting I have (I did not enter these values they were already there) if the purpose of this setting is what it would appear to be since the browser would have to be using the "proxy setting" for "localhost" anyway since the Web Shield is working even though the value "localhost" is also in the "No proxy for" setting (for the one ISP) ???

Is this setting just not working in FF2?... it would really be nice if FF2 support or for that matter any software support would offer more info than they typically do.

Really confused.... Thanks in advance.  :)

« Last Edit: July 10, 2008, 04:53:34 PM by lakrsrool »
Processor: i3 2.53 GHz 4 GIG RAM, OS: WIN 7, Connection: High Speed, Virus/Malware Protection: Avast-2015, SpywareBlaster, Windows Firewall & Defender. Email: Outlook 2010 w/ POP Peeper Email Notifiers.